summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-08-28 00:41:10 +0200
committerManuel Rüger <mrueg@gentoo.org>2015-08-28 00:41:10 +0200
commita4c003bfde98170f1cc38a57be427690edcb878c (patch)
treeed4330d13d93dc82206b9d81c3afb08684801121 /net-print/foomatic-db/foomatic-db-4.0.20150819.ebuild
parentdev-haskell: mark packages as bundled with dev-lang/ghc-7.10.2-r1 (diff)
downloadgentoo-a4c003bfde98170f1cc38a57be427690edcb878c.tar.gz
gentoo-a4c003bfde98170f1cc38a57be427690edcb878c.tar.bz2
gentoo-a4c003bfde98170f1cc38a57be427690edcb878c.zip
net-print/foomatic-db: Version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-print/foomatic-db/foomatic-db-4.0.20150819.ebuild')
-rw-r--r--net-print/foomatic-db/foomatic-db-4.0.20150819.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-print/foomatic-db/foomatic-db-4.0.20150819.ebuild b/net-print/foomatic-db/foomatic-db-4.0.20150819.ebuild
new file mode 100644
index 000000000000..d722328a74ab
--- /dev/null
+++ b/net-print/foomatic-db/foomatic-db-4.0.20150819.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit versionator
+
+DESCRIPTION="Printer information files for foomatic-db-engine to generate ppds"
+HOMEPAGE="http://www.linuxprinting.org/foomatic.html"
+SRC_URI="http://www.openprinting.org/download/foomatic/${PN}-$(replace_version_separator 2 -).tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ net-print/foomatic-db-engine
+ !net-print/foo2zjs[hp2600n]"
+
+S="${WORKDIR}/${PN}-$(get_version_component_range 3 ${PV})"
+
+src_prepare() {
+ # ppd files do not belong to this package
+ rm -r db/source/PPD || die
+}
+
+src_configure() {
+ econf \
+ --disable-gzip-ppds \
+ --disable-ppds-to-cups
+}
+
+src_install() {
+ default
+ rmdir "${ED}"/usr/share/foomatic/db/source/PPD || die
+ # Avoid collision with foo2zjs, bug 185486
+ rm "${ED}"/usr/share/foomatic/db/source/{driver/foo2{hp,lava,xqx,zjs}.xml,printer/{Generic-ZjStream_Printer,HP-{Color_LaserJet_{1500,1600,2600n},LaserJet_{10{00,05,18,20,22},M1005_MFP}},Minolta-{Color_PageWorks_Pro_L,magicolor_2{20,30,43}0_DL},Samsung-CLP-{3,6}00}.xml} || die
+}