summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-10-16 09:42:09 +0100
committerJames Le Cuirot <chewi@gentoo.org>2021-10-16 09:42:09 +0100
commita13aef3f18414766ef5452ccc8198e067c7dcfe4 (patch)
treed66260cffa9a94652ba39c56ba2764ae68fa3909 /net-print/hplip-plugin
parentdev-libs/angelscript: Drop old 2.34.0 (diff)
downloadgentoo-a13aef3f18414766ef5452ccc8198e067c7dcfe4.tar.gz
gentoo-a13aef3f18414766ef5452ccc8198e067c7dcfe4.tar.bz2
gentoo-a13aef3f18414766ef5452ccc8198e067c7dcfe4.zip
net-print/hplip-plugin: Version bump to 3.21.8
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'net-print/hplip-plugin')
-rw-r--r--net-print/hplip-plugin/Manifest1
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.21.8.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index e06eb63eb4e6..3baee2c5fbd4 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1,2 +1,3 @@
DIST hplip-3.20.11-plugin.run 11514293 BLAKE2B b3b7698a45e5e68a25ec1216e736484d26546b657f4a519a153acf0280847667e7ca81afc988f722668746281857d51d9e1703857514ffe5b57dea85f2bae4d3 SHA512 9075c1ac8e8f6e12d33b81b633025259f54352ea00271eec07ee898fd9a164445519608fc9ea61a7157845a4a03f87c28f486c7994f0d7db81d11d3fe51f1876
DIST hplip-3.21.6-plugin.run 11514013 BLAKE2B 3ce0aea3642579838fc683a26a2ef16ce3477b3b664487764895504d1f488fa1246ece0ee19889403e6f22f18ebbe16a7ccd689ae6bbc48197179365dbeb672d SHA512 aa5620687a4b3ac1ff4c8278ac8d51bb38cedf6ea79782bd7c11e71beb0fe75672761874f271ff33e73a394f2a3aa04e1976455688b0f850b57ad7bc1eea3af8
+DIST hplip-3.21.8-plugin.run 11513942 BLAKE2B cbc5614b28a2032ade7fe9906ba5e93c773129121c5b6be950d8d04fd3edeaa97224cee6db4db72fbee6312151d4340b54c04753d03fea36a1772c961a3a0eba SHA512 5042e210d9c084e73a971d605a2eee5e96f2309101859fca09efbd09d60b6ae4959e54cdb334589f36a7aea16fb9eb23eb02bf2b330fab2e4c5a710cb0ec55e1
diff --git a/net-print/hplip-plugin/hplip-plugin-3.21.8.ebuild b/net-print/hplip-plugin/hplip-plugin-3.21.8.ebuild
new file mode 100644
index 000000000000..66a474795496
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.21.8.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing/plugins"
+SRC_URI="https://developers.hp.com/sites/default/files/hplip-${PV}-plugin.run"
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="orblite"
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/udev
+ orblite? (
+ media-gfx/sane-backends
+ >=sys-libs/glibc-2.26
+ virtual/libusb:0
+ )
+"
+DEPEND=""
+
+S=${WORKDIR}
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PREBUILT="${HPLIP_HOME}/*.so"
+
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+src_install() {
+ local hplip_arch
+ case "${ARCH}" in
+ amd64) hplip_arch="x86_64" ;;
+ arm) hplip_arch="arm32" ;;
+ arm64) hplip_arch="arm64" ;;
+ x86) hplip_arch="x86_32" ;;
+ *) die "Unsupported architecture." ;;
+ esac
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ bb_orblite-*)
+ use orblite || continue
+ plugin_type=scan ;;
+ bb_*)
+ plugin_type=scan ;;
+ fax_*)
+ plugin_type=fax ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ insinto /var/lib/hp
+ newins - hplip.state <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}