summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2021-08-19 19:55:59 +0200
committerDaniel Pielmeier <billie@gentoo.org>2021-08-19 19:57:00 +0200
commit0a903472c995423a13b64f1392d0948920566746 (patch)
tree88f00a41c6aece7de68687042c3e49c6b55f1c75 /net-print/hplip
parentdev-python/flexmock: add 0.10.6, fix for borgmatic (diff)
downloadgentoo-0a903472c995423a13b64f1392d0948920566746.tar.gz
gentoo-0a903472c995423a13b64f1392d0948920566746.tar.bz2
gentoo-0a903472c995423a13b64f1392d0948920566746.zip
net-print/hplip: PYTHON_MULTI_USEDEP -> PYTHON_USEDEP V2.
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
Diffstat (limited to 'net-print/hplip')
-rw-r--r--net-print/hplip/hplip-3.21.6.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/net-print/hplip/hplip-3.21.6.ebuild b/net-print/hplip/hplip-3.21.6.ebuild
index 84ae3994756d..e3f7c820026e 100644
--- a/net-print/hplip/hplip-3.21.6.ebuild
+++ b/net-print/hplip/hplip-3.21.6.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8,9} )
PYTHON_REQ_USE="threads(+),xml"
# 14 and 15 spit out a lot of warnings about subdirs
@@ -51,19 +51,19 @@ RDEPEND="
${COMMON_DEPEND}
app-text/ghostscript-gpl
!minimal? (
- $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]' 'python3*')
+ $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]' 'python3*')
kernel_linux? ( virtual/udev )
$(python_gen_cond_dep '
- >=dev-python/dbus-python-1.2.0-r1[${PYTHON_MULTI_USEDEP}]
- dev-python/distro[${PYTHON_MULTI_USEDEP}]
- fax? ( dev-python/reportlab[${PYTHON_MULTI_USEDEP}] )
+ >=dev-python/dbus-python-1.2.0-r1[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ fax? ( dev-python/reportlab[${PYTHON_USEDEP}] )
qt5? (
- >=dev-python/PyQt5-5.5.1[dbus,gui,widgets,${PYTHON_MULTI_USEDEP}]
- libnotify? ( dev-python/notify2[${PYTHON_MULTI_USEDEP}] )
+ >=dev-python/PyQt5-5.5.1[dbus,gui,widgets,${PYTHON_USEDEP}]
+ libnotify? ( dev-python/notify2[${PYTHON_USEDEP}] )
)
scanner? (
- >=dev-python/reportlab-3.2[${PYTHON_MULTI_USEDEP}]
- >=dev-python/pillow-3.1.1[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/reportlab-3.2[${PYTHON_USEDEP}]
+ >=dev-python/pillow-3.1.1[${PYTHON_USEDEP}]
X? (
|| (
kde? ( kde-misc/skanlite )