summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-02-19 23:03:59 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-02-19 23:04:44 +0100
commit7c012a14c2f42d769e52d2bf0d3b5596856ce252 (patch)
tree5a69773d05802be9d10479adce31fc1c0bc66059 /net-print/poster/poster-20060221-r2.ebuild
parentsci-geosciences/qgis: Fix build with sip-4.19 (diff)
downloadgentoo-7c012a14c2f42d769e52d2bf0d3b5596856ce252.tar.gz
gentoo-7c012a14c2f42d769e52d2bf0d3b5596856ce252.tar.bz2
gentoo-7c012a14c2f42d769e52d2bf0d3b5596856ce252.zip
net-print/poster: Add patch for bug 471238
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-print/poster/poster-20060221-r2.ebuild')
-rw-r--r--net-print/poster/poster-20060221-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-print/poster/poster-20060221-r2.ebuild b/net-print/poster/poster-20060221-r2.ebuild
new file mode 100644
index 000000000000..8d5076042531
--- /dev/null
+++ b/net-print/poster/poster-20060221-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Small utility for making a poster from an EPS file or a one-page PS document"
+SRC_URI="mirror://kde/printing/${P}.tar.bz2"
+HOMEPAGE="https://printing.kde.org/downloads"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix_gs_crash.patch"
+ "${FILESDIR}/${P}-fix_duplicate_DocumentMedia.patch"
+)
+
+src_compile(){
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} ${PN}.c -lm -o ${PN} || die
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc README ChangeLog
+}