summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-11-21 21:32:50 +0000
committerJames Le Cuirot <chewi@gentoo.org>2022-11-21 21:32:50 +0000
commit0e0c50026c4054fc33bec90a4e868b596ec7bc6d (patch)
tree988eb0ad39812359ee07e197903af93e1a8a01ef /net-print
parentdev-cpp/asio: add 1.24.0 (diff)
downloadgentoo-0e0c50026c4054fc33bec90a4e868b596ec7bc6d.tar.gz
gentoo-0e0c50026c4054fc33bec90a4e868b596ec7bc6d.tar.bz2
gentoo-0e0c50026c4054fc33bec90a4e868b596ec7bc6d.zip
net-print/hplip-plugin: Version bump to 3.22.10
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/hplip-plugin/Manifest1
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.22.10.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index 37a09c3cb9e8..d89bdf6a6cb1 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1 +1,2 @@
+DIST hplip-3.22.10-plugin.run 11494258 BLAKE2B c9cca80349af4f04f1b1d055083fea451d079a08179fe29fb8ca056c76a36847a58cdc526080d16620a7ab7b8650ccc46f15b3a63447964a6f6006e54b316905 SHA512 dfedc343898fb7b9e951de9a09578627b208f7d0652666eb05d5926ad3ec220bd049d6bee1fb211c72f2e484925e48a665c3133aeeca9d19032fd95e0c3711fa
DIST hplip-3.22.6-plugin.run 11493966 BLAKE2B 9346625c665c25c5c065462269fba4764ef6728a5a351fc0ca81d5fbd3af41185d18cbee88bc9ae0c40909ed1dd412c5f53486676daf0459b79a612c7d65c257 SHA512 6eafe71f88a012bc95ecdf5bf70756e08074208964183b057f299167030b9d228c934c08955c400333b88b46d7d55ed25eb0792a8ed24b4df97a61dddca64585
diff --git a/net-print/hplip-plugin/hplip-plugin-3.22.10.ebuild b/net-print/hplip-plugin/hplip-plugin-3.22.10.ebuild
new file mode 100644
index 000000000000..54c789992915
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.22.10.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing/plugins"
+SRC_URI="https://developers.hp.com/sites/default/files/hplip-${PV}-plugin.run"
+S="${WORKDIR}"
+
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="orblite"
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/udev
+ orblite? (
+ media-gfx/sane-backends
+ >=sys-libs/glibc-2.26
+ virtual/libusb:0
+ )
+"
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PREBUILT="${HPLIP_HOME}/*.so"
+
+src_install() {
+ local hplip_arch plugin
+ case "${ARCH}" in
+ amd64) hplip_arch="x86_64" ;;
+ arm) hplip_arch="arm32" ;;
+ arm64) hplip_arch="arm64" ;;
+ x86) hplip_arch="x86_32" ;;
+ *) die "Unsupported architecture." ;;
+ esac
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ bb_orblite-*)
+ use orblite || continue
+ plugin_type=scan ;;
+ bb_*)
+ plugin_type=scan ;;
+ fax_*)
+ plugin_type=fax ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ insinto /var/lib/hp
+ newins - hplip.state <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}