summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-12 04:55:28 +0000
committerSam James <sam@gentoo.org>2021-06-12 04:55:28 +0000
commit1e79b14e58f43ec8074889ce0b42d8fe03e6f93c (patch)
tree7b0e269983ff070d0a82d60482375cb0616731b9 /net-print
parentapp-benchmarks/ioping: add 1.2 (diff)
downloadgentoo-1e79b14e58f43ec8074889ce0b42d8fe03e6f93c.tar.gz
gentoo-1e79b14e58f43ec8074889ce0b42d8fe03e6f93c.tar.bz2
gentoo-1e79b14e58f43ec8074889ce0b42d8fe03e6f93c.zip
net-print/cups-filters: add 1.28.8
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/cups-filters/Manifest1
-rw-r--r--net-print/cups-filters/cups-filters-1.28.8.ebuild148
2 files changed, 149 insertions, 0 deletions
diff --git a/net-print/cups-filters/Manifest b/net-print/cups-filters/Manifest
index f6598a7fd15c..9a0303b1da23 100644
--- a/net-print/cups-filters/Manifest
+++ b/net-print/cups-filters/Manifest
@@ -1,2 +1,3 @@
DIST cups-filters-1.28.3.tar.xz 1501824 BLAKE2B b4f493681ac2a701648b3b9b071f4ebfb432dd4660b610579ff2ed6cba4f6cd4351d5a1f28f5c096b3ba20d9c45dc87837bf127b9bc98680a98dec58dd0a68ea SHA512 ac139ae7452342bd46e464bff3438d437f1c9a2e719a7b32b7abc22c2667acaa93dfb976decb277a02572e688ecd86289e01fca817bef93018dff2076fb2a30c
DIST cups-filters-1.28.7.tar.xz 1503052 BLAKE2B b9d3280871faa79a7c277731bf6eb1eef161537829d4bc07ec36075ebc12a3617dce66994ed708991757ce7d78fc5ab010925a1d3d9811fd11cf1172f4786442 SHA512 fa94f51ca1c208dcacb1814d8b812c9a72dd09475b7cf836b02c72cb5e3290318f37e475ee3ae8d45351715c3a2ccc0df5ac51ae6fc11462f5acdfa303a04727
+DIST cups-filters-1.28.8.tar.xz 1502456 BLAKE2B 21dad6dc9a1d2f967f3938f2fc5e35eebadb67da8b526a9ea61599272bd3f87e8efff376661adc02b62b539798cbe46e0f7c5c25ba262da0561b53bbb3d08d5d SHA512 77b39ce2a30ad44d50aa58964b389fa5dd75b2b4307ccb25996050fd176e1e794ad0a66ddd4de76e95a671683c3bf448a4f471272c97a752f25ff6234f7d8511
diff --git a/net-print/cups-filters/cups-filters-1.28.8.ebuild b/net-print/cups-filters/cups-filters-1.28.8.ebuild
new file mode 100644
index 000000000000..4c748c67fe65
--- /dev/null
+++ b/net-print/cups-filters/cups-filters-1.28.8.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+GENTOO_DEPEND_ON_PERL=no
+
+inherit autotools perl-module systemd flag-o-matic
+
+if [[ "${PV}" == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/OpenPrinting/cups-filters.git"
+else
+ SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+fi
+DESCRIPTION="Cups filters"
+HOMEPAGE="https://wiki.linuxfoundation.org/openprinting/cups-filters"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+IUSE="dbus +foomatic jpeg ldap pclm pdf perl png +postscript test tiff zeroconf"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-text/poppler-0.32:=[cxx,jpeg?,lcms,tiff?,utils]
+ >=app-text/qpdf-8.3.0:=
+ dev-libs/glib:2
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/lcms:2
+ >=net-print/cups-1.7.3
+ !<=net-print/cups-1.5.9999
+ sys-devel/bc
+ sys-libs/zlib
+ dbus? ( sys-apps/dbus )
+ foomatic? ( !net-print/foomatic-filters )
+ jpeg? ( virtual/jpeg:0 )
+ ldap? ( net-nds/openldap )
+ pdf? ( app-text/mupdf )
+ perl? ( dev-lang/perl:= )
+ png? ( media-libs/libpng:0= )
+ postscript? ( >=app-text/ghostscript-gpl-9.09[cups] )
+ tiff? ( media-libs/tiff:0 )
+ zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+ test? ( media-fonts/dejavu )
+"
+
+src_prepare() {
+ local need_eautoreconf=
+
+ default
+
+ if ! use test ; then
+ eapply "${FILESDIR}"/${PN}-1.28.2-make-missing-testfont-non-fatal.patch
+ need_eautoreconf=yes
+ elif [[ "${PV}" == "9999" ]] ; then
+ need_eautoreconf=yes
+ fi
+
+ [[ -n ${need_eautoreconf} ]] && eautoreconf
+
+ # Bug #626800
+ append-cxxflags -std=c++11
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-imagefilters
+ --localstatedir="${EPREFIX}"/var
+ --with-browseremoteprotocols=DNSSD,CUPS
+ --with-cups-rundir="${EPREFIX}"/run/cups
+ --with-fontdir="fonts/conf.avail"
+ --with-pdftops=pdftops
+ --with-rcdir=no
+ --without-php
+ --disable-static
+ $(use_enable dbus)
+ $(use_enable foomatic)
+ $(use_enable ldap)
+ $(use_enable pclm)
+ $(use_enable pdf mutool)
+ $(use_enable postscript ghostscript)
+ $(use_enable zeroconf avahi)
+ $(use_with jpeg)
+ $(use_with png)
+ $(use_with tiff)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+
+ if use perl; then
+ pushd "${S}/scripting/perl" > /dev/null || die
+ perl-module_src_configure
+ perl-module_src_compile
+ popd > /dev/null || die
+ fi
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+
+ if use perl; then
+ pushd "${S}/scripting/perl" > /dev/null || die
+ perl-module_src_install
+ perl_delete_localpod
+ popd > /dev/null || die
+ fi
+
+ if use postscript; then
+ # workaround: some printer drivers still require pstoraster and pstopxl, bug #383831
+ dosym gstoraster /usr/libexec/cups/filter/pstoraster
+ dosym gstopxl /usr/libexec/cups/filter/pstopxl
+ fi
+
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+
+ cp "${FILESDIR}"/cups-browsed.init.d-r1 "${T}"/cups-browsed || die
+
+ if ! use zeroconf ; then
+ sed -i -e 's:need cupsd avahi-daemon:need cupsd:g' "${T}"/cups-browsed || die
+ sed -i -e 's:cups\.service avahi-daemon\.service:cups.service:g' "${S}"/utils/cups-browsed.service || die
+ fi
+
+ doinitd "${T}"/cups-browsed
+ systemd_dounit "${S}/utils/cups-browsed.service"
+}
+
+pkg_postinst() {
+ if ! use foomatic ; then
+ ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."
+ ewarn "necessary. net-print/foomatic-filters as replacement is deprecated and unmaintained."
+ fi
+}