summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-04 16:32:27 +0100
committerSam James <sam@gentoo.org>2023-10-04 16:32:27 +0100
commit517e978ef861d2037bf46f4d96e78c2bacbcef3b (patch)
tree9d22cf5f63a86b21bc9bb1651a249f3a71aaeae0 /net-print
parentdev-util/rebar: Stabilize 3.21.0 ALLARCHES, #915171 (diff)
downloadgentoo-517e978ef861d2037bf46f4d96e78c2bacbcef3b.tar.gz
gentoo-517e978ef861d2037bf46f4d96e78c2bacbcef3b.tar.bz2
gentoo-517e978ef861d2037bf46f4d96e78c2bacbcef3b.zip
net-print/cups: require SSL
Upstream have started to require SSL on master and the --disable-tls build broke in 2.4.7. There's no point in fighting it given master now requires it, see https://github.com/OpenPrinting/cups/commit/123baa03a4e09047cfa25e003a0a9db8cc8fc363. Closes: https://bugs.gentoo.org/914869 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/cups/cups-2.4.7-r1.ebuild (renamed from net-print/cups/cups-2.4.7.ebuild)12
-rw-r--r--net-print/cups/cups-9999.ebuild12
2 files changed, 8 insertions, 16 deletions
diff --git a/net-print/cups/cups-2.4.7.ebuild b/net-print/cups/cups-2.4.7-r1.ebuild
index fb26dd7c4f2a..ca1eb9e72744 100644
--- a/net-print/cups/cups-2.4.7.ebuild
+++ b/net-print/cups/cups-2.4.7-r1.ebuild
@@ -28,7 +28,7 @@ HOMEPAGE="https://www.cups.org/ https://github.com/OpenPrinting/cups"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="acl dbus debug kerberos openssl pam selinux +ssl static-libs systemd test usb X xinetd zeroconf"
+IUSE="acl dbus debug kerberos openssl pam selinux static-libs systemd test usb X xinetd zeroconf"
# As of 2.4.2, they don't actually seem to be interactive (they pass some flags
# by default to input for us), but they fail on some greyscale issue w/ poppler?
@@ -52,10 +52,8 @@ DEPEND="
kerberos? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
pam? ( sys-libs/pam )
!pam? ( virtual/libcrypt:= )
- ssl? (
- !openssl? ( >=net-libs/gnutls-2.12.23-r6:0=[${MULTILIB_USEDEP}] )
- openssl? ( dev-libs/openssl:=[${MULTILIB_USEDEP}] )
- )
+ !openssl? ( >=net-libs/gnutls-2.12.23-r6:=[${MULTILIB_USEDEP}] )
+ openssl? ( dev-libs/openssl:=[${MULTILIB_USEDEP}] )
systemd? ( sys-apps/systemd )
usb? ( virtual/libusb:1 )
X? ( x11-misc/xdg-utils )
@@ -166,9 +164,7 @@ multilib_src_configure() {
$(multilib_native_use_enable pam)
$(use_enable static-libs static)
$(use_enable test unit-tests)
- # USE="ssl" => gnutls
- # USE="ssl openssl" => openssl
- $(use_with ssl tls $(usex openssl openssl gnutls))
+ --with-tls=$(usex openssl openssl gnutls)
$(use_with systemd ondemand systemd)
$(multilib_native_use_enable usb libusb)
$(use_with zeroconf dnssd avahi)
diff --git a/net-print/cups/cups-9999.ebuild b/net-print/cups/cups-9999.ebuild
index d1f511ef75b9..3d6b8b8cac30 100644
--- a/net-print/cups/cups-9999.ebuild
+++ b/net-print/cups/cups-9999.ebuild
@@ -28,7 +28,7 @@ HOMEPAGE="https://www.cups.org/ https://github.com/OpenPrinting/cups"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="acl dbus debug kerberos openssl pam selinux +ssl static-libs systemd test usb X xinetd zeroconf"
+IUSE="acl dbus debug kerberos openssl pam selinux static-libs systemd test usb X xinetd zeroconf"
# As of 2.4.2, they don't actually seem to be interactive (they pass some flags
# by default to input for us), but they fail on some greyscale issue w/ poppler?
@@ -52,10 +52,8 @@ DEPEND="
kerberos? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
pam? ( sys-libs/pam )
!pam? ( virtual/libcrypt:= )
- ssl? (
- !openssl? ( >=net-libs/gnutls-2.12.23-r6:0=[${MULTILIB_USEDEP}] )
- openssl? ( dev-libs/openssl:=[${MULTILIB_USEDEP}] )
- )
+ !openssl? ( >=net-libs/gnutls-2.12.23-r6:=[${MULTILIB_USEDEP}] )
+ openssl? ( dev-libs/openssl:=[${MULTILIB_USEDEP}] )
systemd? ( sys-apps/systemd )
usb? ( virtual/libusb:1 )
X? ( x11-misc/xdg-utils )
@@ -166,9 +164,7 @@ multilib_src_configure() {
$(multilib_native_use_enable pam)
$(use_enable static-libs static)
$(use_enable test unit-tests)
- # USE="ssl" => gnutls
- # USE="ssl openssl" => openssl
- $(use_with ssl tls $(usex openssl openssl gnutls))
+ --with-tls=$(usex openssl openssl gnutls)
$(use_with systemd ondemand systemd)
$(multilib_native_use_enable usb libusb)
$(use_with zeroconf dnssd avahi)