summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2019-08-27 08:42:29 +0200
committerTupone Alfredo <tupone@gentoo.org>2019-08-27 08:42:29 +0200
commit5bcb0af746f30ce9bda642d0e4ef153328986206 (patch)
treebaf9012411be1fb53c832f1ca745bfd038f950b8 /net-print
parentdev-util/dialog: Old (diff)
downloadgentoo-5bcb0af746f30ce9bda642d0e4ef153328986206.tar.gz
gentoo-5bcb0af746f30ce9bda642d0e4ef153328986206.tar.bz2
gentoo-5bcb0af746f30ce9bda642d0e4ef153328986206.zip
net-print/cnijfilter2: version bump to 5.70 from Dag Bakke
Closes: https://bugs.gentoo.org/691562 Closes: https://bugs.gentoo.org/691250 Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/cnijfilter2/Manifest1
-rw-r--r--net-print/cnijfilter2/cnijfilter2-5.70.ebuild64
-rw-r--r--net-print/cnijfilter2/files/cnijfilter2-5.70-gentoo.patch58
3 files changed, 123 insertions, 0 deletions
diff --git a/net-print/cnijfilter2/Manifest b/net-print/cnijfilter2/Manifest
index b6dcf7835788..0b046e1c3d56 100644
--- a/net-print/cnijfilter2/Manifest
+++ b/net-print/cnijfilter2/Manifest
@@ -1,3 +1,4 @@
DIST cnijfilter2-source-5.20-1.tar.gz 466507 BLAKE2B 1ca96153350a157f56dfed691a04dcbe1e3ab5462b59c0cd919316a7c54a36bbeb34cf4205132f0aa3e5a23f89eb260c35c1a3ee14ea85bc36b9e3b67cd7e3f7 SHA512 60be49d34adf9a4d2cd8337cccb36eb8c078e9712bf8043c3552f1d83c3da307badfe34fc3683c99e3234da30f4ba82e0c4a0b48ea5f78f0d66db1408bd7d495
DIST cnijfilter2-source-5.40-1.tar.gz 817298 BLAKE2B 1088eb19c70ed9133c38b8a6da9fbc26c42d6f077fda01678fb4485c2db21a17567fab8ab5c9565ece7ea13e5fac3f7c5842e984116d6c595e7a1f19092d3461 SHA512 bb4ce18864037fae9735fcb1b2c3198fe39f8abe0caa754e457e3cb0d03767742d82ff4fddf81451215395b23eea8207a880e238558e0ea2ac5c359186ecd859
DIST cnijfilter2-source-5.50-1.tar.gz 1129057 BLAKE2B 20208b1fa679a4303b5f47ae733224fa1346277d539e62688ecbfaa6a1a9f7b01cb4742c299ec188d59787e4175896dfe8d812f8aa936977f8168d823216b239 SHA512 9a99d0230fb9498d2b17648e58009efa5812fe5c076c11fdc6c2afeec453e355c1e3406053330e965e46be23651df6b887d0edb20eebd564554a7bf31b155186
+DIST cnijfilter2-source-5.70-1.tar.gz 1366033 BLAKE2B 0d03c4c4f4bc00ea91cc46db6554252997242dcc98ee65fe856528848843cdd6d2195e3839d8dad71f1fc722cfbb2e65730020665d9095d0a93900840659477d SHA512 3d9afe4ca6b042015898f4fc08d991a4af2c55010c9d98807a12dade01d2655f74b7e4896abeb933c93faeca954bcfdadfd6e359ee8efe5952623fc635500729
diff --git a/net-print/cnijfilter2/cnijfilter2-5.70.ebuild b/net-print/cnijfilter2/cnijfilter2-5.70.ebuild
new file mode 100644
index 000000000000..3b5058bc8153
--- /dev/null
+++ b/net-print/cnijfilter2/cnijfilter2-5.70.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P="${PN}-source-${PV}-1"
+
+DESCRIPTION="IJ Printer Driver"
+HOMEPAGE="https://www.canon.it/"
+SRC_URI="http://gdlp01.c-wss.com/gds/0/0100009930/01/${MY_P}.tar.gz"
+
+LICENSE="Canon-IJ"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/libusb:1
+ dev-libs/libxml2
+ net-print/cups"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_prepare() {
+ default
+ DIRS="cmdtocanonij2 cmdtocanonij3 cnijbe2 lgmon3 rastertocanonij tocanonij tocnpwg"
+ LIBDIR=com/libs_bin$(usex amd64 64 32)
+ for d in ${DIRS}; do
+ mv "${d}"/configure.{in,ac} || die
+ done
+ echo "AC_INIT([${PN}], [${PV}])" >> configure.ac
+ echo "AM_INIT_AUTOMAKE" >> configure.ac
+ echo "AC_CONFIG_SUBDIRS([${DIRS}])" >> configure.ac
+ echo "AC_CONFIG_FILES([Makefile])" >> configure.ac
+ echo "AC_OUTPUT()" >> configure.ac
+ echo "SUBDIRS= ${DIRS}" >> Makefile.am
+ sed -i \
+ -e "/^CFLAGS/d" \
+ */configure.ac || die
+ eautoreconf
+ cd ${LIBDIR}
+ rm libcn*.so || die
+ ln -sf libcnbpcnclapicom2.so.5.0.0 libcnbpcnclapicom2.so || die
+ ln -sf libcnbpnet20.so.1.0.0 libcnbpnet20.so || die
+ ln -sf libcnbpnet30.so.1.0.0 libcnbpnet30.so || die
+ ln -sf libcnnet2.so.1.2.4 libcnnet2.so || die
+
+ cd -
+}
+
+src_configure() {
+ LDFLAGS="-L"${S}"/${LIBDIR}" econf --enable-progpath="${EPREFIX}/usr/bin"
+}
+
+src_install() {
+ default
+ insinto /usr/share/ppd/cupsfilters
+ doins ppd/*ppd
+ dolib.so ${LIBDIR}/*
+}
diff --git a/net-print/cnijfilter2/files/cnijfilter2-5.70-gentoo.patch b/net-print/cnijfilter2/files/cnijfilter2-5.70-gentoo.patch
new file mode 100644
index 000000000000..fcb2d62ad7b5
--- /dev/null
+++ b/net-print/cnijfilter2/files/cnijfilter2-5.70-gentoo.patch
@@ -0,0 +1,58 @@
+--- a/cmdtocanonij2/filter/Makefile.am 2018-01-14 18:14:20.645473030 +0100
++++ b/cmdtocanonij2/filter/Makefile.am 2018-01-14 18:14:36.078219959 +0100
+@@ -1,4 +1,4 @@
+-filterdir=$(libdir)/cups/filter
++filterdir=$(libexecdir)/cups/filter
+
+ filter_PROGRAMS= cmdtocanonij2
+
+--- a/cmdtocanonij3/filter/Makefile.am 2018-01-14 18:14:20.645473030 +0100
++++ b/cmdtocanonij3/filter/Makefile.am 2018-01-14 18:14:36.078219959 +0100
+@@ -1,4 +1,4 @@
+-filterdir=$(libdir)/cups/filter
++filterdir=$(libexecdir)/cups/filter
+
+ filter_PROGRAMS= cmdtocanonij3
+
+--- a/cnijbe2/src/Makefile.am 2018-01-14 19:25:48.823470121 +0100
++++ b/cnijbe2/src/Makefile.am 2018-01-14 19:25:59.316275741 +0100
+@@ -1,6 +1,6 @@
+ ## Process this file with automake to produce Makefile.in
+
+-backend_bindir = /usr/lib/cups/backend
++backend_bindir = $(libexecdir)/cups/backend
+ backend_bin_PROGRAMS = cnijbe2
+ transform =
+
+--- a/rastertocanonij/src/Makefile.am 2018-01-14 21:31:33.053307218 +0100
++++ b/rastertocanonij/src/Makefile.am 2018-01-14 21:31:41.106166479 +0100
+@@ -1,4 +1,4 @@
+-filterdir=$(libdir)/cups/filter
++filterdir=$(libexecdir)/cups/filter
+
+ filter_PROGRAMS= rastertocanonij
+
+--- a/tocanonij/src/Makefile.am 2018-01-15 22:38:14.236460663 +0100
++++ b/tocanonij/src/Makefile.am 2018-01-15 22:38:39.184018933 +0100
+@@ -1,7 +1,8 @@
+ INCLUDES = \
+ -I$(top_srcdir)/include/cncl
+
+-bin_PROGRAMS= tocanonij
++filterdir=$(libexecdir)/cups/filter
++filter_PROGRAMS= tocanonij
+
+ tocanonij_SOURCES= \
+ main.c
+--- a/tocnpwg/src/Makefile.am 2018-01-15 22:42:43.759703863 +0100
++++ b/tocnpwg/src/Makefile.am 2018-01-15 22:43:10.442232986 +0100
+@@ -2,7 +2,8 @@
+ INCLUDES = \
+ @XML_2_CFLAGS@
+
+-bin_PROGRAMS= tocnpwg
++filterdir=$(libexecdir)/cups/filter
++filter_PROGRAMS= tocnpwg
+
+ tocnpwg_SOURCES= \
+ main.c mkpset.c