summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-10-19 11:59:22 +0100
committerJames Le Cuirot <chewi@gentoo.org>2023-10-19 11:59:22 +0100
commit8221c8f5e154e4e92e852479d0507b16052a8360 (patch)
treee70b092e13238c6d347ba61307cd7cd0d2b26514 /net-print
parentdev-util/hipcc: drop 5.7.0 (diff)
downloadgentoo-8221c8f5e154e4e92e852479d0507b16052a8360.tar.gz
gentoo-8221c8f5e154e4e92e852479d0507b16052a8360.tar.bz2
gentoo-8221c8f5e154e4e92e852479d0507b16052a8360.zip
net-print/hplip-plugin: Version bump to 3.23.8
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/hplip-plugin/Manifest1
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.23.8.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index 0823342c7452..9c6939b4fd9c 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1 +1,2 @@
DIST hplip-3.23.5-plugin.run 11491464 BLAKE2B 78f2f5cb60dc273d9d5c26909b277d36379bb345f12b2c4ddb2ba0542cd090872452f055b02d713f84b753f2418ee5a07a9a6852c256078747b30a15d7a0f352 SHA512 73389d295c21bc2c49b3aaa130f04784890eb72b3ca02fe1967b48ef1153205bd625c8efee103d96e1abbc7a4550f028153e94351f9437683d2579d910807dd4
+DIST hplip-3.23.8-plugin.run 11491257 BLAKE2B 1e87b741ebb28605c18954033e5b34ce2456671786e5472665e307253121635c23ecb920f974042ddbf8ebe76882d810f1fce2d39a46fadf774048f9a5673b33 SHA512 ba27bb609d2c17972bc7506ca6e9ef8c389c764c8276d0b1ddd711254f9bdb5c354ebe05026e392bfc261648fc57ccf199f60403c0bfbc3aceb78fcf890a39db
diff --git a/net-print/hplip-plugin/hplip-plugin-3.23.8.ebuild b/net-print/hplip-plugin/hplip-plugin-3.23.8.ebuild
new file mode 100644
index 000000000000..4bf67bc6bda1
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.23.8.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing/plugins"
+SRC_URI="https://developers.hp.com/sites/default/files/hplip-${PV}-plugin.run"
+S="${WORKDIR}"
+
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="orblite"
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/udev
+ orblite? (
+ media-gfx/sane-backends
+ >=sys-libs/glibc-2.26
+ virtual/libusb:0
+ )
+"
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PREBUILT="${HPLIP_HOME}/*.so"
+
+src_install() {
+ local hplip_arch plugin
+ case "${ARCH}" in
+ amd64) hplip_arch="x86_64" ;;
+ arm) hplip_arch="arm32" ;;
+ arm64) hplip_arch="arm64" ;;
+ x86) hplip_arch="x86_32" ;;
+ *) die "Unsupported architecture." ;;
+ esac
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ bb_orblite-*)
+ use orblite || continue
+ plugin_type=scan ;;
+ bb_*)
+ plugin_type=scan ;;
+ fax_*)
+ plugin_type=fax ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ insinto /var/lib/hp
+ newins - hplip.state <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}