summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-02-11 17:31:00 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-03-16 13:13:26 +0100
commit8dfab6971f247d726a47def8d50c32b02289fb75 (patch)
treeba57adff076e30ae6f0d9c6bce94022f8dae3750 /net-print
parentsci-astronomy/esorex: EAPI8 bump, use HTTPS, fix LICENSE (diff)
downloadgentoo-8dfab6971f247d726a47def8d50c32b02289fb75.tar.gz
gentoo-8dfab6971f247d726a47def8d50c32b02289fb75.tar.bz2
gentoo-8dfab6971f247d726a47def8d50c32b02289fb75.zip
net-print/poster: EAPI8 bump, fix HOMEPAGE
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/35277 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/poster/poster-20060221-r4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-print/poster/poster-20060221-r4.ebuild b/net-print/poster/poster-20060221-r4.ebuild
new file mode 100644
index 000000000000..b0aeabe617c5
--- /dev/null
+++ b/net-print/poster/poster-20060221-r4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Small utility for making a poster from an EPS file or a one-page PS document"
+HOMEPAGE="https://ctan.org/pkg/poster"
+SRC_URI="mirror://kde/printing/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix_gs_crash.patch"
+ "${FILESDIR}/${P}-fix_duplicate_DocumentMedia.patch"
+ "${FILESDIR}/${P}-fix_cutmarks.patch"
+)
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} ${PN}.c -lm -o ${PN} || die
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc README ChangeLog
+}