summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-01-26 21:30:56 +0000
committerJames Le Cuirot <chewi@gentoo.org>2022-01-26 21:31:51 +0000
commitaf4955f1a8da67b7b6aef31f7d5276f477b010cb (patch)
treeb0eb9c67d416570788784a708b5be8fac9876b6a /net-print
parentdev-python/pyhamcrest: Add pypy3 love (diff)
downloadgentoo-af4955f1a8da67b7b6aef31f7d5276f477b010cb.tar.gz
gentoo-af4955f1a8da67b7b6aef31f7d5276f477b010cb.tar.bz2
gentoo-af4955f1a8da67b7b6aef31f7d5276f477b010cb.zip
net-print/hplip-plugin: Version bump to 3.21.12
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/hplip-plugin/Manifest1
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.21.12.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index 986ad4603fb6..6a5db3529f6d 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1,2 +1,3 @@
DIST hplip-3.20.11-plugin.run 11514293 BLAKE2B b3b7698a45e5e68a25ec1216e736484d26546b657f4a519a153acf0280847667e7ca81afc988f722668746281857d51d9e1703857514ffe5b57dea85f2bae4d3 SHA512 9075c1ac8e8f6e12d33b81b633025259f54352ea00271eec07ee898fd9a164445519608fc9ea61a7157845a4a03f87c28f486c7994f0d7db81d11d3fe51f1876
DIST hplip-3.21.10-plugin.run 11514107 BLAKE2B a5e0d9d76e4575e8b99cf32749590d1b5209bfd9b33827f3d6f918a4574fb7452c68c816933fe6142b9acd8e336fd57a5a4ef6cf126e767ce37a05872db666ef SHA512 ee5c36b42e3f8e59607bf4e5a2b0e2b594f19aa7302125fff5dd5fdf392cc7cd142d6c44cbd35a53e1f160ee8293a25419caec2de7e09ecc926551723c793b67
+DIST hplip-3.21.12-plugin.run 11487224 BLAKE2B 601f70d6d75bc0172b6de647af43afa0ec047eb8b0a9a37611f2496d43daf1d4de4b705d6e58cb209910d7341811dc365d7aeb60d738f5e8ede71337bf36b58e SHA512 5bf6c0d7fb10f9108baac5d9c0c62f080b15cb227ae39c6647111d6dd39a3f97ab1044bccce781f224b5886842da5bd5063d3ce05db374a43e57a7152c52683b
diff --git a/net-print/hplip-plugin/hplip-plugin-3.21.12.ebuild b/net-print/hplip-plugin/hplip-plugin-3.21.12.ebuild
new file mode 100644
index 000000000000..354cee23d950
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.21.12.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing/plugins"
+SRC_URI="https://developers.hp.com/sites/default/files/hplip-${PV}-plugin.run"
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="orblite"
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/udev
+ orblite? (
+ media-gfx/sane-backends
+ >=sys-libs/glibc-2.26
+ virtual/libusb:0
+ )
+"
+DEPEND=""
+
+S=${WORKDIR}
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PREBUILT="${HPLIP_HOME}/*.so"
+
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+src_install() {
+ local hplip_arch
+ case "${ARCH}" in
+ amd64) hplip_arch="x86_64" ;;
+ arm) hplip_arch="arm32" ;;
+ arm64) hplip_arch="arm64" ;;
+ x86) hplip_arch="x86_32" ;;
+ *) die "Unsupported architecture." ;;
+ esac
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ bb_orblite-*)
+ use orblite || continue
+ plugin_type=scan ;;
+ bb_*)
+ plugin_type=scan ;;
+ fax_*)
+ plugin_type=fax ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ insinto /var/lib/hp
+ newins - hplip.state <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}