summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-09-11 09:27:52 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-09-11 09:28:01 +0200
commitb3c035d4f5883f12deb1e704bfa8843cf7f2df3e (patch)
tree39226a6359005d8b6ebbccba301c6392f7822ad0 /net-print
parentdev-python/nbconvert: bump to 6.0.1 (diff)
downloadgentoo-b3c035d4f5883f12deb1e704bfa8843cf7f2df3e.tar.gz
gentoo-b3c035d4f5883f12deb1e704bfa8843cf7f2df3e.tar.bz2
gentoo-b3c035d4f5883f12deb1e704bfa8843cf7f2df3e.zip
net-print/cups-filters: Bump to version 1.28.2
Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/cups-filters/Manifest1
-rw-r--r--net-print/cups-filters/cups-filters-1.28.2.ebuild148
-rw-r--r--net-print/cups-filters/files/cups-filters-1.28.2-make-missing-testfont-non-fatal.patch14
3 files changed, 163 insertions, 0 deletions
diff --git a/net-print/cups-filters/Manifest b/net-print/cups-filters/Manifest
index 22f016c71f39..7651b4c12bac 100644
--- a/net-print/cups-filters/Manifest
+++ b/net-print/cups-filters/Manifest
@@ -1,2 +1,3 @@
DIST cups-filters-1.27.4.tar.xz 1493860 BLAKE2B 424c3ba73ec7d6f4683eaedde86d657b1a2da17670c84097f5f3f8ef525cc8cc6d7843a88d35013a5f48bba8a903f7504df9054427b9a63d748ce39de458e71f SHA512 8005e94bb6b06d0a15fa4dfd8455d0bc67418478bf517e205af1c8c0018681a97ae9ea486db07570050ebeeb7f63f75319a8fe012c112c6d16c0941299eaa50e
DIST cups-filters-1.27.5.tar.xz 1494864 BLAKE2B 457968139f0bc1a5fd4c587dfe4a88d1904eb0ca9ee2aa88c1360785eb53b59e7eb823535ef01a9f81551628514441077562e91487a55a9f0c9e6c9dbdba98b7 SHA512 8bc917b2a168add1062d091d02d99c39d72861c0d0cb1242c34b2bf117c9943e7fdc1fe002de7cde4cb1919fbce41073adc34916c328fc99e66e389b0a4fe103
+DIST cups-filters-1.28.2.tar.xz 1502352 BLAKE2B e0d95a7e1596d4dc05a8e2d32b2ee573cfa1ec304288e476a38c8b51de5ed8e0b6a71e371d2196802b116d63aea1e750e0b3a6c8fae749377de0ab72f92aa86e SHA512 aa5f075927286a8278259025aa5baf95445809a83b88e2d4654e8f0a124012591b045df115294242fae60a283d983d6cdbaafc6a51224af30a7e56b58d831da5
diff --git a/net-print/cups-filters/cups-filters-1.28.2.ebuild b/net-print/cups-filters/cups-filters-1.28.2.ebuild
new file mode 100644
index 000000000000..d3c34b7f443d
--- /dev/null
+++ b/net-print/cups-filters/cups-filters-1.28.2.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+GENTOO_DEPEND_ON_PERL=no
+
+inherit autotools perl-module systemd flag-o-matic
+
+if [[ "${PV}" == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/OpenPrinting/cups-filters.git"
+else
+ SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~m68k-mint"
+fi
+DESCRIPTION="Cups filters"
+HOMEPAGE="https://wiki.linuxfoundation.org/openprinting/cups-filters"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+IUSE="dbus +foomatic jpeg ldap pclm pdf perl png +postscript static-libs test tiff zeroconf"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-text/poppler-0.32:=[cxx,jpeg?,lcms,tiff?,utils]
+ >=app-text/qpdf-8.3.0:=
+ dev-libs/glib:2
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/lcms:2
+ >=net-print/cups-1.7.3
+ !<=net-print/cups-1.5.9999
+ sys-devel/bc
+ sys-libs/zlib
+ dbus? ( sys-apps/dbus )
+ foomatic? ( !net-print/foomatic-filters )
+ jpeg? ( virtual/jpeg:0 )
+ ldap? ( net-nds/openldap )
+ pdf? ( app-text/mupdf )
+ perl? ( dev-lang/perl:= )
+ png? ( media-libs/libpng:0= )
+ postscript? ( >=app-text/ghostscript-gpl-9.09[cups] )
+ tiff? ( media-libs/tiff:0 )
+ zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+ test? ( media-fonts/dejavu )
+"
+
+src_prepare() {
+ local need_eautoreconf=
+
+ default
+
+ if ! use test ; then
+ eapply "${FILESDIR}"/${PN}-1.28.2-make-missing-testfont-non-fatal.patch
+ need_eautoreconf=yes
+ elif [[ "${PV}" == "9999" ]] ; then
+ need_eautoreconf=yes
+ fi
+
+ [[ -n ${need_eautoreconf} ]] && eautoreconf
+
+ # Bug #626800
+ append-cxxflags -std=c++11
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-imagefilters
+ --localstatedir="${EPREFIX}"/var
+ --with-browseremoteprotocols=DNSSD,CUPS
+ --with-cups-rundir="${EPREFIX}"/run/cups
+ --with-fontdir="fonts/conf.avail"
+ --with-pdftops=pdftops
+ --with-rcdir=no
+ --without-php
+ $(use_enable dbus)
+ $(use_enable foomatic)
+ $(use_enable ldap)
+ $(use_enable pclm)
+ $(use_enable pdf mutool)
+ $(use_enable postscript ghostscript)
+ $(use_enable static-libs static)
+ $(use_enable zeroconf avahi)
+ $(use_with jpeg)
+ $(use_with png)
+ $(use_with tiff)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+
+ if use perl; then
+ pushd "${S}/scripting/perl" > /dev/null
+ perl-module_src_configure
+ perl-module_src_compile
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ default
+
+ if use perl; then
+ pushd "${S}/scripting/perl" > /dev/null
+ perl-module_src_install
+ perl_delete_localpod
+ popd > /dev/null
+ fi
+
+ if use postscript; then
+ # workaround: some printer drivers still require pstoraster and pstopxl, bug #383831
+ dosym gstoraster /usr/libexec/cups/filter/pstoraster
+ dosym gstopxl /usr/libexec/cups/filter/pstopxl
+ fi
+
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+
+ cp "${FILESDIR}"/cups-browsed.init.d-r1 "${T}"/cups-browsed || die
+
+ if ! use zeroconf ; then
+ sed -i -e 's:need cupsd avahi-daemon:need cupsd:g' "${T}"/cups-browsed || die
+ sed -i -e 's:cups\.service avahi-daemon\.service:cups.service:g' "${S}"/utils/cups-browsed.service || die
+ fi
+
+ doinitd "${T}"/cups-browsed
+ systemd_dounit "${S}/utils/cups-browsed.service"
+}
+
+src_test() {
+ emake check
+}
+
+pkg_postinst() {
+ if ! use foomatic ; then
+ ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."
+ ewarn "necessary. net-print/foomatic-filters as replacement is deprecated and unmaintained."
+ fi
+}
diff --git a/net-print/cups-filters/files/cups-filters-1.28.2-make-missing-testfont-non-fatal.patch b/net-print/cups-filters/files/cups-filters-1.28.2-make-missing-testfont-non-fatal.patch
new file mode 100644
index 000000000000..8447929a5246
--- /dev/null
+++ b/net-print/cups-filters/files/cups-filters-1.28.2-make-missing-testfont-non-fatal.patch
@@ -0,0 +1,14 @@
+--- cups-filters-1.28.2/configure.ac
++++ cups-filters-1.28.2/configure.ac
+@@ -790,7 +790,10 @@
+ )
+
+ AS_IF([test "x$cross_compiling" != "xyes" && ! test -f "$with_test_font_path"],
+- [AC_MSG_ERROR(DejaVuSans.ttf font file is missing. Please install a package providing it.)]
++ [
++ AC_MSG_WARN(DejaVuSans.ttf font file is missing. Expect test failures!)]
++ AC_DEFINE([TESTFONT])
++ ]
+ )
+ AC_DEFINE_UNQUOTED([TESTFONT], ["$with_test_font_path"], [Path to font used in tests])
+