summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-02-07 15:45:21 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-02-07 15:45:55 +0100
commitb8fa126dd2c2241428665c8e5112a6a2abf9d2ef (patch)
tree107bbfe3299531bcfc949d1b4c1ff6042b446295 /net-print
parentdev-vcs/git: Removed old. (diff)
downloadgentoo-b8fa126dd2c2241428665c8e5112a6a2abf9d2ef.tar.gz
gentoo-b8fa126dd2c2241428665c8e5112a6a2abf9d2ef.tar.bz2
gentoo-b8fa126dd2c2241428665c8e5112a6a2abf9d2ef.zip
net-print/cups: Bump to version 2.1.3
Package-Manager: portage-2.2.27 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/cups/Manifest1
-rw-r--r--net-print/cups/cups-2.1.3.ebuild357
-rw-r--r--net-print/cups/files/cups-1.6.0-dont-compress-manpages.patch6
-rw-r--r--net-print/cups/files/cups-1.6.0-fix-install-perms.patch6
-rw-r--r--net-print/cups/files/cupsd.init.d-r220
5 files changed, 382 insertions, 8 deletions
diff --git a/net-print/cups/Manifest b/net-print/cups/Manifest
index 271c55fd3143..f911ce00d11c 100644
--- a/net-print/cups/Manifest
+++ b/net-print/cups/Manifest
@@ -1,3 +1,4 @@
DIST cups-2.0.3-source.tar.bz2 8797220 SHA256 bc3167048690a7379f29a37d9fbd2143cf0ca033b54eedd9333ddfc4ee258881 SHA512 fcc2be8d12cec624423a07706486afd226c9cb29b2ba694d63b8250c16a7d0f39aa51e6c831ca7c978ba5009e98b1daedad4b119a4f3287a88e21e48f0d07e18 WHIRLPOOL d12771b6d941db78854a1b05644a4402fa6a62f8acab1332c7490887e0099463b129684f4dd21b5e9f02e4f8e23bef633a06fca01ad8fa8b34de9298b72ab3ba
DIST cups-2.0.4-source.tar.bz2 8799274 SHA256 e1d5e68d9f24faca317aeaebc164c34102813bc0f1d69c00b3a59b49c49f4abd SHA512 d0db3ce729ee893f260b69814343e84af4b934f1783d96049fcf58204a93ac534d0bf0c1626f5ac55371962419b91c857bd872f499e905223069b5103405c4ae WHIRLPOOL cbeb3f61cf534017180aa0d55f60ec81ac082f92d3626b18b4480aaf9e67b425b829ad260dfa1227ba56a79b52959f1e740848d26dc938fc9fc0159f1844a2bb
DIST cups-2.1.2-source.tar.bz2 8831726 SHA256 bab0ca3ba80eae48319b3a6b19a5b14fad5ce230f30151a0cfa4c0271df281ad SHA512 c1bd15acdd8ac55a731c9267f0dcf9159a02c3a895d4b032b0e0d0bbb1189eb4b3b4600a9f025a8359a55ce93a5911014058f361f2bc954d1fb2cdbf219e183d WHIRLPOOL e4bb7729bb4ac7d8ba51a18178dfaeaa98c3e4525c7c6beb17dbe78f938e7cb2da466f9b4cb7f68452ddae6a52de36ee3c2b204dd1f5c9e21141cdaf7fdccea0
+DIST cups-2.1.3-source.tar.bz2 8832400 SHA256 36a70d43584aea2617da914b9331e23341c3501a8254c4d2eae9c11ec01fd4d3 SHA512 5cc715b8521b4d6af29a97a8abf7a1b0973840c00727ee8e7926e89a4a9da8e67565d14cc4b57ab7cfb40b238d4faaed7608b9ab95947cc3671ed87b710f8f36 WHIRLPOOL 161c65b8adc3ab1c65208fe23bf14aefe5dfd84e9b162c69b1a8f977c3a4fc7c31ea92d0c2eaca3c276fa192596a31701052f0c2a1ffd213a09d48c11d446f6f
diff --git a/net-print/cups/cups-2.1.3.ebuild b/net-print/cups/cups-2.1.3.ebuild
new file mode 100644
index 000000000000..3f1174b961b5
--- /dev/null
+++ b/net-print/cups/cups-2.1.3.ebuild
@@ -0,0 +1,357 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools fdo-mime gnome2-utils flag-o-matic linux-info \
+ multilib multilib-minimal pam python-single-r1 user versionator \
+ java-pkg-opt-2 systemd toolchain-funcs
+
+MY_P=${P/_rc/rc}
+MY_P=${MY_P/_beta/b}
+MY_PV=${PV/_rc/rc}
+MY_PV=${MY_PV/_beta/b}
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="http://www.cups.org/cups.git"
+ if [[ ${PV} != 9999 ]]; then
+ EGIT_BRANCH=branch-${PV/.9999}
+ fi
+else
+ SRC_URI="http://www.cups.org/software/${MY_PV}/${MY_P}-source.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~m68k-mint"
+fi
+
+DESCRIPTION="The Common Unix Printing System"
+HOMEPAGE="http://www.cups.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="acl dbus debug java kerberos lprng-compat pam
+ python selinux +ssl static-libs systemd +threads usb X xinetd zeroconf"
+
+LANGS="ca cs de es fr it ja ru"
+for X in ${LANGS} ; do
+ IUSE="${IUSE} +linguas_${X}"
+done
+
+CDEPEND="
+ app-text/libpaper
+ acl? (
+ kernel_linux? (
+ sys-apps/acl
+ sys-apps/attr
+ )
+ )
+ dbus? ( >=sys-apps/dbus-1.6.18-r1[${MULTILIB_USEDEP}] )
+ java? ( >=virtual/jre-1.6:* )
+ kerberos? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
+ !lprng-compat? ( !net-print/lprng )
+ pam? ( virtual/pam )
+ python? ( ${PYTHON_DEPS} )
+ ssl? (
+ >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}]
+ >=net-libs/gnutls-2.12.23-r6[${MULTILIB_USEDEP}]
+ )
+ systemd? ( sys-apps/systemd )
+ usb? ( virtual/libusb:1 )
+ X? ( x11-misc/xdg-utils )
+ xinetd? ( sys-apps/xinetd )
+ zeroconf? ( >=net-dns/avahi-0.6.31-r2[${MULTILIB_USEDEP}] )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20140508
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )
+"
+
+DEPEND="${CDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+"
+
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-cups )
+"
+
+PDEPEND="
+ app-text/ghostscript-gpl[cups]
+ app-text/poppler[utils]
+ >=net-print/cups-filters-1.0.43
+"
+
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ usb? ( threads )
+"
+
+# upstream includes an interactive test which is a nono for gentoo
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+# systemd-socket.patch from Fedora
+PATCHES=(
+ "${FILESDIR}/${PN}-1.6.0-dont-compress-manpages.patch"
+ "${FILESDIR}/${PN}-1.6.0-fix-install-perms.patch"
+ "${FILESDIR}/${PN}-1.4.4-nostrip.patch"
+ "${FILESDIR}/${PN}-2.0.2-rename-systemd-service-files.patch"
+ "${FILESDIR}/${PN}-2.1.2-systemd-socket.patch"
+ "${FILESDIR}/${PN}-2.0.1-xinetd-installation-fix.patch"
+ "${FILESDIR}/${PN}-2.0.3-cross-compile.patch"
+)
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/cups-config
+)
+
+pkg_setup() {
+ enewgroup lp
+ enewuser lp -1 -1 -1 lp
+ enewgroup lpadmin 106
+
+ use python && python-single-r1_pkg_setup
+
+ if use kernel_linux; then
+ linux-info_pkg_setup
+ if ! linux_config_exists; then
+ ewarn "Can't check the linux kernel configuration."
+ ewarn "You might have some incompatible options enabled."
+ else
+ # recheck that we don't have usblp to collide with libusb
+ if use usb; then
+ if linux_chkconfig_present USB_PRINTER; then
+ eerror "Your usb printers will be managed via libusb. In this case, "
+ eerror "${P} requires the USB_PRINTER support disabled."
+ eerror "Please disable it:"
+ eerror " CONFIG_USB_PRINTER=n"
+ eerror "in /usr/src/linux/.config or"
+ eerror " Device Drivers --->"
+ eerror " USB support --->"
+ eerror " [ ] USB Printer support"
+ eerror "Alternatively, just disable the usb useflag for cups (your printer will still work)."
+ fi
+ else
+ #here we should warn user that he should enable it so he can print
+ if ! linux_chkconfig_present USB_PRINTER; then
+ ewarn "If you plan to use USB printers you should enable the USB_PRINTER"
+ ewarn "support in your kernel."
+ ewarn "Please enable it:"
+ ewarn " CONFIG_USB_PRINTER=y"
+ ewarn "in /usr/src/linux/.config or"
+ ewarn " Device Drivers --->"
+ ewarn " USB support --->"
+ ewarn " [*] USB Printer support"
+ ewarn "Alternatively, enable the usb useflag for cups and use the libusb code."
+ fi
+ fi
+ fi
+ fi
+}
+
+src_prepare() {
+ default
+
+ # Remove ".SILENT" rule for verbose output (bug 524338).
+ sed 's#^.SILENT:##g' -i "${S}"/Makedefs.in || die "sed failed"
+
+ # Fix install-sh, posix sh does not have 'function'.
+ sed 's#function gzipcp#gzipcp()#g' -i "${S}/install-sh"
+
+ AT_M4DIR=config-scripts eaclocal
+ eautoconf
+
+ # custom Makefiles
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ export DSOFLAGS="${LDFLAGS}"
+
+ einfo LANGS=\"${LANGS}\"
+ einfo LINGUAS=\"${LINGUAS}\"
+
+ local myconf=()
+
+ if tc-is-static-only; then
+ myconf+=(
+ --disable-shared
+ )
+ fi
+
+ # explicitly specify compiler wrt bug 524340
+ #
+ # need to override KRB5CONFIG for proper flags
+ # https://www.cups.org/str.php?L4423
+ econf \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ KRB5CONFIG="${EPREFIX}"/usr/bin/${CHOST}-krb5-config \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --localstatedir="${EPREFIX}"/var \
+ --with-rundir="${EPREFIX}"/run/cups \
+ --with-cups-user=lp \
+ --with-cups-group=lp \
+ --with-docdir="${EPREFIX}"/usr/share/cups/html \
+ --with-languages="${LINGUAS}" \
+ --with-system-groups=lpadmin \
+ --with-xinetd=/etc/xinetd.d \
+ $(multilib_native_use_enable acl) \
+ $(use_enable dbus) \
+ $(use_enable debug) \
+ $(use_enable debug debug-guards) \
+ $(multilib_native_use_with java) \
+ $(use_enable kerberos gssapi) \
+ $(multilib_native_use_enable pam) \
+ $(multilib_native_use_with python python "${PYTHON}") \
+ $(use_enable static-libs static) \
+ $(use_enable threads) \
+ $(use_enable ssl gnutls) \
+ $(use_enable systemd) \
+ $(multilib_native_use_enable usb libusb) \
+ $(use_enable zeroconf avahi) \
+ --disable-dnssd \
+ --without-perl \
+ --without-php \
+ $(multilib_is_native_abi && echo --enable-libpaper || echo --disable-libpaper) \
+ "${myconf[@]}"
+
+ # install in /usr/libexec always, instead of using /usr/lib/cups, as that
+ # makes more sense when facing multilib support.
+ sed -i -e "s:SERVERBIN.*:SERVERBIN = \"\$\(BUILDROOT\)${EPREFIX}/usr/libexec/cups\":" Makedefs || die
+ sed -i -e "s:#define CUPS_SERVERBIN.*:#define CUPS_SERVERBIN \"${EPREFIX}/usr/libexec/cups\":" config.h || die
+ sed -i -e "s:cups_serverbin=.*:cups_serverbin=\"${EPREFIX}/usr/libexec/cups\":" cups-config || die
+}
+
+multilib_src_compile() {
+ if multilib_is_native_abi; then
+ default
+ else
+ emake libs
+ fi
+}
+
+multilib_src_test() {
+ multilib_is_native_abi && default
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi; then
+ emake BUILDROOT="${D}" install
+ else
+ emake BUILDROOT="${D}" install-libs install-headers
+ dobin cups-config
+ fi
+}
+
+multilib_src_install_all() {
+ dodoc {CHANGES,CREDITS,README}.txt
+
+ # move the default config file to docs
+ dodoc "${ED}"/etc/cups/cupsd.conf.default
+ rm -f "${ED}"/etc/cups/cupsd.conf.default
+
+ # clean out cups init scripts
+ rm -rf "${ED}"/etc/{init.d/cups,rc*,pam.d/cups}
+
+ # install our init script
+ local neededservices
+ use zeroconf && neededservices+=" avahi-daemon"
+ use dbus && neededservices+=" dbus"
+ [[ -n ${neededservices} ]] && neededservices="need${neededservices}"
+ cp "${FILESDIR}"/cupsd.init.d-r2 "${T}"/cupsd || die
+ sed -i \
+ -e "s/@neededservices@/$neededservices/" \
+ "${T}"/cupsd || die
+ doinitd "${T}"/cupsd
+
+ # install our pam script
+ pamd_mimic_system cups auth account
+
+ if use xinetd ; then
+ # correct path
+ sed -i \
+ -e "s:server = .*:server = /usr/libexec/cups/daemon/cups-lpd:" \
+ "${ED}"/etc/xinetd.d/cups-lpd || die
+ # it is safer to disable this by default, bug #137130
+ grep -w 'disable' "${ED}"/etc/xinetd.d/cups-lpd || \
+ { sed -i -e "s:}:\tdisable = yes\n}:" "${ED}"/etc/xinetd.d/cups-lpd || die ; }
+ # write permission for file owner (root), bug #296221
+ fperms u+w /etc/xinetd.d/cups-lpd || die "fperms failed"
+ else
+ # always configure with --with-xinetd= and clean up later,
+ # bug #525604
+ rm -rf "${ED}"/etc/xinetd.d
+ fi
+
+ keepdir /usr/libexec/cups/driver /usr/share/cups/{model,profiles} \
+ /var/log/cups /var/spool/cups/tmp
+
+ keepdir /etc/cups/{interfaces,ppd,ssl}
+
+ use X || rm -r "${ED}"/usr/share/applications
+
+ # create /etc/cups/client.conf, bug #196967 and #266678
+ echo "ServerName ${EPREFIX}/run/cups/cups.sock" >> "${ED}"/etc/cups/client.conf
+
+ # the following file is now provided by cups-filters:
+ rm -r "${ED}"/usr/share/cups/banners || die
+
+ # the following are created by the init script
+ rm -r "${ED}"/var/cache/cups || die
+ rm -r "${ED}"/run || die
+
+ # for the special case of running lprng and cups together, bug 467226
+ if use lprng-compat ; then
+ rm -fv "${ED}"/usr/bin/{lp*,cancel}
+ rm -fv "${ED}"/usr/sbin/lp*
+ rm -fv "${ED}"/usr/share/man/man1/{lp*,cancel*}
+ rm -fv "${ED}"/usr/share/man/man8/lp*
+ ewarn "Not installing lp... binaries, since the lprng-compat useflag is set."
+ ewarn "Unless you plan to install an exotic server setup, you most likely"
+ ewarn "do not want this. Disable the useflag then and all will be fine."
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ # Update desktop file database and gtk icon cache (bug 370059)
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+
+ # not slotted - at most one value
+ if ! [[ "${REPLACING_VERSIONS}" ]]; then
+ echo
+ elog "For information about installing a printer and general cups setup"
+ elog "take a look at: https://wiki.gentoo.org/wiki/Printing"
+ echo
+ fi
+
+ if [[ "${REPLACING_VERSIONS}" ]] && [[ "${REPLACING_VERSIONS}" < "1.6" ]]; then
+ echo
+ elog "CUPS-1.6 no longer supports automatic remote printers or implicit classes"
+ elog "via the CUPS, LDAP, or SLP protocols, i.e. \"network browsing\"."
+ elog "You will have to find printers using zeroconf/avahi instead, enter"
+ elog "the location manually, or run cups-browsed from net-print/cups-filters"
+ elog "which re-adds that functionality as a separate daemon."
+ echo
+ fi
+
+ if [[ "${REPLACING_VERSIONS}" == "1.6.2-r4" ]]; then
+ ewarn
+ ewarn "You are upgrading from the broken version net-print/cups-1.6.2-r4."
+ ewarn "Please rebuild net-print/cups-filters now to make sure everything is OK."
+ ewarn
+ fi
+}
+
+pkg_postrm() {
+ # Update desktop file database and gtk icon cache (bug 370059)
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
diff --git a/net-print/cups/files/cups-1.6.0-dont-compress-manpages.patch b/net-print/cups/files/cups-1.6.0-dont-compress-manpages.patch
index 62db46eea00d..a388b4d5e021 100644
--- a/net-print/cups/files/cups-1.6.0-dont-compress-manpages.patch
+++ b/net-print/cups/files/cups-1.6.0-dont-compress-manpages.patch
@@ -1,7 +1,5 @@
-Index: config-scripts/cups-manpages.m4
-===================================================================
---- config-scripts/cups-manpages.m4 (Revision 10458)
-+++ config-scripts/cups-manpages.m4 (Arbeitskopie)
+--- a/config-scripts/cups-manpages.m4
++++ b/config-scripts/cups-manpages.m4
@@ -69,10 +69,10 @@
;;
Linux* | GNU* | Darwin*)
diff --git a/net-print/cups/files/cups-1.6.0-fix-install-perms.patch b/net-print/cups/files/cups-1.6.0-fix-install-perms.patch
index 2d7a77c44f3d..e71934b7d49f 100644
--- a/net-print/cups/files/cups-1.6.0-fix-install-perms.patch
+++ b/net-print/cups/files/cups-1.6.0-fix-install-perms.patch
@@ -1,7 +1,5 @@
-Index: Makedefs.in
-===================================================================
---- Makedefs.in (Revision 10520)
-+++ Makedefs.in (Arbeitskopie)
+--- a/Makedefs.in
++++ b/Makedefs.in
@@ -40,14 +40,14 @@
# Installation programs...
#
diff --git a/net-print/cups/files/cupsd.init.d-r2 b/net-print/cups/files/cupsd.init.d-r2
new file mode 100644
index 000000000000..7910a3c511bc
--- /dev/null
+++ b/net-print/cups/files/cupsd.init.d-r2
@@ -0,0 +1,20 @@
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
+# $Id$
+
+description="The Common Unix Printing System daemon"
+command="/usr/sbin/cupsd"
+
+depend() {
+ use net
+ @neededservices@
+ before nfs
+ after logger
+}
+
+start_pre() {
+ checkpath -q -d -m 0775 -o root:lp /var/cache/cups
+ checkpath -q -d -m 0775 -o root:lp /var/cache/cups/rss
+ checkpath -q -d -m 0755 -o root:lp /run/cups
+ checkpath -q -d -m 0511 -o lp:lpadmin /run/cups/certs
+}