summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-04 20:43:36 +0100
committerSam James <sam@gentoo.org>2023-10-04 20:43:36 +0100
commitc1e192a3ea62cc038fcb15ef612f0c37660fd837 (patch)
treea09620de29e6c7f85697a55639cd8bcc29654995 /net-print
parentdev-python/jsonschema: Stabilize 4.19.1 arm, #912611 (diff)
downloadgentoo-c1e192a3ea62cc038fcb15ef612f0c37660fd837.tar.gz
gentoo-c1e192a3ea62cc038fcb15ef612f0c37660fd837.tar.bz2
gentoo-c1e192a3ea62cc038fcb15ef612f0c37660fd837.zip
net-print/brlaser: don't redefine _FORTIFY_SOURCE
Closes: https://bugs.gentoo.org/895810 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/brlaser/brlaser-6-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-print/brlaser/brlaser-6-r1.ebuild b/net-print/brlaser/brlaser-6-r1.ebuild
new file mode 100644
index 000000000000..9870f1912e92
--- /dev/null
+++ b/net-print/brlaser/brlaser-6-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Brother laser printer driver"
+HOMEPAGE="https://github.com/pdewacht/brlaser"
+SRC_URI="https://github.com/pdewacht/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="net-print/cups"
+RDEPEND="
+ ${DEPEND}
+ app-text/ghostscript-gpl"
+
+src_prepare() {
+ # Don't clobber toolchain defaults
+ sed -i -e '/-D_FORTIFY_SOURCE=2/d' CMakeLists.txt || die
+
+ cmake_src_prepare
+}