summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2021-02-23 15:47:40 +0100
committerDaniel Pielmeier <billie@gentoo.org>2021-02-23 15:48:12 +0100
commitfc00c3e614996bac5e357924fdc1c617d9b8d4c0 (patch)
treef46f3c0d4ef68ef725268ceb480875485d68a965 /net-print
parentsys-kernel/gentoo-sources: Linux patch 4.4.258 (diff)
downloadgentoo-fc00c3e614996bac5e357924fdc1c617d9b8d4c0.tar.gz
gentoo-fc00c3e614996bac5e357924fdc1c617d9b8d4c0.tar.bz2
gentoo-fc00c3e614996bac5e357924fdc1c617d9b8d4c0.zip
net-print/hplip: Version bump.
Thanks to Andrew Savchenko for the reports. Closes: https://bugs.gentoo.org/771969 Closes: https://bugs.gentoo.org/771972 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/hplip/Manifest2
-rw-r--r--net-print/hplip/hplip-3.21.2.ebuild288
2 files changed, 290 insertions, 0 deletions
diff --git a/net-print/hplip/Manifest b/net-print/hplip/Manifest
index bbe4324220b0..a913ec6d3ce3 100644
--- a/net-print/hplip/Manifest
+++ b/net-print/hplip/Manifest
@@ -3,3 +3,5 @@ DIST hplip-3.20.11-patches-2.tar.xz 18140 BLAKE2B a0271d0c6fcfaa53c68ab00c4c6cfc
DIST hplip-3.20.11.tar.gz 26301441 BLAKE2B 14667f33cc50b2887c8434ada7327a82e16b9acbcdc75d3a50c0261ec9aef3fada9be81e6c0cbdfb4d29914630799c6406893644386db99c0ce86245cca38cc2 SHA512 f583fb4140a29c5e21956c3e51fe3620baa65d33b40447af419d7fc61473a1148a1873216a84e89be785b155ee8e9aebd5e3eb19d2ded82b8415b1a35de1b55d
DIST hplip-3.20.9-patches-2.tar.xz 18040 BLAKE2B f218703f5e6f319306b6cd178eb9f91981eed0d0c06b14c6846ad8a79b1d92b66176856f7b8bb272d0fa20194d4150fecf066c11fff5996f32b6fd71e1d6237d SHA512 5aa16f9c4e829774ea9266f30f6cd9d78556ea4ed36abc57cb11975c097c8bfdc44f139f5b1236af79859355ef715ec27d47f187d330541b29361e779d972fff
DIST hplip-3.20.9.tar.gz 26141198 BLAKE2B 3aa353343ee79ae04dbe94cb9e135469586a50c2052a21ffcff6907be40522a1605f1174b0b8891dea25abb83a3b836350e1e6c9d12ab2798aa826f1d3ce4069 SHA512 d2981cf51f6d893a576c51808710ac9815aa6ac5fdc617d95cc372518731a48b0aca09af721c1792e1531df6cf8fc0ebf5ebd7e9c96950602a830ceed3d441ae
+DIST hplip-3.21.2-patches-1.tar.xz 19212 BLAKE2B c733651a7831b54bec13b5f037b0f00ab53dbec193f73964d7bb3f8ee4e1dcd02a02dd793d7fc322fe34085bbe5ec281076757d8882b4eb7f85fd0e45b1c3200 SHA512 23c696b111fe098358eb609e64cedc2ee85f4a1dac8bce895e3c6bbcb96e62dd5d2d3f1bcc9d12d20ccd6717b23f92b3016c926df7c73f50ba9425542d08ed29
+DIST hplip-3.21.2.tar.gz 27014784 BLAKE2B b6a13f0d48f3052ad09b419dbe9b68605c85ed8f1bfb6f1ec9720b9aace4a1c6d17a933b0d55ba20dbbc3d389ba1d2751dbd9a71d364ad2e2e1617cd7613dc2d SHA512 73ba37275cfe34a58b81c9656514e15da67c1a69af5471ad132a1538d324efe640879cb7e60c359915607e41b63e653e7ae757661e553235f6e83e378ab46474
diff --git a/net-print/hplip/hplip-3.21.2.ebuild b/net-print/hplip/hplip-3.21.2.ebuild
new file mode 100644
index 000000000000..729484bb5f61
--- /dev/null
+++ b/net-print/hplip/hplip-3.21.2.ebuild
@@ -0,0 +1,288 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="threads(+),xml"
+
+# 14 and 15 spit out a lot of warnings about subdirs
+WANT_AUTOMAKE="1.13"
+
+inherit autotools linux-info python-single-r1 readme.gentoo-r1 udev
+
+DESCRIPTION="HP Linux Imaging and Printing - Print, scan, fax drivers and service tools"
+HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing"
+SRC_URI="mirror://sourceforge/hplip/${P}.tar.gz
+ https://dev.gentoo.org/~billie/distfiles/${PN}-3.21.2-patches-1.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+IUSE="doc fax +hpcups hpijs kde libnotify libressl -libusb0 minimal parport policykit qt5 scanner +snmp static-ppds X"
+
+COMMON_DEPEND="
+ net-print/cups
+ sys-apps/dbus
+ virtual/jpeg:0
+ hpijs? ( net-print/cups-filters[foomatic] )
+ !libusb0? ( virtual/libusb:1 )
+ libusb0? ( virtual/libusb:0 )
+ ${PYTHON_DEPS}
+ !minimal? (
+ scanner? (
+ media-gfx/sane-backends
+ )
+ snmp? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ net-analyzer/net-snmp:=
+ $(python_gen_cond_dep 'net-dns/avahi[dbus,${PYTHON_MULTI_USEDEP}]')
+ )
+ )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ ${COMMON_DEPEND}
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ app-text/ghostscript-gpl
+ !minimal? (
+ $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]' 'python3*')
+ kernel_linux? ( virtual/udev )
+ $(python_gen_cond_dep '
+ >=dev-python/dbus-python-1.2.0-r1[${PYTHON_MULTI_USEDEP}]
+ dev-python/distro[${PYTHON_MULTI_USEDEP}]
+ fax? ( dev-python/reportlab[${PYTHON_MULTI_USEDEP}] )
+ qt5? (
+ >=dev-python/PyQt5-5.5.1[dbus,gui,widgets,${PYTHON_MULTI_USEDEP}]
+ libnotify? ( dev-python/notify2[${PYTHON_MULTI_USEDEP}] )
+ )
+ scanner? (
+ >=dev-python/reportlab-3.2[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pillow-3.1.1[${PYTHON_MULTI_USEDEP}]
+ X? (
+ || (
+ kde? ( kde-misc/skanlite )
+ media-gfx/xsane
+ media-gfx/sane-frontends
+ )
+ )
+ )
+ ')
+ )
+ policykit? ( sys-auth/polkit )
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+PATCHES=(
+ "${WORKDIR}/patches"
+)
+
+CONFIG_CHECK="~PARPORT ~PPDEV"
+ERROR_PARPORT="Please make sure kernel parallel port support is enabled (PARPORT and PPDEV)."
+
+#DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+For more information on setting up your printer please take
+a look at the hplip section of the gentoo printing guide:
+https://wiki.gentoo.org/wiki/Printing
+"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+
+ use scanner && ! use X && ewarn "You need USE=X for the scanner GUI."
+
+ use parport && linux-info_pkg_setup
+
+ if use minimal ; then
+ ewarn "Installing driver portions only, make sure you know what you are doing."
+ ewarn "Depending on the USE flags set for hpcups or hpijs the appropiate driver"
+ ewarn "is installed. If both USE flags are set hpijs overrides hpcups."
+ ewarn "This also disables fax, network, scanner and gui support!"
+ fi
+
+ if ! use hpcups && ! use hpijs ; then
+ ewarn "Installing neither hpcups (USE=-hpcups) nor hpijs (USE=-hpijs) driver,"
+ ewarn "which is probably not what you want."
+ ewarn "You will almost certainly not be able to print."
+ fi
+}
+
+src_prepare() {
+ default
+
+ python_fix_shebang .
+
+ # Make desktop files follow the specification
+ # Gentoo bug: https://bugs.gentoo.org/show_bug.cgi?id=443680
+ # Upstream bug: https://bugs.launchpad.net/hplip/+bug/1080324
+ sed -i -e '/^Categories=/s/Application;//' \
+ -e '/^Encoding=.*/d' hplip.desktop.in || die
+ sed -i -e '/^Categories=/s/Application;//' \
+ -e '/^Version=.*/d' \
+ -e '/^Comment=.*/d' hplip-systray.desktop.in || die
+
+ # Fix for Gentoo bug https://bugs.gentoo.org/show_bug.cgi?id=345725
+ # Upstream bug: https://bugs.launchpad.net/hplip/+bug/880847,
+ # https://bugs.launchpad.net/hplip/+bug/500086
+ local udevdir=$(get_udevdir)
+ sed -i -e "s|/etc/udev|${udevdir}|g" \
+ $(find . -type f -exec grep -l /etc/udev {} +) || die
+
+ # Force recognition of Gentoo distro by hp-check
+ sed -i \
+ -e "s:file('/etc/issue', 'r').read():'Gentoo':" \
+ installer/core_install.py || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local drv_build minimal_build
+
+ if use hpcups ; then
+ drv_build="$(use_enable hpcups hpcups-install)"
+ if use static-ppds ; then
+ drv_build="${drv_build} --enable-cups-ppd-install"
+ drv_build="${drv_build} --disable-cups-drv-install"
+ else
+ drv_build="${drv_build} --enable-cups-drv-install"
+ drv_build="${drv_build} --disable-cups-ppd-install"
+ fi
+ else
+ drv_build="--disable-hpcups-install"
+ drv_build="${drv_build} --disable-cups-drv-install"
+ drv_build="${drv_build} --disable-cups-ppd-install"
+ fi
+
+ if use hpijs ; then
+ drv_build="${drv_build} $(use_enable hpijs hpijs-install)"
+ if use static-ppds ; then
+ drv_build="${drv_build} --enable-foomatic-ppd-install"
+ drv_build="${drv_build} --disable-foomatic-drv-install"
+ else
+ drv_build="${drv_build} --enable-foomatic-drv-install"
+ drv_build="${drv_build} --disable-foomatic-ppd-install"
+ fi
+ else
+ drv_build="${drv_build} --disable-hpijs-install"
+ drv_build="${drv_build} --disable-foomatic-drv-install"
+ drv_build="${drv_build} --disable-foomatic-ppd-install"
+ fi
+
+ if use minimal ; then
+ if use hpijs ; then
+ minimal_build="--enable-hpijs-only-build"
+ else
+ minimal_build="--disable-hpijs-only-build"
+ fi
+ if use hpcups ; then
+ minimal_build="${minimal_build} --enable-hpcups-only-build"
+ else
+ minimal_build="${minimal_build} --disable-hpcups-only-build"
+ fi
+ minimal_build="${minimal_build} --disable-fax-build"
+ minimal_build="${minimal_build} --disable-network-build"
+ minimal_build="${minimal_build} --disable-scan-build"
+ minimal_build="${minimal_build} --disable-gui-build"
+ else
+ if use fax ; then
+ minimal_build="${minimal_build} --enable-fax-build"
+ else
+ minimal_build="${minimal_build} --disable-fax-build"
+ fi
+ if use snmp ; then
+ minimal_build="${minimal_build} --enable-network-build"
+ else
+ minimal_build="${minimal_build} --disable-network-build"
+ fi
+ if use scanner ; then
+ minimal_build="${minimal_build} --enable-scan-build"
+ else
+ minimal_build="${minimal_build} --disable-scan-build"
+ fi
+ if use qt5 ; then
+ minimal_build="${minimal_build} --enable-qt5"
+ minimal_build="${minimal_build} --enable-gui-build"
+ else
+ minimal_build="${minimal_build} --disable-gui-build"
+ minimal_build="${minimal_build} --disable-qt5"
+ fi
+ fi
+
+ # disable class driver for now
+ econf \
+ --disable-class-driver \
+ --disable-foomatic-rip-hplip-install \
+ --disable-cups11-build \
+ --disable-lite-build \
+ --disable-shadow-build \
+ --disable-qt3 \
+ --disable-qt4 \
+ --disable-udev_sysfs_rules \
+ --with-cupsbackenddir=$(cups-config --serverbin)/backend \
+ --with-cupsfilterdir=$(cups-config --serverbin)/filter \
+ --with-docdir=/usr/share/doc/${PF} \
+ --with-htmldir=/usr/share/doc/${PF}/html \
+ --enable-hpps-install \
+ --enable-dbus-build \
+ ${drv_build} \
+ ${minimal_build} \
+ $(use_enable doc doc-build) \
+ $(use_enable libusb0 libusb01_build) \
+ $(use_enable parport pp-build) \
+ $(use_enable policykit)
+
+ # hpijs ppds are created at configure time but are not installed (3.17.11)
+
+ # Use system foomatic-rip for hpijs driver instead of foomatic-rip-hplip
+ # The hpcups driver does not use foomatic-rip
+ #local i
+ #for i in ppd/hpijs/*.ppd.gz ; do
+ # rm -f ${i}.temp || die
+ # gunzip -c ${i} | sed 's/foomatic-rip-hplip/foomatic-rip/g' | \
+ # gzip > ${i}.temp || die
+ # mv ${i}.temp ${i} || die
+ #done
+}
+
+src_install() {
+ # Disable parallel install
+ # Gentoo Bug: https://bugs.gentoo.org/show_bug.cgi?id=578018
+ emake -j1 DESTDIR="${D}" install
+ einstalldocs
+ # default
+
+ # Installed by sane-backends
+ # Gentoo Bug: https://bugs.gentoo.org/show_bug.cgi?id=201023
+ rm -f "${ED}"/etc/sane.d/dll.conf || die
+
+ # Remove desktop and autostart files
+ # Gentoo Bug: https://bugs.gentoo.org/show_bug.cgi?id=638770
+ use qt5 || {
+ rm -Rf "${ED}"/usr/share/applications "${ED}"/etc/xdg
+ }
+
+ rm -f "${ED}"/usr/share/doc/${PF}/{copyright,README_LIBJPG,COPYING} || die
+ rmdir --ignore-fail-on-non-empty "${ED}"/usr/share/doc/${PF}/ || die
+
+ # Remove hal fdi files
+ rm -rf "${ED}"/usr/share/hal || die
+
+ find "${D}" -name '*.la' -delete || die
+
+ python_optimize "${ED}"/usr/share/hplip
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}