summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-proxy/dnsproxy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-proxy/dnsproxy')
-rw-r--r--net-proxy/dnsproxy/Manifest1
-rw-r--r--net-proxy/dnsproxy/dnsproxy-1.16-r1.ebuild41
-rw-r--r--net-proxy/dnsproxy/files/dnsproxy-1.16-include.patch10
-rw-r--r--net-proxy/dnsproxy/files/dnsproxy.confd3
-rw-r--r--net-proxy/dnsproxy/files/dnsproxy.initd31
-rw-r--r--net-proxy/dnsproxy/metadata.xml9
6 files changed, 95 insertions, 0 deletions
diff --git a/net-proxy/dnsproxy/Manifest b/net-proxy/dnsproxy/Manifest
new file mode 100644
index 000000000000..2985c8a0441c
--- /dev/null
+++ b/net-proxy/dnsproxy/Manifest
@@ -0,0 +1 @@
+DIST dnsproxy-1.16.tar.gz 47239 SHA256 5d9df5ce547409a0e33888853f0fbaf7c599311992191c939010d2bc57ed63de SHA512 f02498de963555556b656be432612e6d9ed72f29c838672c45ed2b4100cd6ae30b19091cbd33587259935342c86a733b820d2df54a8c3c1c699edb050b1b3d2b WHIRLPOOL cc55fd72966236be4329f6d9320b9d1da0bd630634db5d025d83134f1f4a00a6662ab0af53163b642930f539d07c9a406a85ffccbe608a8b36fa5db62649db6e
diff --git a/net-proxy/dnsproxy/dnsproxy-1.16-r1.ebuild b/net-proxy/dnsproxy/dnsproxy-1.16-r1.ebuild
new file mode 100644
index 000000000000..7e7b39a5fb7c
--- /dev/null
+++ b/net-proxy/dnsproxy/dnsproxy-1.16-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="The dnsproxy daemon is a proxy for DNS queries"
+HOMEPAGE="http://www.wolfermann.org/dnsproxy.html"
+SRC_URI="http://www.wolfermann.org/${P}.tar.gz"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-libs/libevent"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-include.patch
+ append-flags -D_GNU_SOURCE
+}
+
+src_compile() {
+ emake ${PN}
+}
+
+src_install() {
+ dosbin ${PN}
+ keepdir /var/empty
+
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ insinto /etc/${PN}
+ newins ${PN}.conf ${PN}.conf.dist
+
+ dodoc README
+ doman ${PN}.1
+}
diff --git a/net-proxy/dnsproxy/files/dnsproxy-1.16-include.patch b/net-proxy/dnsproxy/files/dnsproxy-1.16-include.patch
new file mode 100644
index 000000000000..96296f5ed2d8
--- /dev/null
+++ b/net-proxy/dnsproxy/files/dnsproxy-1.16-include.patch
@@ -0,0 +1,10 @@
+--- dnsproxy.c.orig 2010-01-11 16:02:00.000000000 +0100
++++ dnsproxy.c 2010-10-27 05:07:05.000000000 +0200
+@@ -28,6 +28,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <grp.h> /* setgroups() */
+ #include <unistd.h>
+
+ #define GLOBALS 1
diff --git a/net-proxy/dnsproxy/files/dnsproxy.confd b/net-proxy/dnsproxy/files/dnsproxy.confd
new file mode 100644
index 000000000000..48f8a51e57f0
--- /dev/null
+++ b/net-proxy/dnsproxy/files/dnsproxy.confd
@@ -0,0 +1,3 @@
+# Options for dnsproxy daemon (rarely you need to change these)
+DNSPROXY_CONFFILE="/etc/dnsproxy/dnsproxy.conf"
+DNSPROXY_PIDFILE="/var/run/dnsproxy.pid"
diff --git a/net-proxy/dnsproxy/files/dnsproxy.initd b/net-proxy/dnsproxy/files/dnsproxy.initd
new file mode 100644
index 000000000000..000fc95eaa2b
--- /dev/null
+++ b/net-proxy/dnsproxy/files/dnsproxy.initd
@@ -0,0 +1,31 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -e "${DNSPROXY_CONFFILE}" ] ; then
+ eerror "You need to create and select the configuration file first."
+ eerror "An example can be found in /etc/dnsproxy/dnsproxy.conf.dist"
+ return 1
+ fi
+}
+
+start() {
+ ebegin "Starting dnsproxy"
+ checkconfig && \
+ start-stop-daemon --start --make-pidfile \
+ --quiet -b --pidfile ${DNSPROXY_PIDFILE} \
+ --exec /usr/sbin/dnsproxy -- -c "${DNSPROXY_CONFFILE}"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping dnsproxy"
+ start-stop-daemon --stop --quiet \
+ --pidfile ${DNSPROXY_PIDFILE}
+ eend $?
+}
diff --git a/net-proxy/dnsproxy/metadata.xml b/net-proxy/dnsproxy/metadata.xml
new file mode 100644
index 000000000000..a2bd924e4079
--- /dev/null
+++ b/net-proxy/dnsproxy/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version = '1.0' encoding = 'UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+<longdescription>The dnsproxy daemon is a proxy for DNS queries. It forwards these queries to
+two previously configured nameservers: one for authoritative queries and another
+for recursive queries. The received answers are sent back to the client unchanged.
+No local caching is done.</longdescription>
+</pkgmetadata>