summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <Marek.Szuba@cern.ch>2016-04-21 11:57:19 +0200
committerAnthony G. Basile <blueness@gentoo.org>2016-04-23 02:49:46 -0400
commit81b6ce6c6fc4b2e7d5f04973e144a9704fcf04e5 (patch)
tree3b63ce26c2ac0f3294f718766a1ad9ccda6eb271 /net-proxy/obfs4proxy/obfs4proxy-9999.ebuild
parentsys-fs/hfsplusutils: add support for USE=static-libs (diff)
downloadgentoo-81b6ce6c6fc4b2e7d5f04973e144a9704fcf04e5.tar.gz
gentoo-81b6ce6c6fc4b2e7d5f04973e144a9704fcf04e5.tar.bz2
gentoo-81b6ce6c6fc4b2e7d5f04973e144a9704fcf04e5.zip
New ebuild: net-proxy/obfs4proxy, plus dependencies.
A new obfuscating proxy for Tor bridges which supports, among others, the OBFS4 protocol. It depends on three packages which were not in Portage and therefore have just had ebuild files created as well: dev-go/ed25519, dev-go/goptlib, and dev-go/siphash. Relevant Gentoo bugs: #580582, #580622, #580626, #580628.
Diffstat (limited to 'net-proxy/obfs4proxy/obfs4proxy-9999.ebuild')
-rw-r--r--net-proxy/obfs4proxy/obfs4proxy-9999.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-proxy/obfs4proxy/obfs4proxy-9999.ebuild b/net-proxy/obfs4proxy/obfs4proxy-9999.ebuild
new file mode 100644
index 000000000000..5bc4c27b31d8
--- /dev/null
+++ b/net-proxy/obfs4proxy/obfs4proxy-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit golang-build
+
+EGO_SRC=git.torproject.org/pluggable-transports/obfs4.git
+EGO_PN=${EGO_SRC}/...
+
+if [[ ${PV} == "9999" ]];
+then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="${P}"
+ SRC_URI="https://github.com/Yawning/obfs4/archive/${P}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="An obfuscating proxy supporting Tor's pluggable transport protocol obfs4"
+HOMEPAGE="https://github.com/Yawning/obfs4"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-go/ed25519
+ dev-go/go-crypto
+ dev-go/go-net
+ dev-go/goptlib
+ dev-go/siphash"
+RDEPEND=""
+
+src_compile() {
+ golang-build_src_compile
+ local binfile=$(find "${T}" -name a.out)
+ [[ -x ${binfile} ]] || die "a.out not found"
+ cp -a ${binfile} obfs4proxy
+}
+
+src_install() {
+ default
+ dobin obfs4proxy || die "install failed"
+ cd src/${EGO_SRC}
+ doman doc/obfs4proxy.1 || die "install failed"
+ dodoc README.md ChangeLog doc/obfs4-spec.txt || die "install failed"
+}