summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-03-21 15:26:50 +0100
committerDavid Seifert <soap@gentoo.org>2020-03-21 15:26:50 +0100
commite8b3bd1a44ebf294583e0d0f8073e7d6a193e354 (patch)
treee598ca6e25ab411bf8dea1566ab9d03b662dd85d /net-proxy/pingtunnel
parentnet-proxy/pingtunnel: Port to EAPI 7 (diff)
downloadgentoo-e8b3bd1a44ebf294583e0d0f8073e7d6a193e354.tar.gz
gentoo-e8b3bd1a44ebf294583e0d0f8073e7d6a193e354.tar.bz2
gentoo-e8b3bd1a44ebf294583e0d0f8073e7d6a193e354.zip
net-proxy/pingtunnel: Use proper POSIX #include's
Closes: https://bugs.gentoo.org/713758 Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-proxy/pingtunnel')
-rw-r--r--net-proxy/pingtunnel/files/pingtunnel-0.72-musl.patch10
-rw-r--r--net-proxy/pingtunnel/pingtunnel-0.72.ebuild5
2 files changed, 14 insertions, 1 deletions
diff --git a/net-proxy/pingtunnel/files/pingtunnel-0.72-musl.patch b/net-proxy/pingtunnel/files/pingtunnel-0.72-musl.patch
new file mode 100644
index 000000000000..cf421365917d
--- /dev/null
+++ b/net-proxy/pingtunnel/files/pingtunnel-0.72-musl.patch
@@ -0,0 +1,10 @@
+--- a/ptunnel.h
++++ b/ptunnel.h
+@@ -45,7 +45,6 @@
+
+ // Includes
+ #ifndef WIN32
+- #include <sys/unistd.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
diff --git a/net-proxy/pingtunnel/pingtunnel-0.72.ebuild b/net-proxy/pingtunnel/pingtunnel-0.72.ebuild
index cc137990d138..0536913f7464 100644
--- a/net-proxy/pingtunnel/pingtunnel-0.72.ebuild
+++ b/net-proxy/pingtunnel/pingtunnel-0.72.ebuild
@@ -21,7 +21,10 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}"/PingTunnel
-PATCHES=( "${FILESDIR}"/${P}_makefile.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}_makefile.patch
+ "${FILESDIR}"/${P}-musl.patch
+)
HTML_DOCS=( web/. )
src_configure() {