summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-11-21 21:16:00 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-21 22:35:33 +0100
commitd9f811620f7203afd687b396b4d21e2d3338d445 (patch)
treec1d60cb958529585f31d00742346e3a8ba55e6ae /net-proxy/squirm/squirm-1.26-r1.ebuild
parentmedia-video/mpv: remove old (diff)
downloadgentoo-d9f811620f7203afd687b396b4d21e2d3338d445.tar.gz
gentoo-d9f811620f7203afd687b396b4d21e2d3338d445.tar.bz2
gentoo-d9f811620f7203afd687b396b4d21e2d3338d445.zip
net-proxy/squirm: Fix build with GCC-5
Adding squid to DEPEND because squid user is expected at install Gentoo-bug: 554800 Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2887
Diffstat (limited to 'net-proxy/squirm/squirm-1.26-r1.ebuild')
-rw-r--r--net-proxy/squirm/squirm-1.26-r1.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/net-proxy/squirm/squirm-1.26-r1.ebuild b/net-proxy/squirm/squirm-1.26-r1.ebuild
index e098e3060f5e..7892f71430f9 100644
--- a/net-proxy/squirm/squirm-1.26-r1.ebuild
+++ b/net-proxy/squirm/squirm-1.26-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI=6
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="A redirector for Squid"
HOMEPAGE="http://squirm.foote.com.au"
@@ -16,17 +16,19 @@ KEYWORDS="~amd64 ppc x86"
IUSE=""
RDEPEND="net-proxy/squid"
+DEPEND="${RDEPEND}"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-gcc5.patch
+)
src_compile() {
emake CC="$(tc-getCC)" LDOPTS="${LDFLAGS}"
}
src_install() {
- emake PREFIX="${ED}/opt/squirm" install
+ emake PREFIX="${ED%/}/opt/squirm" install
}
pkg_postinst() {