summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2020-08-29 15:37:32 +0100
committerSam James <sam@gentoo.org>2020-09-02 22:43:38 +0000
commit77f20cf7081e509811951ab7cd29c894f1784e4f (patch)
treead39cbac0e9e5217ef2a3d188be896f009c964c8 /net-proxy
parentdev-python/kaitaistruct: Add Python 3.8 to PYTHON_COMPAT (diff)
downloadgentoo-77f20cf7081e509811951ab7cd29c894f1784e4f.tar.gz
gentoo-77f20cf7081e509811951ab7cd29c894f1784e4f.tar.bz2
gentoo-77f20cf7081e509811951ab7cd29c894f1784e4f.zip
net-proxy/mitmproxy: Bump to version 5.2.0
* Add Python 3.8 to PYTHON_COMPAT. * Correct the license; it changed from GPLv3 to MIT in 2013. * Enable more tests. * Remove unnecessary test phase and setup tools rdep. * Use app-arch/brotli[python] instead of dev-python/brotlipy. Closes: https://bugs.gentoo.org/718458 Closes: https://bugs.gentoo.org/727294 Closes: https://bugs.gentoo.org/739494 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matt Smith <matt@offtopica.uk> Closes: https://github.com/gentoo/gentoo/pull/17315 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/mitmproxy/Manifest1
-rw-r--r--net-proxy/mitmproxy/mitmproxy-5.2.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/net-proxy/mitmproxy/Manifest b/net-proxy/mitmproxy/Manifest
index caa1bf24f988..9d9052746838 100644
--- a/net-proxy/mitmproxy/Manifest
+++ b/net-proxy/mitmproxy/Manifest
@@ -1 +1,2 @@
DIST mitmproxy-5.1.1.tar.gz 27223155 BLAKE2B 38369eb07c41bde9f8e8c246ab5cc4fc6edfcd222f353624f4d2ae193f176228471aafdadd1b65238ccd808d778a69e1d140035be9116b87a75c286493747fe8 SHA512 ac5cd82d4d89590b57625661c493aca6a702605c612ea1acd9e0d0806067d47f60085ee68260bba2a10dc343410ae6a76ea1575287a0e312e4467a4e8485c6e1
+DIST mitmproxy-5.2.tar.gz 27251381 BLAKE2B d6bc5de8a3840a880664f52e011736cb640d324c6aa3846d4f2b3c2fc0d49467ab8ad3e8268a591cbe19d9f6dda5acc37fa2de705b4de1c1920b5003e10ea457 SHA512 6073c73b24618d6f64c4e99f199ebb6bc4157a3f83bfa7aff10a113f8dde823715e95bdf4202a1526dc0856d120858d32842b814327c3b98452b629fccb1790d
diff --git a/net-proxy/mitmproxy/mitmproxy-5.2.ebuild b/net-proxy/mitmproxy/mitmproxy-5.2.ebuild
new file mode 100644
index 000000000000..d5ba12b4c7c2
--- /dev/null
+++ b/net-proxy/mitmproxy/mitmproxy-5.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7,8} )
+inherit distutils-r1
+
+DESCRIPTION="An interactive, SSL-capable, man-in-the-middle HTTP proxy"
+HOMEPAGE="https://mitmproxy.org/"
+SRC_URI="https://github.com/mitmproxy/mitmproxy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=app-arch/brotli-1.0.0[python,${PYTHON_USEDEP}]
+ >=dev-python/blinker-1.4[${PYTHON_USEDEP}]
+ >=dev-python/certifi-2015.11.20.1[${PYTHON_USEDEP}]
+ >=dev-python/click-6.2[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.9[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/hyper-h2-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/hyperframe-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/kaitaistruct-0.7[${PYTHON_USEDEP}]
+ >=dev-python/ldap3-2.5[${PYTHON_USEDEP}]
+ >=dev-python/passlib-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.6.0[${PYTHON_USEDEP}]
+ >=dev-python/publicsuffix-2.20190205[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.5[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.3[${PYTHON_USEDEP}]
+ >=dev-python/pyperclip-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.9.1[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.15[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-1.5.4[${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.3[${PYTHON_USEDEP}]
+ >=dev-python/urwid-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/wsproto-0.11.0[${PYTHON_USEDEP}]
+ >=dev-python/zstandard-0.11.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/flask-1.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-4.50.8[${PYTHON_USEDEP}]
+ >=dev-python/parver-0.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.10.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.9.1[${PYTHON_USEDEP}]
+ >=dev-python/zstandard-0.8.1[${PYTHON_USEDEP}]
+ )"
+
+RESTRICT="!test? ( test )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # loosen dependencies
+ sed -i \
+ -e '/>/s/>.*/",/g' \
+ -e '/urwid/s/==2\.0\.1,!=2\.1\.0//' \
+ setup.py || die
+
+ # remove failing test
+ sed -i 's/test_get_version/_&/g' test/mitmproxy/test_version.py || die
+
+ # requires asynctest
+ rm test/mitmproxy/addons/test_readfile.py || die
+
+ distutils-r1_python_prepare_all
+}