summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-06-20 00:54:10 -0400
committerAaron Bauman <bman@gentoo.org>2020-06-20 00:54:10 -0400
commitcafca86e0ff9ae35a166ce78bf6fb71973f43da6 (patch)
treec07c51efa1268682097897f9e51e7c5b77083599 /net-proxy
parentdev-python/*: drop last-rited pkgs (diff)
downloadgentoo-cafca86e0ff9ae35a166ce78bf6fb71973f43da6.tar.gz
gentoo-cafca86e0ff9ae35a166ce78bf6fb71973f43da6.tar.bz2
gentoo-cafca86e0ff9ae35a166ce78bf6fb71973f43da6.zip
net-proxy/mitmproxy: drop last-rited pkg
Closes: https://bugs.gentoo.org/718458 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/mitmproxy/Manifest2
-rw-r--r--net-proxy/mitmproxy/metadata.xml8
-rw-r--r--net-proxy/mitmproxy/mitmproxy-4.0.4.ebuild85
-rw-r--r--net-proxy/mitmproxy/mitmproxy-5.1.1.ebuild95
4 files changed, 0 insertions, 190 deletions
diff --git a/net-proxy/mitmproxy/Manifest b/net-proxy/mitmproxy/Manifest
deleted file mode 100644
index 992813c1a41d..000000000000
--- a/net-proxy/mitmproxy/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST mitmproxy-4.0.4.tar.gz 27131713 BLAKE2B 2748b0f3b66e1f5840aae792a1b4cd8ef8efa3673fa24bc0c3e15474b36d68c0f6b2203cf629b6444545b8c6223752232b2ce8526290fe5d74916946e8917a03 SHA512 e08ea8b1c75a95b822c463625509037bbc8a979161cacaa1f0185f98df8d6d7e5400925365dbbe70d18751251b1005824f739a8cd035c0389f7b4aea562adfb3
-DIST mitmproxy-5.1.1.tar.gz 27223155 BLAKE2B 38369eb07c41bde9f8e8c246ab5cc4fc6edfcd222f353624f4d2ae193f176228471aafdadd1b65238ccd808d778a69e1d140035be9116b87a75c286493747fe8 SHA512 ac5cd82d4d89590b57625661c493aca6a702605c612ea1acd9e0d0806067d47f60085ee68260bba2a10dc343410ae6a76ea1575287a0e312e4467a4e8485c6e1
diff --git a/net-proxy/mitmproxy/metadata.xml b/net-proxy/mitmproxy/metadata.xml
deleted file mode 100644
index c7003e858b46..000000000000
--- a/net-proxy/mitmproxy/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="pypi">mitmproxy</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/net-proxy/mitmproxy/mitmproxy-4.0.4.ebuild b/net-proxy/mitmproxy/mitmproxy-4.0.4.ebuild
deleted file mode 100644
index 34ecccf7049a..000000000000
--- a/net-proxy/mitmproxy/mitmproxy-4.0.4.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 )
-inherit distutils-r1
-
-DESCRIPTION="An interactive, SSL-capable, man-in-the-middle HTTP proxy"
-HOMEPAGE="https://mitmproxy.org/"
-SRC_URI="https://github.com/mitmproxy/mitmproxy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="
- >=dev-python/blinker-1.4[${PYTHON_USEDEP}]
- >=dev-python/brotlipy-0.7.0[${PYTHON_USEDEP}]
- >=dev-python/certifi-2015.11.20.1[${PYTHON_USEDEP}]
- >=dev-python/click-6.2[${PYTHON_USEDEP}]
- >=dev-python/cryptography-2.1.4[${PYTHON_USEDEP}]
- >=dev-python/hyper-h2-3.0.1[${PYTHON_USEDEP}]
- >=dev-python/hyperframe-5.1.0[${PYTHON_USEDEP}]
- >=dev-python/kaitaistruct-0.7[${PYTHON_USEDEP}]
- >=dev-python/ldap3-2.5[${PYTHON_USEDEP}]
- >=dev-python/passlib-1.6.5[${PYTHON_USEDEP}]
- >=dev-python/protobuf-python-3.6.0[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-0.3.1[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-17.5[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-2.1.3[${PYTHON_USEDEP}]
- >=dev-python/pyperclip-1.6.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.9.1[${PYTHON_USEDEP}]
- >=dev-python/ruamel-yaml-0.15[${PYTHON_USEDEP}]
- >=dev-python/sortedcontainers-1.5.4[${PYTHON_USEDEP}]
- >=www-servers/tornado-4.3[${PYTHON_USEDEP}]
- >=dev-python/urwid-2.0.1[${PYTHON_USEDEP}]
- >=dev-python/wsproto-0.11.0[${PYTHON_USEDEP}]
-"
-
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- >=dev-python/flask-1.0[${PYTHON_USEDEP}]
- >=dev-python/parver-0.1[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.3[${PYTHON_USEDEP}]
- >=dev-python/requests-2.9.1[${PYTHON_USEDEP}]
- )"
-
-RESTRICT="!test? ( test )"
-
-python_prepare_all() {
- # loosen dependencies
- sed -i '/>/s/>.*/",/g' setup.py || die
-
- # remove failing tests
- sed -e 's/test_iframe_injector/_&/g' \
- -i test/examples/test_examples.py || die
-
- sed -e 's/test_find_unclaimed_URLs/_&/g' \
- -i test/examples/test_xss_scanner.py || die
-
- rm test/mitmproxy/addons/test_readfile.py || die
-
- sed \
- -e 's/test_mode_none_should_pass_without_sni/_&/g' \
- -e 's/test_mode_strict_w_pemfile_should_pass/_&/g' \
- -e 's/test_mode_strict_w_confdir_should_pass/_&/g' \
- -i test/mitmproxy/net/test_tcp.py || die
-
- sed \
- -e 's/test_verification_w_confdir/_&/g' \
- -e 's/test_verification_w_pemfile/_&/g' \
- -i test/mitmproxy/proxy/test_server.py || die
-
- # needs pytest-asyncio
- rm test/mitmproxy/tools/test_main.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- pytest -vv || die
-}
diff --git a/net-proxy/mitmproxy/mitmproxy-5.1.1.ebuild b/net-proxy/mitmproxy/mitmproxy-5.1.1.ebuild
deleted file mode 100644
index 1e3fcc5ed4b7..000000000000
--- a/net-proxy/mitmproxy/mitmproxy-5.1.1.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6,7} )
-inherit distutils-r1
-
-DESCRIPTION="An interactive, SSL-capable, man-in-the-middle HTTP proxy"
-HOMEPAGE="https://mitmproxy.org/"
-SRC_URI="https://github.com/mitmproxy/mitmproxy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="
- >=dev-python/blinker-1.4[${PYTHON_USEDEP}]
- >=dev-python/brotlipy-0.7.0[${PYTHON_USEDEP}]
- >=dev-python/certifi-2015.11.20.1[${PYTHON_USEDEP}]
- >=dev-python/click-6.2[${PYTHON_USEDEP}]
- >=dev-python/cryptography-2.9[${PYTHON_USEDEP}]
- >=dev-python/flask-1.0.4[${PYTHON_USEDEP}]
- >=dev-python/hyper-h2-3.0.1[${PYTHON_USEDEP}]
- >=dev-python/hyperframe-5.1.0[${PYTHON_USEDEP}]
- >=dev-python/kaitaistruct-0.7[${PYTHON_USEDEP}]
- >=dev-python/ldap3-2.5[${PYTHON_USEDEP}]
- >=dev-python/passlib-1.6.5[${PYTHON_USEDEP}]
- >=dev-python/protobuf-python-3.6.0[${PYTHON_USEDEP}]
- >=dev-python/publicsuffix-2.20190205[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-0.3.1[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-17.5[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-2.1.3[${PYTHON_USEDEP}]
- >=dev-python/pyperclip-1.6.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.9.1[${PYTHON_USEDEP}]
- >=dev-python/ruamel-yaml-0.15[${PYTHON_USEDEP}]
- >=dev-python/sortedcontainers-1.5.4[${PYTHON_USEDEP}]
- >=www-servers/tornado-4.3[${PYTHON_USEDEP}]
- >=dev-python/urwid-2.0.1[${PYTHON_USEDEP}]
- >=dev-python/wsproto-0.11.0[${PYTHON_USEDEP}]
-"
-
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- >=dev-python/flask-1.0[${PYTHON_USEDEP}]
- >=dev-python/hypothesis-4.50.8[${PYTHON_USEDEP}]
- >=dev-python/parver-0.1[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.3[${PYTHON_USEDEP}]
- >=dev-python/requests-2.9.1[${PYTHON_USEDEP}]
- >=dev-python/zstandard-0.8.1[${PYTHON_USEDEP}]
- )"
-
-RESTRICT="!test? ( test )"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # loosen dependencies
- sed -i '/>/s/>.*/",/g' setup.py || die
-
- # fix brotli dependency
- sed -i 's/Brotli/brotlipy/g' setup.py || die
-
- # remove failing tests
- sed -e 's/test_iframe_injector/_&/g' \
- -i test/examples/test_examples.py || die
-
- sed -e 's/test_find_unclaimed_URLs/_&/g' \
- -i test/examples/test_xss_scanner.py || die
-
- rm test/mitmproxy/addons/test_readfile.py || die
-
- sed \
- -e 's/test_mode_none_should_pass_without_sni/_&/g' \
- -e 's/test_mode_strict_w_pemfile_should_pass/_&/g' \
- -e 's/test_mode_strict_w_confdir_should_pass/_&/g' \
- -i test/mitmproxy/net/test_tcp.py || die
-
- sed \
- -e 's/test_verification_w_confdir/_&/g' \
- -e 's/test_verification_w_pemfile/_&/g' \
- -i test/mitmproxy/proxy/test_server.py || die
-
- # needs pytest-asyncio
- rm test/mitmproxy/tools/test_main.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- pytest -vv || die
-}