summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-27 06:15:51 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-27 08:16:55 +0200
commit600e33d66bc80bfdc9f55dfae027f5c8a6d94ef9 (patch)
treee3a0abfa1ddefc3a82b9d2073e6ed9a5ecc94843 /net-voip/telepathy-rakia/telepathy-rakia-0.8.0-r1.ebuild
parentdev-ruby/simplecov-html: add 0.12.3 (diff)
downloadgentoo-600e33d66bc80bfdc9f55dfae027f5c8a6d94ef9.tar.gz
gentoo-600e33d66bc80bfdc9f55dfae027f5c8a6d94ef9.tar.bz2
gentoo-600e33d66bc80bfdc9f55dfae027f5c8a6d94ef9.zip
net-voip/telepathy-rakia: Port to py3 / any-r1
Backport a py3 compat patch and correct the package to use python-any-r1 as it does not seem to install anything Python. Closes: https://bugs.gentoo.org/735434 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-voip/telepathy-rakia/telepathy-rakia-0.8.0-r1.ebuild')
-rw-r--r--net-voip/telepathy-rakia/telepathy-rakia-0.8.0-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-voip/telepathy-rakia/telepathy-rakia-0.8.0-r1.ebuild b/net-voip/telepathy-rakia/telepathy-rakia-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..e6a644508e34
--- /dev/null
+++ b/net-voip/telepathy-rakia/telepathy-rakia-0.8.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit python-any-r1
+
+DESCRIPTION="A SIP connection manager for Telepathy based around the Sofia-SIP library"
+HOMEPAGE="https://telepathy.freedesktop.org/"
+SRC_URI="https://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz
+ https://patch-diff.githubusercontent.com/raw/TelepathyIM/telepathy-rakia/pull/1.patch
+ -> ${P}-py3.patch"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-linux"
+RESTRICT="test"
+
+COMMON_DEPEND="
+ >=dev-libs/dbus-glib-0.60
+ >=dev-libs/glib-2.30:2
+ >=net-libs/sofia-sip-1.12.11
+ >=net-libs/telepathy-glib-0.17.6
+ >=sys-apps/dbus-0.60
+"
+RDEPEND="${COMMON_DEPEND}
+ !net-voip/telepathy-sofiasip
+"
+# telepathy-rakia was formerly known as telepathy-sofiasip
+DEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/libxslt
+"
+# eautoreconf requires: gtk-doc-am
+
+PATCHES=(
+ "${DISTDIR}"/${P}-py3.patch
+)
+
+src_configure() {
+ econf --disable-fatal-warnings
+}