summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2023-08-30 23:26:57 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-09-22 11:31:02 +0300
commit1a33da47e59649895b62ba70111a3d046c06685a (patch)
tree80725da428dae6adcb64e95cdc41f04da12fd20b /net-voip
parentapp-text/podofo: add 0.10.1 (diff)
downloadgentoo-1a33da47e59649895b62ba70111a3d046c06685a.tar.gz
gentoo-1a33da47e59649895b62ba70111a3d046c06685a.tar.bz2
gentoo-1a33da47e59649895b62ba70111a3d046c06685a.zip
net-voip/sipvicious: 0.3.4-r1 (PEP517).
Closes: https://bugs.gentoo.org/910014 Signed-off-by: Jaco Kroon <jaco@uls.co.za> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/sipvicious/sipvicious-0.3.4-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-voip/sipvicious/sipvicious-0.3.4-r1.ebuild b/net-voip/sipvicious/sipvicious-0.3.4-r1.ebuild
new file mode 100644
index 000000000000..c7af6c8c7db5
--- /dev/null
+++ b/net-voip/sipvicious/sipvicious-0.3.4-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_SINGLE_IMPL=1
+
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="SIPVicious is a SIP security package"
+HOMEPAGE="https://github.com/EnableSecurity/sipvicious/wiki"
+SRC_URI="https://github.com/EnableSecurity/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="$(python_gen_cond_dep '
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ ')"
+
+src_prepare() {
+ default
+ sed -re 's:man/man1:share/man/man1:' -i setup.py || die "Error updating man page installation location."
+}