summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimone Scanzoni <nonno.cicala@libero.it>2020-09-16 10:57:37 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-09-16 11:04:12 +0300
commit31b2228503ff9978e7713c43bbcb2de18e98df0c (patch)
treedec1d1a5b096292694a94868ff01d48cf857667f /net-vpn/logmein-hamachi
parentmedia-tv/v4l-dvb-saa716x: update SRC_URI (diff)
downloadgentoo-31b2228503ff9978e7713c43bbcb2de18e98df0c.tar.gz
gentoo-31b2228503ff9978e7713c43bbcb2de18e98df0c.tar.bz2
gentoo-31b2228503ff9978e7713c43bbcb2de18e98df0c.zip
net-vpn/logmein-hamachi: version bump to 2.1.0.203
Closes: https://bugs.gentoo.org/696538 Signed-off-by: Simone Scanzoni <nonno.cicala@libero.it> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-vpn/logmein-hamachi')
-rw-r--r--net-vpn/logmein-hamachi/Manifest2
-rw-r--r--net-vpn/logmein-hamachi/logmein-hamachi-2.1.0.203.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/net-vpn/logmein-hamachi/Manifest b/net-vpn/logmein-hamachi/Manifest
index 8ef27ad859db..37fe79750def 100644
--- a/net-vpn/logmein-hamachi/Manifest
+++ b/net-vpn/logmein-hamachi/Manifest
@@ -2,3 +2,5 @@ DIST logmein-hamachi-2.1.0.174-x64.tgz 1367599 BLAKE2B 338ccdcf8ab6d94bd689908dd
DIST logmein-hamachi-2.1.0.174-x86.tgz 1290587 BLAKE2B efcb3629097822360c126a4951293f43a885925f9c273e0f70b71f6613b6c7b8d78253e5d0d1a9f63218536359d92095b60ceacff2579854f0102c44c8dd7d66 SHA512 0f8da40d6508dab71680a74065649d51288c345849f74c7e2682040b720536f5324d142690aa879f9c5e8f1717654ab93357f4b960a567f5b584609bd814e82f
DIST logmein-hamachi-2.1.0.198-x64.tgz 1332004 BLAKE2B 72447c4a87e32aaafc424abcfece72645881e8da0cfd20f12e6e4f9470005c9f735588269541c1ef12cc92cf287cd7804f14ec32e56ac860e6d034271f688b9d SHA512 7ac7fb64c2ae1864f023138778f05681f852a5b4289638ca4905bf9c4ef7612e657b3641193abf33900e145c667391e9d438aadfcdbc710c0be5790816777d8f
DIST logmein-hamachi-2.1.0.198-x86.tgz 1242014 BLAKE2B 41c2efc83f2dac62b18286a10f219e9df479473b403f10ac2306350694435804725e91053c841ac06b4414264071e39dbc26caaeea500de8815dce681a01aa5b SHA512 67a465359ebe11c572308f38d6a0221bbd61b1a96eddb5235c112db6c060f392a9d05cb88b7ef82d6011b468e89bc72269e39bf421b656a815df4c9c1ff19113
+DIST logmein-hamachi-2.1.0.203-x64.tgz 1622719 BLAKE2B 7be3e4a496adaf5a42c1d16fd8a50c9d079da8d729de4cd1c7c203ffd5315423c222f5ccdbd54058a547168f2bae32df80f8f191e2f91e4dd77aa8516eeaaf0a SHA512 f34d65792162003f230d0531faf7c64aeacf6b7014c1266f07657d81c6f9d9bcda78e08c7d2569bc358574017a5f43ff99c247c86439739114b821ad5e40110e
+DIST logmein-hamachi-2.1.0.203-x86.tgz 1368703 BLAKE2B 686149ccf57683d1a6ecae5d8f8dd16d793156fd5c3e95556ca4e12e9138f4bbc0eee1f4785ff684138a99e38a95156afa9e48e7587ed02d9fccbae7e8c9043a SHA512 b153dba334cf04abb9662c4c1fc576388bebdf0af303549e25c65536b3601f9c90e2a4c986898979d2abfc9fca2d31943e787d4ff3b59fc7147c2a1a1a1fdad9
diff --git a/net-vpn/logmein-hamachi/logmein-hamachi-2.1.0.203.ebuild b/net-vpn/logmein-hamachi/logmein-hamachi-2.1.0.203.ebuild
new file mode 100644
index 000000000000..e1358b40444d
--- /dev/null
+++ b/net-vpn/logmein-hamachi/logmein-hamachi-2.1.0.203.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd
+
+DESCRIPTION="LogMeIn Hamachi VPN tunneling engine"
+HOMEPAGE="https://www.vpn.net/"
+SRC_URI="x86? ( https://www.vpn.net/installers/${P}-x86.tgz )
+ amd64? ( https://www.vpn.net/installers/${P}-x64.tgz )"
+
+LICENSE="LogMeIn"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!net-misc/hamachi"
+
+RESTRICT="mirror"
+
+QA_PREBUILT="/opt/${PN}/bin/hamachid"
+QA_PRESTRIPPED="/opt/${PN}/bin/hamachid"
+QA_WX_LOAD="/opt/${PN}/bin/hamachid"
+
+pkg_setup() {
+ einfo "Checking your kernel configuration for TUN/TAP support."
+ CONFIG_CHECK="~TUN"
+ check_extra_config
+}
+
+src_unpack() {
+ unpack ${A}
+ mv "${P}-$(usex x86 x86 x64)" "${S}" || die
+}
+
+src_install() {
+ into /opt/${PN}
+ dobin hamachid dnsup dnsdown
+ dosym ../../opt/${PN}/bin/hamachid /usr/bin/hamachi
+
+ # Config and log directory
+ keepdir /var/lib/${PN}
+
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+
+ dodoc CHANGES README
+}
+
+pkg_postinst() {
+ elog "LogMeIn Hamachi2 is installed."
+ elog "Consult the README file on how to configure your client."
+ elog "You can run the client 'hamachi' as root,"
+ elog "or as a user if you add a newline terminated line:"
+ elog "Ipc.User <login name>"
+ elog "to the file '/var/lib/${PN}/h2-engine-override.cfg'"
+ elog "and restart the daemon with"
+ elog "/etc/init.d/${PN} restart"
+ elog "or:"
+ elog "systemctl restart ${PN}"
+ elog "To enable auto-login when the service starts set a nickname in"
+ elog "/etc/conf.d/${PN} (only supported using openRC)"
+}