summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorILMostro <ilmostro7@gmail.com>2020-03-10 02:32:48 -0500
committerJoonas Niilola <juippis@gentoo.org>2020-03-25 15:45:24 +0200
commit755b037eda3181421eca7e208f0eaeb7652d4d6f (patch)
tree0258d421492aa81773331142da8a9338e142df53 /net-vpn/protonvpn-cli/protonvpn-cli-2.2.2.ebuild
parentapp-text/robodoc: revision to build against musl (diff)
downloadgentoo-755b037eda3181421eca7e208f0eaeb7652d4d6f.tar.gz
gentoo-755b037eda3181421eca7e208f0eaeb7652d4d6f.tar.bz2
gentoo-755b037eda3181421eca7e208f0eaeb7652d4d6f.zip
net-vpn/protonvpn-cli: bump to version 2.2.2
Signed-off-by: Amel Hodzic <ilmostro7@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/14917 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-vpn/protonvpn-cli/protonvpn-cli-2.2.2.ebuild')
-rw-r--r--net-vpn/protonvpn-cli/protonvpn-cli-2.2.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-vpn/protonvpn-cli/protonvpn-cli-2.2.2.ebuild b/net-vpn/protonvpn-cli/protonvpn-cli-2.2.2.ebuild
new file mode 100644
index 000000000000..d1f445f5b0e2
--- /dev/null
+++ b/net-vpn/protonvpn-cli/protonvpn-cli-2.2.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A VPN command-line tool from protonvpn - python rewrite"
+HOMEPAGE="https://protonvpn.com https://github.com/ProtonVPN/protonvpn-cli-ng"
+SRC_URI="https://github.com/ProtonVPN/${PN}-ng/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="dev-python/docopt[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pythondialog:0[${PYTHON_USEDEP}]
+ net-vpn/openvpn"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-ng-${PV}"
+
+DOCS=( CHANGELOG.md README.md USAGE.md )