summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-11-05 18:20:23 -0500
committerAnthony G. Basile <blueness@gentoo.org>2017-11-05 18:20:43 -0500
commitf356a93c7acc8c66fe3e35127db02205e788791e (patch)
tree7bd9c9faf9f30e43f6fdec340426cbbc44b3f56c /net-vpn/tinc
parentsys-fs/xmwfs: new ebuild. (diff)
downloadgentoo-f356a93c7acc8c66fe3e35127db02205e788791e.tar.gz
gentoo-f356a93c7acc8c66fe3e35127db02205e788791e.tar.bz2
gentoo-f356a93c7acc8c66fe3e35127db02205e788791e.zip
net-vpn/tinc: version bump to 1.0.33
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-vpn/tinc')
-rw-r--r--net-vpn/tinc/Manifest1
-rw-r--r--net-vpn/tinc/tinc-1.0.33.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/net-vpn/tinc/Manifest b/net-vpn/tinc/Manifest
index d1ba938a4837..afddf8ea6cb8 100644
--- a/net-vpn/tinc/Manifest
+++ b/net-vpn/tinc/Manifest
@@ -1,3 +1,4 @@
DIST tinc-1.0.31.tar.gz 494877 SHA256 d3cbc82e6e07975a2ccc0b369d07e30fc3324e71e240dca8781ce9a4f629519b SHA512 ac694d4ceec19bddebd3d5b9f37eb703a4701b93f65a7bbcdbc0b364f2a4f8b116c85748d06ec7821474de5c4d434caf5448109a0846e15c4a96adb92a0fc622 WHIRLPOOL aec84cd59ca80ca806171003447f946073c8f99fd872eaef1e7fea9d423cd4905d554964920be802e0862f5ab8de7d9d7094792c30403af8b62abca12286e2b1
DIST tinc-1.0.32.tar.gz 496221 SHA256 4db24feaff8db4bbb7edb7a4b8f5f8edc39b26eb5feccc99e8e67a6960c05587 SHA512 1533305a062782ec788bcb59f4cbfac76ed401ccfe57b5cbd9a3fd9b76a238dbd0f612071c24b157fec4dfc409c79b1b4fbf6e176510b321dcdd79174632028c WHIRLPOOL 1d20dd365ea4c774555f809412befe0857fdd574dbbb92b8cf61764973dfaa67ebe95480913c594de663cc91845b3850b9fe541c006725d60c32d6f403cb6be0
+DIST tinc-1.0.33.tar.gz 486374 SHA256 7f6f5dc6444bc651ac635c81f4745bcce581bbd1d45ed60cbdc4ee11bebb10f4 SHA512 f17c7682e177d85a049891255fc590069c7901307951ee93364a7a754f1a7c5ca4b6a6f7ddcb4c9ad150f0155ff7db7112990a3fc3a6496b48bdbfd3b1ae8804 WHIRLPOOL 9fa868d3ac0b89e0c4458c00b79149e21baa3a6e9950665da11e91278048f2a8866c23027e39f1cf34e940794d5c6b5427a561c4a0a1e4bbfdce3d2554b6b3d8
DIST tinc-1.1pre15.tar.gz 704145 SHA256 41dc3e40c5f8be497b779acd6f59ef4572e1430d0d0f0436f2de5cb21a59ef18 SHA512 29b109c84a89204a9fe298e3cfb092169a7c3cbb62e0cabdb7fe8eaa01b03343b7d48bf028525754af1a340781de209e0b9412669c256a30e7226a8a21412c17 WHIRLPOOL f258704dd6f2f4c5fd184a1f38da93a2bd8e655b07cfed47837e57a049c8be4e9b744f1a10b1932d020aab6c7c5bf043a83d7c9529755f5accca445f95355439
diff --git a/net-vpn/tinc/tinc-1.0.33.ebuild b/net-vpn/tinc/tinc-1.0.33.ebuild
new file mode 100644
index 000000000000..c8adaa0c7d3e
--- /dev/null
+++ b/net-vpn/tinc/tinc-1.0.33.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+inherit systemd
+
+DESCRIPTION="tinc is an easy to configure VPN implementation"
+HOMEPAGE="http://www.tinc-vpn.org/"
+SRC_URI="http://www.tinc-vpn.org/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="libressl +lzo uml vde +zlib"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ lzo? ( dev-libs/lzo:2 )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}
+ vde? ( net-misc/vde )"
+
+src_configure() {
+ econf \
+ --enable-jumbograms \
+ --disable-tunemu \
+ $(use_enable lzo) \
+ $(use_enable uml) \
+ $(use_enable vde) \
+ $(use_enable zlib)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodir /etc/tinc
+ dodoc AUTHORS NEWS README THANKS
+ doconfd "${FILESDIR}"/tinc.networks
+ newconfd "${FILESDIR}"/tincd.conf tincd
+ newinitd "${FILESDIR}"/tincd-r1 tincd
+ systemd_newunit "${FILESDIR}"/tincd_at.service "tincd@.service"
+}
+
+pkg_postinst() {
+ elog "This package requires the tun/tap kernel device."
+ elog "Look at http://www.tinc-vpn.org/ for how to configure tinc"
+}