summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-05-04 14:48:51 -0400
committerAnthony G. Basile <blueness@gentoo.org>2019-05-04 14:49:11 -0400
commitbe60ee03d4618b922e226bc867f0371cb3f0c432 (patch)
tree83b5b38900bcc0c7c441f4960c4baa52b389ca24 /net-vpn/tor
parentvirtual/modutils: Add ~riscv keyword (diff)
downloadgentoo-be60ee03d4618b922e226bc867f0371cb3f0c432.tar.gz
gentoo-be60ee03d4618b922e226bc867f0371cb3f0c432.tar.bz2
gentoo-be60ee03d4618b922e226bc867f0371cb3f0c432.zip
net-vpn/tor: add USE=doc and man for bug #684986
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'net-vpn/tor')
-rw-r--r--net-vpn/tor/metadata.xml1
-rw-r--r--net-vpn/tor/tor-0.4.0.4_rc.ebuild10
2 files changed, 7 insertions, 4 deletions
diff --git a/net-vpn/tor/metadata.xml b/net-vpn/tor/metadata.xml
index ed620b018464..121fa511c906 100644
--- a/net-vpn/tor/metadata.xml
+++ b/net-vpn/tor/metadata.xml
@@ -6,6 +6,7 @@
<name>Anthony G. Basile</name>
</maintainer>
<use>
+ <flag name="man">Build and install man pages</flag>
<flag name="scrypt">Use <pkg>app-crypt/libscrypt</pkg> for the scrypt algorithm</flag>
<flag name="tor-hardening">Compile tor with hardening on vanilla compilers/linkers</flag>
</use>
diff --git a/net-vpn/tor/tor-0.4.0.4_rc.ebuild b/net-vpn/tor/tor-0.4.0.4_rc.ebuild
index 2e27b784b6bc..6b60698543f6 100644
--- a/net-vpn/tor/tor-0.4.0.4_rc.ebuild
+++ b/net-vpn/tor/tor-0.4.0.4_rc.ebuild
@@ -16,13 +16,13 @@ S="${WORKDIR}/${MY_PF}"
LICENSE="BSD GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~ppc-macos"
-IUSE="caps libressl lzma scrypt seccomp selinux systemd tor-hardening test zstd"
+IUSE="caps doc libressl lzma +man scrypt seccomp selinux systemd tor-hardening test zstd"
DEPEND="
- app-text/asciidoc
dev-libs/libevent[ssl]
sys-libs/zlib
caps? ( sys-libs/libcap )
+ man? ( app-text/asciidoc )
!libressl? ( dev-libs/openssl:0=[-bindist] )
libressl? ( dev-libs/libressl:0= )
lzma? ( app-arch/xz-utils )
@@ -38,7 +38,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.3.3.2-alpha-tor.service.in.patch
)
-DOCS=( README ChangeLog ReleaseNotes doc/HACKING )
+DOCS=()
pkg_setup() {
enewgroup tor
@@ -46,11 +46,11 @@ pkg_setup() {
}
src_configure() {
+ use doc && DOCS+=( README ChangeLog ReleaseNotes doc/HACKING )
export ac_cv_lib_cap_cap_init=$(usex caps)
econf \
--localstatedir="${EPREFIX}/var" \
--enable-system-torrc \
- --enable-asciidoc \
--disable-android \
--disable-libfuzzer \
--disable-module-dirauth \
@@ -58,6 +58,7 @@ src_configure() {
--disable-rust \
--disable-restart-debugging \
--disable-zstd-advanced-apis \
+ $(use_enable man asciidoc) \
$(use_enable lzma) \
$(use_enable scrypt libscrypt) \
$(use_enable seccomp) \
@@ -84,4 +85,5 @@ src_install() {
insinto /etc/tor/
newins "${FILESDIR}"/torrc-r1 torrc
+
}