summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2022-05-10 09:52:05 +0200
committerMike Gilbert <floppym@gentoo.org>2022-05-10 12:16:54 -0400
commit2181f388dd2da65ee80722ea1d109192a48346b7 (patch)
tree14c6d4870ade5260a24377ba2c51fedfa3e29561 /net-vpn
parentdev-libs/pthreadpool: drop gtest download (diff)
downloadgentoo-2181f388dd2da65ee80722ea1d109192a48346b7.tar.gz
gentoo-2181f388dd2da65ee80722ea1d109192a48346b7.tar.bz2
gentoo-2181f388dd2da65ee80722ea1d109192a48346b7.zip
net-vpn/vpnc-scripts: bump version to 20220510
Closes: https://github.com/gentoo/gentoo/pull/25414 Signed-off-by: Henning Schild <henning@hennsch.de> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/vpnc-scripts/Manifest1
-rw-r--r--net-vpn/vpnc-scripts/vpnc-scripts-20220510.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/net-vpn/vpnc-scripts/Manifest b/net-vpn/vpnc-scripts/Manifest
index de68088215d6..241b6ae9bbe1 100644
--- a/net-vpn/vpnc-scripts/Manifest
+++ b/net-vpn/vpnc-scripts/Manifest
@@ -1 +1,2 @@
DIST vpnc-scripts-20210402.tar.gz 39925 BLAKE2B 2bc8a274773e51ba48e402588fdf5b51d20360f610afe5608f91dfe2466644b68d891a60c27e4c6938b4ed5da1f193ddb7a8ac955c8f02e6bf91437dc5c47620 SHA512 5f9fc5ab1a5a2607f807700536c4a8e71c551052e72979c1cdd02b15906615be33a297b873b0806f269e51645f10f1c02a7acfed2501148bfa2797250582920d
+DIST vpnc-scripts-20220510.tar.gz 44155 BLAKE2B c52a1680d25882776c76fc52d8df7f482fe157c7f52ab1c6b14ef6291801a94d5655e6284d55af9d09871e57003e4b434a5453a986ea0e28cd7764c348614bc8 SHA512 c391048b60e739e21954b22b9c4bb764a55c71f8fe6d4e263293efae1bd8d1229ca6b841c2cdd4352c36641d5143c2bca023bff65fa5b8ae8ea151d77b5231cf
diff --git a/net-vpn/vpnc-scripts/vpnc-scripts-20220510.ebuild b/net-vpn/vpnc-scripts/vpnc-scripts-20220510.ebuild
new file mode 100644
index 000000000000..992e33a030a8
--- /dev/null
+++ b/net-vpn/vpnc-scripts/vpnc-scripts-20220510.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 99999999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/openconnect/vpnc-scripts.git"
+else
+ SRC_URI="ftp://ftp.infradead.org/pub/vpnc-scripts/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+DESCRIPTION="Connect scripts for use with vpnc and openconnect (and similar clients)"
+HOMEPAGE="https://gitlab.com/openconnect/vpnc-scripts"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="!<net-vpn/vpnc-0.5.3_p550-r3"
+
+src_install() {
+ exeinto /etc/vpnc
+ doexe vpnc-script{,-{ptrtd,sshd}}
+}