summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-02-15 17:00:47 -0600
committerWilliam Hubbs <williamh@gentoo.org>2024-02-15 17:02:37 -0600
commit255b92b5bbdebcc6716c3d8db938015ed1ab9420 (patch)
tree28dd716cd284f7140aced51a105d639fa228e832 /net-vpn
parentsys-kernel/linux-firmware: keyword 20240115-r2 (diff)
downloadgentoo-255b92b5bbdebcc6716c3d8db938015ed1ab9420.tar.gz
gentoo-255b92b5bbdebcc6716c3d8db938015ed1ab9420.tar.bz2
gentoo-255b92b5bbdebcc6716c3d8db938015ed1ab9420.zip
net-vpn/tailscale: add 1.60.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/tailscale/Manifest2
-rw-r--r--net-vpn/tailscale/tailscale-1.60.0.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/net-vpn/tailscale/Manifest b/net-vpn/tailscale/Manifest
index 527e12e64c65..eb5cae476362 100644
--- a/net-vpn/tailscale/Manifest
+++ b/net-vpn/tailscale/Manifest
@@ -4,3 +4,5 @@ DIST tailscale-1.56.1-deps.tar.xz 395648828 BLAKE2B 08770560a70296af830763fdfd82
DIST tailscale-1.56.1.tar.gz 2311243 BLAKE2B 3046aae1d6b652cd0ce56202b1f24bafca019621878e7da2258c2850b534d8dff713d4e32b4c985bc1636382505934efb320e751ca75275054139184b8e61640 SHA512 a6e213eeb885d160b816f7d795d8ae66cd322d652657ee5309e220c6526eb73d5aea07dcd57983468520891c5405fcb84255350cdacc078514cede8a351a4888
DIST tailscale-1.58.2-deps.tar.xz 397235964 BLAKE2B 3273320edb277d8f6527b6048f62356930287c6eeb1310e35dede72be0476331d2ae4ffe9658f8c36ebfc3384cc2b0e4f617cb25d2685c5e28dda66a9290e12b SHA512 370262f4589814d87587d8b685cde3a706611627ab6de09fdd271b3110baebebcfe2334574b7737643e5e2797638220901b1769eae469a08ec3325d82ac633de
DIST tailscale-1.58.2.tar.gz 2361679 BLAKE2B 1aa66710677ba7c648782db9f67ce8cf565812b08610bb078bcd78ee2d695601fcb2f681102eb7a1232b6c4057ba5e1fed1d26b375cec793f0fbce65aff38755 SHA512 3370af3c0214544d15196063f798e17e7c35566cf4d01628faa1e26ba1a5885834b0f3d2862e3009a81ff9f4298cdd3f826fc5d09f23568c30c64bc6f0400f6b
+DIST tailscale-1.60.0-deps.tar.xz 382250200 BLAKE2B 199d78fdccd0502dbf2d7e9e3cb50660a83d1187e35e50cd5f648970927fdf5c1df98682e8366d108603a1163df32fdc523041b8fe36dabfb2d13f0951357b16 SHA512 7fa1f21d42ddc85a98ad420104e17183b9c615010e8f13ca971f3488d382c6b7a8595006062e09f6438eeeaa6559a4e35eab3b053e85a66c5dfa9924d1aa5258
+DIST tailscale-1.60.0.tar.gz 2440764 BLAKE2B f6c6ee3e378ddc37dbe67a74b1ff2b1cf5b9cbe720f6a38b3292f6fc7874b2712f00d7ba2e647a12c7b29edb2ca131605226af5fd56200b8fa7c6005e6eba778 SHA512 81c96c6f64d4141894673be7d524bacae7485f9c1d63fde5dcea952573daafc87c9f5b5fa17ceabe8e88a4d61b4f939822228fb2a310bd8522ca15f7cb9c3a60
diff --git a/net-vpn/tailscale/tailscale-1.60.0.ebuild b/net-vpn/tailscale/tailscale-1.60.0.ebuild
new file mode 100644
index 000000000000..4665feacdfd8
--- /dev/null
+++ b/net-vpn/tailscale/tailscale-1.60.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# These settings are obtained by running ./build_dist.sh shellvars` in
+# the upstream repo.
+VERSION_MINOR="60"
+VERSION_SHORT="1.60.0"
+VERSION_LONG="1.60.0-tf4e3ee53e"
+VERSION_GIT_HASH="f4e3ee53ea4605d400df2ef6b6005b026661f96b"
+
+DESCRIPTION="Tailscale vpn client"
+HOMEPAGE="https://tailscale.com"
+SRC_URI="https://github.com/tailscale/tailscale/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="net-firewall/iptables"
+BDEPEND=">=dev-lang/go-1.21"
+
+RESTRICT="test"
+
+# This translates the build command from upstream's build_dist.sh to an
+# ebuild equivalent.
+build_dist() {
+ ego build -tags xversion -ldflags "
+ -X tailscale.com/version.Long=${VERSION_LONG}
+ -X tailscale.com/version.Short=${VERSION_SHORT}
+ -X tailscale.com/version.GitCommit=${VERSION_GIT_HASH}" "$@"
+}
+
+src_compile() {
+ build_dist ./cmd/tailscale
+ build_dist ./cmd/tailscaled
+}
+
+src_install() {
+ dosbin tailscaled
+ dobin tailscale
+
+ systemd_dounit cmd/tailscaled/tailscaled.service
+ insinto /etc/default
+ newins cmd/tailscaled/tailscaled.defaults tailscaled
+ keepdir /var/lib/${PN}
+ fperms 0750 /var/lib/${PN}
+
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles" ${PN}.conf
+
+ newinitd "${FILESDIR}/${PN}d.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}d.confd" ${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}