summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2023-12-08 21:15:46 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-02-26 17:41:45 +0100
commit26a321d1cdfeed9df884e8da95af8a66cd43ce56 (patch)
tree9f6a86add657e0c0d9df79b149f39b5774000d1c /net-vpn
parentnet-vpn/eduvpn-client: update icon cache (diff)
downloadgentoo-26a321d1cdfeed9df884e8da95af8a66cd43ce56.tar.gz
gentoo-26a321d1cdfeed9df884e8da95af8a66cd43ce56.tar.bz2
gentoo-26a321d1cdfeed9df884e8da95af8a66cd43ce56.zip
net-vpn/eduvpn-common: add 1.2.0
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/eduvpn-common/Manifest2
-rw-r--r--net-vpn/eduvpn-common/eduvpn-common-1.2.0.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/net-vpn/eduvpn-common/Manifest b/net-vpn/eduvpn-common/Manifest
index 8cdaa49d13e2..ce6b8a20210a 100644
--- a/net-vpn/eduvpn-common/Manifest
+++ b/net-vpn/eduvpn-common/Manifest
@@ -2,3 +2,5 @@ DIST eduvpn-common-1.1.2-deps.tar.xz 7517364 BLAKE2B a6bd2c11d5056170d88ca8c35d0
DIST eduvpn-common-1.1.2.gh.tar.gz 208300 BLAKE2B 8cb7e96d4a6a5032a1696aa57a6322f6a861aebba8b1f653d8be98e0044eacb3f23dc400ac9a8598dd83f30ca2140394ee2aa5733a27547f2a0378ad03ab422d SHA512 dbc290e48bc045456ad83e58e63c223cef5a7e1c7178537a44ed306a423276e644fb0f5607a7d8ddc5014b48ae11b57e365068d72887062277f8ab4f6f1ae660
DIST eduvpn-common-1.1.99.0-deps.tar.xz 7581560 BLAKE2B faa8a91a3eaff9a49e2c39059687d3e2264dd2f0dfcd711b301776a90df34e5f85aa1f5b724771a7b0e6c5f2ee3ec62fe72ddfdb6c35cb4cd664069fe189f26c SHA512 05d8f9785d0b967f7e2d64ec735b8e1dbf251b895ea7b860471128cb13d66ae6ffbb8507d831d7e2a7a4d0cf585bdd3f4514f74ff14202fa604d7a36a2d7d540
DIST eduvpn-common-1.1.99.0.gh.tar.gz 209972 BLAKE2B 3547be10495bed8dd7ac185bf711d32cfdedee44b4acd7e1ef3ac7d56a7d4ca335deea34d8c9744738ef104d2f1ffe30b4623b0abb3589d7d3380ba00d6cf09d SHA512 f4e2ef80a1c4736bbfc30d0c8d439f993ccde87c93daa5d1f7179494938513123afeb44f23bbc4287d0309da10d5a0aeddfb77eae51933bbe6e5c57d461b1d5f
+DIST eduvpn-common-1.2.0-deps.tar.xz 7583176 BLAKE2B af35dd134a77753448fc9e7f91bde9d52fe05c20339eea637d0d0c5e9564f19cae6e294723adf1ef6c516ae05bc0495be2f316b2560b9d1860d9ce509517e04b SHA512 83e88038a6b5cb39917f9b892ac8783ef273c9e606173aad68125702a70a70dc9c61f54f0078d92214d6e1ec3e92cbdff3d10f18caf889cd603a2d75fa70c209
+DIST eduvpn-common-1.2.0.gh.tar.gz 210499 BLAKE2B 1e584138378f2c08ca71c6954b35196db2541a77327a3a7d88fefd2f2e946fd544d8d54d39b539a558830ad60ba65e3382035f016446ef596a015db3ccf43704 SHA512 abd7c4372ef5a2b7e182b497c46235f2c10b7d7e87bcab32910a3a149a0db31a93890a8e6d5434935ca444da69ec8bbccb944762dc160a879903baccac18bb35
diff --git a/net-vpn/eduvpn-common/eduvpn-common-1.2.0.ebuild b/net-vpn/eduvpn-common/eduvpn-common-1.2.0.ebuild
new file mode 100644
index 000000000000..3545e366925a
--- /dev/null
+++ b/net-vpn/eduvpn-common/eduvpn-common-1.2.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+inherit distutils-r1 go-module linux-info
+
+DESCRIPTION="Linux client and Python client API for eduVPN"
+HOMEPAGE="https://www.eduvpn.org/"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/eduvpn/eduvpn-common.git"
+else
+ SRC_URI="
+ https://github.com/eduvpn/eduvpn-common/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz
+ https://www-user.tu-chemnitz.de/~hamari/eduvpn/${P}-deps.tar.xz
+ "
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="openvpn wireguard"
+RESTRICT="test"
+
+RDEPEND="
+ openvpn? ( net-vpn/openvpn )
+"
+
+wrap_python() {
+ local phase=$1
+ shift
+
+ pushd wrappers/python >/dev/null || die
+ distutils-r1_${phase} "$@"
+ popd >/dev/null || die
+}
+
+pkg_pretend() {
+ if use wireguard; then
+ CONFIG_CHECK="~WIREGUARD"
+ WARNING_WIREGUARD="You must enable WIREGUARD to use wireguard."
+ check_extra_config
+ fi
+}
+
+src_prepare() {
+ default
+
+ mkdir -p wrappers/python/eduvpn_common/lib || die
+
+ wrap_python ${FUNCNAME}
+}
+
+src_compile() {
+ default
+ wrap_python ${FUNCNAME}
+}
+
+src_test() {
+ default
+ wrap_python ${FUNCNAME}
+}
+
+src_install() {
+ # The shared library is installed within the python package. There is no
+ # need to call the default routine.
+ wrap_python ${FUNCNAME}
+}