summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Su <chris@lesscrowds.org>2023-02-16 22:51:56 +0800
committerYixun Lan <dlan@gentoo.org>2023-03-16 17:49:00 +0800
commit3e4be71aa43961da1c2b85c79221a8f9fd0e9467 (patch)
treee1b3cb20c5c967c44bfe2cb03d1dc643a484a7f6 /net-vpn
parentkde-apps/kgpg: keyword 22.12.3 riscv #900599 (diff)
downloadgentoo-3e4be71aa43961da1c2b85c79221a8f9fd0e9467.tar.gz
gentoo-3e4be71aa43961da1c2b85c79221a8f9fd0e9467.tar.bz2
gentoo-3e4be71aa43961da1c2b85c79221a8f9fd0e9467.zip
net-vpn/headscale: 0.20.0 version bump
Closes: https://github.com/gentoo/gentoo/pull/29617 Signed-off-by: Chris Su <chris@lesscrowds.org> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/headscale/Manifest2
-rw-r--r--net-vpn/headscale/headscale-0.20.0.ebuild48
-rw-r--r--net-vpn/headscale/metadata.xml3
3 files changed, 53 insertions, 0 deletions
diff --git a/net-vpn/headscale/Manifest b/net-vpn/headscale/Manifest
index 52c778b6f3eb..90ab2fca7de4 100644
--- a/net-vpn/headscale/Manifest
+++ b/net-vpn/headscale/Manifest
@@ -1,2 +1,4 @@
DIST headscale-0.16.2-deps.tar.xz 246778024 BLAKE2B 7c2beff2b18ca87aa4d496332d6b521f31d7b496227950204d9efe35f8259fdf1f3519fce951827f3698b5c166148db3ef69225acf16ce2e659b70017ac9e0f2 SHA512 5bc9b1b6bf1c3c70a7e033c2820c9fc05df45d19855e8050687072f0394920d77416640eb9af100027a96646df285b5a3d09bab4c959d4475e8b2b304f01a4ef
DIST headscale-0.16.2.tar.gz 391683 BLAKE2B c75835e7f15847236b357988cdb66c65c3e2cb6ac2328e4fb5cb07da9c132b664afe69fcaf3fa9f6a70951e76a91ddf8fda2ea74c1af9055daca30f3efb593ab SHA512 bad885866855211d43b45dcc7b958595967241af4c2a1b370532fef7c751b85002138cd3742e4046603af383c123b66afd7de9aba59e8eee600d7ffdd70ff12c
+DIST headscale-0.20.0-deps.tar.xz 199890824 BLAKE2B 4b96f22d2cd1c4156bb730cc476dbf65b969b64b857cbdc0d91714b031ca8df4993327a2e31bf8dec51b5309790bf8e606117b7c49a96654914551a9081df3cf SHA512 2394e5e995d8fae72b9561e98c1d2576309a37583441a42eee1d74fd123340dba8615c78beb581633aea15b234d213cbfcd97701c8cbf6dc85381d7dca4252a7
+DIST headscale-0.20.0.tar.gz 581431 BLAKE2B 07def2a4e6509759a1b7a18c8faa426e420a17b42290e3162540c8115316012cc83a5cbd9e8918940244591ebfca4a9225e5a0475554e52f54bd791904d6407e SHA512 e201c63f3646501229b114b48c3603945272b79390f4ab8d3f9bc557cdf02b1c404cd18ba85aaf1a5038ec41361746177278a51d6075db5944d3edf1efdcc4be
diff --git a/net-vpn/headscale/headscale-0.20.0.ebuild b/net-vpn/headscale/headscale-0.20.0.ebuild
new file mode 100644
index 000000000000..12d3cfd3a6af
--- /dev/null
+++ b/net-vpn/headscale/headscale-0.20.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd
+
+DESCRIPTION="An open source, self-hosted implementation of the Tailscale control server"
+HOMEPAGE="https://github.com/juanfont/headscale"
+DEPS_URIS=( https://github.com/slchris/gentoo-go-deps/releases/download/headscale-0.20.0/${P}-deps.tar.xz )
+SRC_URI="https://github.com/juanfont/headscale/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${DEPS_URIS}"
+
+LICENSE="BSD Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+DEPEND="
+ acct-group/headscale
+ acct-user/headscale
+"
+RDEPEND="
+ ${DEPEND}
+ net-firewall/iptables
+"
+
+src_compile() {
+ export -n GOCACHE XDG_CACHE_HOME
+ go build -o ./bin/${PN} ./cmd/${PN} || die
+}
+
+src_install() {
+ dobin bin/headscale
+ dodoc -r config-example.yaml derp-example.yaml
+ keepdir /etc/headscale /var/lib/headscale
+ systemd_dounit "${FILESDIR}"/headscale.service
+ newconfd "${FILESDIR}"/headscale.confd headscale
+ newinitd "${FILESDIR}"/headscale.initd headscale
+ fowners -R ${PN}:${PN} /etc/headscale /var/lib/headscale
+}
+
+pkg_postinst() {
+ [[ -f "${EROOT}"/etc/headscale/config.yaml ]] && return
+ elog "Please create ${EROOT}/etc/headscale/config.yaml before starting the service"
+ elog "An example is in ${EROOT}/usr/share/doc/${P}/config-example.yaml.bz2"
+ ewarn ">=headscale-0.19.0 has a DB structs breaking, please BACKUP your database before upgrading!"
+ ewarn "see also: https://github.com/juanfont/headscale/pull/1171 and https://github.com/juanfont/headscale/pull/1144"
+}
diff --git a/net-vpn/headscale/metadata.xml b/net-vpn/headscale/metadata.xml
index 73d345656db7..f02e9a5a66e4 100644
--- a/net-vpn/headscale/metadata.xml
+++ b/net-vpn/headscale/metadata.xml
@@ -13,4 +13,7 @@
<email>jsmolic@gentoo.org</email>
<name>Jakov Smolić</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">juanfont/headscale</remote-id>
+ </upstream>
</pkgmetadata>