summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-08-19 15:01:43 -0400
committerMike Gilbert <floppym@gentoo.org>2022-08-19 15:12:51 -0400
commit40559d7761064c24a692fbf4ec9fa97f450958b2 (patch)
tree5ab9d5df4f9cacde6e09c711281153bec52ad6ff /net-vpn
parentsys-apps/cpu-x: adjust src_configure for prior USE changes (diff)
downloadgentoo-40559d7761064c24a692fbf4ec9fa97f450958b2.tar.gz
gentoo-40559d7761064c24a692fbf4ec9fa97f450958b2.tar.bz2
gentoo-40559d7761064c24a692fbf4ec9fa97f450958b2.zip
net-vpn/openconnect: include inttypes.h in jsondump.c
Closes: https://bugs.gentoo.org/865797 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/openconnect/files/openconnect-9.01-inttypes.patch32
-rw-r--r--net-vpn/openconnect/openconnect-9.01.ebuild3
2 files changed, 35 insertions, 0 deletions
diff --git a/net-vpn/openconnect/files/openconnect-9.01-inttypes.patch b/net-vpn/openconnect/files/openconnect-9.01-inttypes.patch
new file mode 100644
index 000000000000..c9b28913ce9f
--- /dev/null
+++ b/net-vpn/openconnect/files/openconnect-9.01-inttypes.patch
@@ -0,0 +1,32 @@
+From c0775e6cd46fb5df6c6aab52314e3038c44d2152 Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Fri, 19 Aug 2022 11:55:42 -0400
+Subject: [PATCH] jsondump.c: include <inttypes.h> for PRId64
+
+Fixes a build failure with gnutls and a json-parser snapshot taken on
+2021-12-08.
+
+Building with openssl or with the bundled copy of json-parser causes
+inttypes.h to be included indirectly.
+
+Bug: https://bugs.gentoo.org/865797
+Signed-off-by: Mike Gilbert <floppym@gentoo.org>
+---
+ jsondump.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/jsondump.c b/jsondump.c
+index a18780b5..2b097e8a 100644
+--- a/jsondump.c
++++ b/jsondump.c
+@@ -24,6 +24,7 @@
+ #include <string.h>
+ #include <ctype.h>
+ #include <errno.h>
++#include <inttypes.h>
+
+ /*
+ * Copyright (C) 2015 Mirko Pasqualetti All rights reserved.
+--
+GitLab
+
diff --git a/net-vpn/openconnect/openconnect-9.01.ebuild b/net-vpn/openconnect/openconnect-9.01.ebuild
index 824c77958d4b..e4aa08f994e4 100644
--- a/net-vpn/openconnect/openconnect-9.01.ebuild
+++ b/net-vpn/openconnect/openconnect-9.01.ebuild
@@ -85,6 +85,9 @@ src_unpack() {
}
src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}/openconnect-9.01-inttypes.patch"
+ )
default
if [[ ${PV} == 9999 ]]; then
eautoreconf