summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-08-07 12:25:53 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-08-07 12:27:02 -0500
commit9504756ead195fe0d18ea77ff5892f43ce877a5f (patch)
tree065e5c318854ed19a45e12b7d2ec1a228f336ac7 /net-vpn
parentmail-filter/rspamd: backport memory leak fix (diff)
downloadgentoo-9504756ead195fe0d18ea77ff5892f43ce877a5f.tar.gz
gentoo-9504756ead195fe0d18ea77ff5892f43ce877a5f.tar.bz2
gentoo-9504756ead195fe0d18ea77ff5892f43ce877a5f.zip
net-vpn/tailscale: add 1.46.1
Closes: https://bugs.gentoo.org/911273 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/tailscale/Manifest2
-rw-r--r--net-vpn/tailscale/tailscale-1.46.1.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/net-vpn/tailscale/Manifest b/net-vpn/tailscale/Manifest
index 6783ff1ecec3..236948aaef8c 100644
--- a/net-vpn/tailscale/Manifest
+++ b/net-vpn/tailscale/Manifest
@@ -2,3 +2,5 @@ DIST tailscale-1.36.2-deps.tar.xz 251788056 BLAKE2B 341fbf98fb6f59337e17e79688c6
DIST tailscale-1.36.2.tar.gz 1539770 BLAKE2B f1533f1dfdf1806a235892e988db401da76954858cd10baa8aa89e14330c7c627b5bafc682fb4a100cc89ff14b2dc2f3093b0d24e9ee754a0f24930a7578dc76 SHA512 bb3abfc370f24534748b877fcf51e57bd575843d35fcde4653544f82f1437dbccd489dcf73b37e4ec194a1ea1d42e3397937b239db95512d701af8f078cc80fd
DIST tailscale-1.38.4-deps.tar.xz 252299404 BLAKE2B aa500af08c64dd07dc04b4f96d8c6c99f7aa8a85aec673f2ef3603be3c2ca63b476aac2c575f2378f8964ce8365d4d295dfbce9080d24c1136d57009e3f1ce2b SHA512 392916e4ed041d976bf21c6aac66155d040274032d5ec683badf57bbdc8f6735b6ebe84f4d683ad0f412145b22cc1d17be51f058440790bb94d12f3dc59c2624
DIST tailscale-1.38.4.tar.gz 1644918 BLAKE2B e61c32513afe8715b99e5ee14ee572849fd1b92c31744894af4d028ab599685d2e38c5fb6eb9e8d40e0638d427065499089152ae002ef7dc947d3957f0fdc785 SHA512 f077217d9333263f3883d766abfb8a9adef3cf9c06544cca28bca41e6f51bf06991a0d31ff2ec0dbf01e80cbc04c903bb5b55cdcd871269d3b659664ce24d011
+DIST tailscale-1.46.1-deps.tar.xz 370535596 BLAKE2B 84c37e83f6ced653132c9a3639ad652cf258ab232d7f32fd5fbe8d2303aaae87c169bc6948c602be435f88c05373c6908d2120b16b83fc3795230fd633a62add SHA512 358a91bdff4df7933660a31f0c967e090c8b10b42abf3e6497bf163e93bf86e4b98b5defadf5dba87815c941361310bfde6060927da73eac0bb55f56c80dace2
+DIST tailscale-1.46.1.tar.gz 1817180 BLAKE2B b5ace1aa3fa98b14be53bbf55ec271cbbaf4c28a095300963961dd8bc5ee308091d46807af3b82f8ecb88070763a245292304706ab29e74d6f1e56ff495c2c51 SHA512 cecaa216b1f451b65e826856f630e5dd8ef9bbd85684602450e71f0f46b6b1b97bf20a0b7c401a72c354a5a9404386d6bd03350da2a65fb4e358320763d93ab4
diff --git a/net-vpn/tailscale/tailscale-1.46.1.ebuild b/net-vpn/tailscale/tailscale-1.46.1.ebuild
new file mode 100644
index 000000000000..4115c2796858
--- /dev/null
+++ b/net-vpn/tailscale/tailscale-1.46.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# These settings are obtained by running ./build_dist.sh shellvars` in
+# the upstream repo.
+VERSION_MINOR="46"
+VERSION_SHORT="1.46.1"
+VERSION_LONG="1.46.1-t2d3223f55"
+VERSION_GIT_HASH="2d3223f557924d408b5d67b80440d6fba264a0fd"
+
+DESCRIPTION="Tailscale vpn client"
+HOMEPAGE="https://tailscale.com"
+SRC_URI="https://github.com/tailscale/tailscale/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="net-firewall/iptables"
+
+RESTRICT="test"
+
+# This translates the build command from upstream's build_dist.sh to an
+# ebuild equivalent.
+build_dist() {
+ ego build -tags xversion -ldflags "
+ -X tailscale.com/version.Long=${VERSION_LONG}
+ -X tailscale.com/version.Short=${VERSION_SHORT}
+ -X tailscale.com/version.GitCommit=${VERSION_GIT_HASH}" "$@"
+}
+
+src_compile() {
+ build_dist ./cmd/tailscale
+ build_dist ./cmd/tailscaled
+}
+
+src_install() {
+ dosbin tailscaled
+ dobin tailscale
+
+ systemd_dounit cmd/tailscaled/tailscaled.service
+ insinto /etc/default
+ newins cmd/tailscaled/tailscaled.defaults tailscaled
+ keepdir /var/lib/${PN}
+ fperms 0750 /var/lib/${PN}
+
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles" ${PN}.conf
+
+ newinitd "${FILESDIR}/${PN}d.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}d.confd" ${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}