summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-02-15 11:20:55 -0600
committerWilliam Hubbs <williamh@gentoo.org>2024-02-15 11:21:12 -0600
commitb66c0817a62c6405a46db98e6131c70532a2f83d (patch)
tree6b926dd1e01ef1cab731bd5e1d5030acefc1ff15 /net-vpn
parentprofiles: Remove stable mask of USE=test for vulkan-utility-libraries (diff)
downloadgentoo-b66c0817a62c6405a46db98e6131c70532a2f83d.tar.gz
gentoo-b66c0817a62c6405a46db98e6131c70532a2f83d.tar.bz2
gentoo-b66c0817a62c6405a46db98e6131c70532a2f83d.zip
net-vpn/tailscale: add 1.58.2
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/tailscale/Manifest2
-rw-r--r--net-vpn/tailscale/tailscale-1.58.2.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/net-vpn/tailscale/Manifest b/net-vpn/tailscale/Manifest
index a80eda5f010b..527e12e64c65 100644
--- a/net-vpn/tailscale/Manifest
+++ b/net-vpn/tailscale/Manifest
@@ -2,3 +2,5 @@ DIST tailscale-1.50.1-deps.tar.xz 371484616 BLAKE2B cb4ac1939c4ad36bf3c752ccbdd1
DIST tailscale-1.50.1.tar.gz 1992569 BLAKE2B 503dd358d13f038eafd67d2c00f292965eaba390ec483daded893082a87428c4bbf01bafb0339aaca3ebc62123985f0686046959d4aa25325b877a779de83b34 SHA512 3eb0e0f0ef6df4d77f9649fb8deb8b829286bc8ab70016b09da6aad9aa4e5d027494e2151db425b52e775997345d39d13bce6013e8c69700023a936f142dcfd6
DIST tailscale-1.56.1-deps.tar.xz 395648828 BLAKE2B 08770560a70296af830763fdfd82ab16533911279c3d0719c5a628f8900292f1154b2a297111662152874251ae91081c03e34c25cb2016bd649bfcf89e423a3d SHA512 c3f91ce12ded8e0307e517f40c8953887ad4f85fe243d4dcfb7a874f478409dadc750e736c5d355a62dcacada30f1cf8f40adbc8d13ca9286f7456557da712ea
DIST tailscale-1.56.1.tar.gz 2311243 BLAKE2B 3046aae1d6b652cd0ce56202b1f24bafca019621878e7da2258c2850b534d8dff713d4e32b4c985bc1636382505934efb320e751ca75275054139184b8e61640 SHA512 a6e213eeb885d160b816f7d795d8ae66cd322d652657ee5309e220c6526eb73d5aea07dcd57983468520891c5405fcb84255350cdacc078514cede8a351a4888
+DIST tailscale-1.58.2-deps.tar.xz 397235964 BLAKE2B 3273320edb277d8f6527b6048f62356930287c6eeb1310e35dede72be0476331d2ae4ffe9658f8c36ebfc3384cc2b0e4f617cb25d2685c5e28dda66a9290e12b SHA512 370262f4589814d87587d8b685cde3a706611627ab6de09fdd271b3110baebebcfe2334574b7737643e5e2797638220901b1769eae469a08ec3325d82ac633de
+DIST tailscale-1.58.2.tar.gz 2361679 BLAKE2B 1aa66710677ba7c648782db9f67ce8cf565812b08610bb078bcd78ee2d695601fcb2f681102eb7a1232b6c4057ba5e1fed1d26b375cec793f0fbce65aff38755 SHA512 3370af3c0214544d15196063f798e17e7c35566cf4d01628faa1e26ba1a5885834b0f3d2862e3009a81ff9f4298cdd3f826fc5d09f23568c30c64bc6f0400f6b
diff --git a/net-vpn/tailscale/tailscale-1.58.2.ebuild b/net-vpn/tailscale/tailscale-1.58.2.ebuild
new file mode 100644
index 000000000000..0a375b02d222
--- /dev/null
+++ b/net-vpn/tailscale/tailscale-1.58.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# These settings are obtained by running ./build_dist.sh shellvars` in
+# the upstream repo.
+VERSION_MINOR="58"
+VERSION_SHORT="1.58.2"
+VERSION_LONG="1.58.2-tb0e1bbb62"
+VERSION_GIT_HASH="b0e1bbb62ef3834e99f5212b44043cec1866b07e"
+
+DESCRIPTION="Tailscale vpn client"
+HOMEPAGE="https://tailscale.com"
+SRC_URI="https://github.com/tailscale/tailscale/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="net-firewall/iptables"
+BDEPEND=">=dev-lang/go-1.21"
+
+RESTRICT="test"
+
+# This translates the build command from upstream's build_dist.sh to an
+# ebuild equivalent.
+build_dist() {
+ ego build -tags xversion -ldflags "
+ -X tailscale.com/version.Long=${VERSION_LONG}
+ -X tailscale.com/version.Short=${VERSION_SHORT}
+ -X tailscale.com/version.GitCommit=${VERSION_GIT_HASH}" "$@"
+}
+
+src_compile() {
+ build_dist ./cmd/tailscale
+ build_dist ./cmd/tailscaled
+}
+
+src_install() {
+ dosbin tailscaled
+ dobin tailscale
+
+ systemd_dounit cmd/tailscaled/tailscaled.service
+ insinto /etc/default
+ newins cmd/tailscaled/tailscaled.defaults tailscaled
+ keepdir /var/lib/${PN}
+ fperms 0750 /var/lib/${PN}
+
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles" ${PN}.conf
+
+ newinitd "${FILESDIR}/${PN}d.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}d.confd" ${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}