summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-09-24 12:19:12 -0400
committerAnthony G. Basile <blueness@gentoo.org>2019-09-24 12:19:51 -0400
commitdd08e553a35d81a2a853a9610083f2143a25039a (patch)
treecf5867c7cf1959cb47fdc26acbf0f320eb131aec /net-vpn
parentmedia-plugins/kodi-visualization-fishbmc: 5.1.1 version bump (diff)
downloadgentoo-dd08e553a35d81a2a853a9610083f2143a25039a.tar.gz
gentoo-dd08e553a35d81a2a853a9610083f2143a25039a.tar.bz2
gentoo-dd08e553a35d81a2a853a9610083f2143a25039a.zip
net-vpn/tor: version bump to 0.4.1.6
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/tor/Manifest1
-rw-r--r--net-vpn/tor/tor-0.4.1.6.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/net-vpn/tor/Manifest b/net-vpn/tor/Manifest
index ff75bd5feaaf..0d14e1cff82d 100644
--- a/net-vpn/tor/Manifest
+++ b/net-vpn/tor/Manifest
@@ -1,2 +1,3 @@
DIST tor-0.4.0.5.tar.gz 7203877 BLAKE2B e03710038615a5b9baf327933917c369bb3fabd4df6dd9f16053a0b72bcf20219e956e74258d0e39ae297d406035a89fab017d2e28c795f5d713c3933ad7cd29 SHA512 f6bccc52aaa436a501077b0891ecd3a9779f288b3b15fd76fa2c612e60aba04763b5951f55b2357e6271797b2f924bee9a6d2c1ee20419daa02d9d38ec68510b
DIST tor-0.4.1.5.tar.gz 7378436 BLAKE2B 33e4cd5958f4b0e1ece2cc035f87d6ccd255fcc9d0d1d92d05a9d469997f39120cddf700a614b80c83dbc4f57a80e270178ea3c04159b96aec248405654a6a5b SHA512 33d30f5fd2a92dfcb28d97c76c9d396d3eda27036b01c3a678428e878f046e45a87c2d42de0c1b8ba672568d75b08ba4cbf56d1aa50acd34c0d174180faace6e
+DIST tor-0.4.1.6.tar.gz 7390096 BLAKE2B b98f06b771953de781f446528096ff3c688599bae4c141f14a6be06373deebf11f6c15faf2168aee672bf75fcd25f42e2142e469046cd0a442b558c7cf41b28b SHA512 9e4625216e25b9498d6054a9920e5a8932ca7b28c5131062eac637b69c80cdf05bc3fd008b833e5359d8849e256f1f405abd56b07f50fd91077b153ba60503da
diff --git a/net-vpn/tor/tor-0.4.1.6.ebuild b/net-vpn/tor/tor-0.4.1.6.ebuild
new file mode 100644
index 000000000000..5260bac68c8c
--- /dev/null
+++ b/net-vpn/tor/tor-0.4.1.6.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic readme.gentoo-r1 systemd user
+
+MY_PV="$(ver_rs 4 -)"
+MY_PF="${PN}-${MY_PV}"
+DESCRIPTION="Anonymizing overlay network for TCP"
+HOMEPAGE="http://www.torproject.org/"
+SRC_URI="https://www.torproject.org/dist/${MY_PF}.tar.gz
+ https://archive.torproject.org/tor-package-archive/${MY_PF}.tar.gz"
+S="${WORKDIR}/${MY_PF}"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~ppc-macos"
+IUSE="caps doc libressl lzma +man scrypt seccomp selinux systemd tor-hardening test zstd"
+
+DEPEND="
+ dev-libs/libevent[ssl]
+ sys-libs/zlib
+ caps? ( sys-libs/libcap )
+ man? ( app-text/asciidoc )
+ !libressl? ( dev-libs/openssl:0=[-bindist] )
+ libressl? ( dev-libs/libressl:0= )
+ lzma? ( app-arch/xz-utils )
+ scrypt? ( app-crypt/libscrypt )
+ seccomp? ( sys-libs/libseccomp )
+ systemd? ( sys-apps/systemd )
+ zstd? ( app-arch/zstd )"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-tor )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.7.4-torrc.sample.patch
+ "${FILESDIR}"/${PN}-0.3.3.2-alpha-tor.service.in.patch
+)
+
+DOCS=()
+
+pkg_setup() {
+ enewgroup tor
+ enewuser tor -1 -1 /var/lib/tor tor
+}
+
+src_configure() {
+ use doc && DOCS+=( README ChangeLog ReleaseNotes doc/HACKING )
+ export ac_cv_lib_cap_cap_init=$(usex caps)
+ econf \
+ --localstatedir="${EPREFIX}/var" \
+ --enable-system-torrc \
+ --disable-android \
+ --disable-libfuzzer \
+ --disable-module-dirauth \
+ --enable-pic \
+ --disable-rust \
+ --disable-restart-debugging \
+ --disable-zstd-advanced-apis \
+ $(use_enable man asciidoc) \
+ $(use_enable lzma) \
+ $(use_enable scrypt libscrypt) \
+ $(use_enable seccomp) \
+ $(use_enable systemd) \
+ $(use_enable tor-hardening gcc-hardening) \
+ $(use_enable tor-hardening linker-hardening) \
+ $(use_enable test unittests) \
+ $(use_enable test coverage) \
+ $(use_enable zstd)
+}
+
+src_install() {
+ default
+ readme.gentoo_create_doc
+
+ newconfd "${FILESDIR}"/tor.confd tor
+ newinitd "${FILESDIR}"/tor.initd-r8 tor
+ systemd_dounit contrib/dist/tor.service
+
+ keepdir /var/lib/tor
+
+ fperms 750 /var/lib/tor
+ fowners tor:tor /var/lib/tor
+
+ insinto /etc/tor/
+ newins "${FILESDIR}"/torrc-r1 torrc
+
+}