summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-30 20:52:56 +0100
committerSam James <sam@gentoo.org>2023-05-30 20:53:02 +0100
commitf14ba0909e5de39ca3e0050d9932f41cead849f9 (patch)
tree319a0d1dd7f3df29e3277fe8a4b780d896247c22 /net-vpn
parentdev-python/hatchling: Enable tests on py3.12 (diff)
downloadgentoo-f14ba0909e5de39ca3e0050d9932f41cead849f9.tar.gz
gentoo-f14ba0909e5de39ca3e0050d9932f41cead849f9.tar.bz2
gentoo-f14ba0909e5de39ca3e0050d9932f41cead849f9.zip
net-vpn/openfortivpn: add 1.20.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/openfortivpn/Manifest1
-rw-r--r--net-vpn/openfortivpn/files/openfortivpn-1.02.3-systemd_substitute_bin_and_sysconfig_dirs.patch11
-rw-r--r--net-vpn/openfortivpn/openfortivpn-1.20.3.ebuild40
3 files changed, 52 insertions, 0 deletions
diff --git a/net-vpn/openfortivpn/Manifest b/net-vpn/openfortivpn/Manifest
index 96053ddc300f..b88e7b43c9a1 100644
--- a/net-vpn/openfortivpn/Manifest
+++ b/net-vpn/openfortivpn/Manifest
@@ -1,2 +1,3 @@
DIST openfortivpn-1.19.0.tar.gz 168962 BLAKE2B f2cff6f89a0662aca5911f6c3ef5953181383d4a66a41df83916c551338f07364436a174de39874cb654d6538955ac5d0a57a875facf2cc9b8c8a27a48df7fbf SHA512 4f4179178cbf2fc03ddebdfd4197c03a7108ecfa5216d5f11d80b2e3b840816f0a9a59714f58ecdcf966b76eb9b459e0bf78901940120ed1aa1cf69021385a53
DIST openfortivpn-1.20.2.tar.gz 167680 BLAKE2B fec9ef5f38af6cf32283cb281d0871115c3ddface35bbbe5fb96cd132cf2f586bd21ddaf55424bc902ea3984472109ec40ee4fd16706d10cc1795b4d68216b1d SHA512 e3ad8e74f7ba05f61df464af8a6ff6ba41e0c73ad52fbb9eaa9485814788a4636800b91cdd88f88caecbc9e305b2759a628b02fbe2eaf12d33c7912bb3ce065b
+DIST openfortivpn-1.20.3.tar.gz 168568 BLAKE2B ef6132c354c0348d09584675d7fe0213bf67f78df6ef36434f7e7d5166e6a7ec2dd4352613271f208a72b7666a6259642156bd297485714f9bc53f09fd2dce17 SHA512 38a1b208c2cbba1b1f723d6f8a2e178970b8fd384dbb424c38654821d56fc1652bae27b7593cd6af3c08d7c9b8cf97550185905b690e6eae7222b31aea266f01
diff --git a/net-vpn/openfortivpn/files/openfortivpn-1.02.3-systemd_substitute_bin_and_sysconfig_dirs.patch b/net-vpn/openfortivpn/files/openfortivpn-1.02.3-systemd_substitute_bin_and_sysconfig_dirs.patch
new file mode 100644
index 000000000000..e9435f3054ed
--- /dev/null
+++ b/net-vpn/openfortivpn/files/openfortivpn-1.02.3-systemd_substitute_bin_and_sysconfig_dirs.patch
@@ -0,0 +1,11 @@
+--- a/lib/systemd/system/openfortivpn@.service.in
++++ b/lib/systemd/system/openfortivpn@.service.in
+@@ -9,7 +9,7 @@ Documentation=https://github.com/adrienverge/openfortivpn/wiki
+ [Service]
+ Type=notify
+ PrivateTmp=true
+-ExecStart=@BINDIR@/openfortivpn -c @SYSCONFDIR@/openfortivpn/%I.conf
++ExecStart=/usr/bin/openfortivpn -c /etc/openfortivpn/%I.conf
+ Restart=on-failure
+ OOMScoreAdjust=-100
+
diff --git a/net-vpn/openfortivpn/openfortivpn-1.20.3.ebuild b/net-vpn/openfortivpn/openfortivpn-1.20.3.ebuild
new file mode 100644
index 000000000000..2a6111254e1e
--- /dev/null
+++ b/net-vpn/openfortivpn/openfortivpn-1.20.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info
+
+DESCRIPTION="Fortinet compatible VPN client"
+HOMEPAGE="https://github.com/adrienverge/openfortivpn"
+SRC_URI="https://github.com/adrienverge/openfortivpn/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3-with-openssl-exception openssl"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/openssl:=
+ <net-dialup/ppp-2.5.0
+"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~PPP ~PPP_ASYNC"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.02.3-systemd_substitute_bin_and_sysconfig_dirs.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' Makefile.am || die "Failed to remove -Werror from Makefile.am"
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ keepdir /etc/openfortivpn
+}