summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-wireless/adm8211/adm8211-20060111.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-wireless/adm8211/adm8211-20060111.ebuild')
-rw-r--r--net-wireless/adm8211/adm8211-20060111.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/net-wireless/adm8211/adm8211-20060111.ebuild b/net-wireless/adm8211/adm8211-20060111.ebuild
new file mode 100644
index 000000000000..df9c975a56fa
--- /dev/null
+++ b/net-wireless/adm8211/adm8211-20060111.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit linux-mod
+
+S=${WORKDIR}/${PN}
+
+DESCRIPTION="IEEE 802.11 wireless LAN driver for adm8211 based cards"
+HOMEPAGE="http://aluminum.sourmilk.net/adm8211/"
+SRC_URI="http://aluminum.sourmilk.net/adm8211/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+RDEPEND="net-wireless/wireless-tools"
+
+BUILD_TARGETS="all"
+
+MODULE_NAMES="adm8211(net:)"
+
+CONFIG_CHECK="WIRELESS_EXT CRYPTO_ARC4"
+ERROR_WIRELESS_EXT="${P} requires support for Wireless LAN drivers (non-hamradio) & Wireless Extensions"
+ERROR_CRYPTO_ARC4="${P} requires support for ARC4 cipher algorithm (CONFIG_CRYPTO_ARC4)."
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if kernel_is lt 2 6 10; then
+ eerror "${P} requires linux-2.6.9 or later."
+ die "${P} requires linux-2.6.9 or later"
+ fi
+
+ BUILD_PARAMS="KDIR=${KV_DIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/01-fix-up-build-breaks-from-2.6.19.patch
+ epatch ${FILESDIR}/02-Use-ieee80211_generic_get_stats.patch
+ epatch ${FILESDIR}/03-fix-work_struct-build-breakage.patch
+ epatch ${FILESDIR}/04-fix-set-essid-for-WE-21.patch
+ epatch ${FILESDIR}/05-update-email-address-from-jkmaline-cc.hut.fi-to.patch
+ kernel_is ge 2 6 22 && epatch ${FILESDIR}/06-adm8211-fix-build-breakage-from-skb-mac.raw.patch
+
+ convert_to_m ${S}/Makefile
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc Changelog NOTES TODO
+}