summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-15 21:17:46 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-15 21:20:25 -0400
commit4ef11d009cb731a7d6968ef41b3967418ce58087 (patch)
treeb55426402a1ca0e188cf4a0801a6b6af2e651fd4 /net-wireless/gnome-bluetooth/gnome-bluetooth-3.34.5.ebuild
parentx11-themes/gnome-backgrounds: Version bump to 40.0 (diff)
downloadgentoo-4ef11d009cb731a7d6968ef41b3967418ce58087.tar.gz
gentoo-4ef11d009cb731a7d6968ef41b3967418ce58087.tar.bz2
gentoo-4ef11d009cb731a7d6968ef41b3967418ce58087.zip
net-wireless/gnome-bluetooth: Version bump to 3.34.5
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-wireless/gnome-bluetooth/gnome-bluetooth-3.34.5.ebuild')
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-3.34.5.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-3.34.5.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.34.5.ebuild
new file mode 100644
index 000000000000..04b83b0833a2
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.34.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson udev xdg
+
+DESCRIPTION="Bluetooth graphical utilities integrated with GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeBluetooth"
+
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
+SLOT="2/13" # subslot = libgnome-bluetooth soname version
+IUSE="gtk-doc +introspection"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.12:3[introspection?]
+ media-libs/libcanberra[gtk3]
+ >=x11-libs/libnotify-0.7.0
+ virtual/libudev
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+RDEPEND="${DEPEND}
+ acct-group/plugdev
+ virtual/udev
+ >=net-wireless/bluez-5
+"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.9 )
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dicon_update=false
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ udev_dorules "${FILESDIR}"/61-${PN}.rules
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ if ! has_version 'sys-apps/systemd[acl]' ; then
+ elog "Don't forget to add yourself to the plugdev group "
+ elog "if you want to be able to control bluetooth transmitter."
+ fi
+}