summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-08-14 14:31:01 -0400
committerRick Farina <zerochaos@gentoo.org>2020-08-14 14:31:01 -0400
commit58b873f93723920df128007c11e3db131619039d (patch)
tree26d48756eacdde089bbfdf4c068f9c5d1519a62e /net-wireless/hackrf-tools
parentnet-wireless/hackrf-tools: remove unnescessary +x (diff)
downloadgentoo-58b873f93723920df128007c11e3db131619039d.tar.gz
gentoo-58b873f93723920df128007c11e3db131619039d.tar.bz2
gentoo-58b873f93723920df128007c11e3db131619039d.zip
net-wireless/hackrf-tools: migrate to cmake.eclass
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless/hackrf-tools')
-rw-r--r--net-wireless/hackrf-tools/hackrf-tools-2018.01.1-r1.ebuild6
-rw-r--r--net-wireless/hackrf-tools/hackrf-tools-9999.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/net-wireless/hackrf-tools/hackrf-tools-2018.01.1-r1.ebuild b/net-wireless/hackrf-tools/hackrf-tools-2018.01.1-r1.ebuild
index 787eb9c15248..85077b67001e 100644
--- a/net-wireless/hackrf-tools/hackrf-tools-2018.01.1-r1.ebuild
+++ b/net-wireless/hackrf-tools/hackrf-tools-2018.01.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="tools for communicating with HackRF SDR platform"
HOMEPAGE="http://greatscottgadgets.com/hackrf/"
@@ -29,7 +29,7 @@ DEPEND="~net-libs/libhackrf-${PV}:=
RDEPEND="${DEPEND}"
src_install() {
- cmake-utils_src_install
+ cmake_src_install
dosbin "${FILESDIR}/hackrf_easy_flash"
if [[ ${PV} != "9999" ]] ; then
insinto /usr/share/hackrf
diff --git a/net-wireless/hackrf-tools/hackrf-tools-9999.ebuild b/net-wireless/hackrf-tools/hackrf-tools-9999.ebuild
index 849ca9207958..d7c23f080763 100644
--- a/net-wireless/hackrf-tools/hackrf-tools-9999.ebuild
+++ b/net-wireless/hackrf-tools/hackrf-tools-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="tools for communicating with HackRF SDR platform"
HOMEPAGE="http://greatscottgadgets.com/hackrf/"
@@ -29,7 +29,7 @@ DEPEND="~net-libs/libhackrf-${PV}:=
RDEPEND="${DEPEND}"
src_install() {
- cmake-utils_src_install
+ cmake_src_install
dosbin "${FILESDIR}/hackrf_easy_flash"
if [[ ${PV} != "9999" ]] ; then
insinto /usr/share/hackrf