summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-12 10:46:30 +0000
committerSam James <sam@gentoo.org>2021-06-12 10:54:03 +0000
commit86cc0139a30af31444b0bb1cd43520c381162c68 (patch)
tree0aec34262d2eae8af0b01bcb74a308f4a6f16bf8 /net-wireless/hostapd/hostapd-9999.ebuild
parentapp-text/poppler: Synced live ebuild (diff)
downloadgentoo-86cc0139a30af31444b0bb1cd43520c381162c68.tar.gz
gentoo-86cc0139a30af31444b0bb1cd43520c381162c68.tar.bz2
gentoo-86cc0139a30af31444b0bb1cd43520c381162c68.zip
net-wireless/hostapd: ebuild tidying
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-wireless/hostapd/hostapd-9999.ebuild')
-rw-r--r--net-wireless/hostapd/hostapd-9999.ebuild27
1 files changed, 12 insertions, 15 deletions
diff --git a/net-wireless/hostapd/hostapd-9999.ebuild b/net-wireless/hostapd/hostapd-9999.ebuild
index c9cb0fa9f955..6149f90b94e0 100644
--- a/net-wireless/hostapd/hostapd-9999.ebuild
+++ b/net-wireless/hostapd/hostapd-9999.ebuild
@@ -28,30 +28,29 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE="internal-tls ipv6 logwatch netlink sqlite +suiteb +wps +crda"
+IUSE="internal-tls ipv6 netlink sqlite +suiteb +wps +crda"
DEPEND="
- internal-tls? ( dev-libs/libtommath )
- !internal-tls? ( dev-libs/openssl:0=[-bindist] )
-
+ internal-tls? ( dev-libs/libtommath )
+ !internal-tls? ( dev-libs/openssl:0=[-bindist] )
kernel_linux? (
dev-libs/libnl:3
crda? ( net-wireless/crda )
)
netlink? ( net-libs/libnfnetlink )
sqlite? ( >=dev-db/sqlite-3 )"
-
RDEPEND="${DEPEND}"
pkg_pretend() {
if use internal-tls; then
- ewarn "internal-tls implementation is experimental and provides fewer features"
+ ewarn "internal-tls implementation is experimental and provides fewer features"
fi
}
src_unpack() {
# Override default one because we need the SRC_URI ones even in case of 9999 ebuilds
default
+
if [[ ${PV} == 9999 ]] ; then
git-r3_src_unpack
fi
@@ -69,7 +68,7 @@ src_prepare() {
}
src_configure() {
- local CONFIG="${S}/.config"
+ local CONFIG="${S}"/.config
restore_config "${CONFIG}"
if [[ -f "${CONFIG}" ]]; then
@@ -226,20 +225,18 @@ src_install() {
docinto examples
dodoc wired.conf
- if use logwatch; then
- insinto /etc/log.d/conf/services/
- doins logwatch/${PN}.conf
+ insinto /etc/log.d/conf/services/
+ doins logwatch/${PN}.conf
- exeinto /etc/log.d/scripts/services/
- doexe logwatch/${PN}
- fi
+ exeinto /etc/log.d/scripts/services/
+ doexe logwatch/${PN}
save_config .config
}
pkg_postinst() {
einfo
- einfo "If you are running openRC you need to follow this instructions:"
+ einfo "If you are running OpenRC you need to follow this instructions:"
einfo "In order to use ${PN} you need to set up your wireless card"
einfo "for master mode in /etc/conf.d/net and then start"
einfo "/etc/init.d/${PN}."
@@ -260,7 +257,7 @@ pkg_postinst() {
if use wps; then
einfo "You have enabled Wi-Fi Protected Setup support, please"
- einfo "read the README-WPS file in /usr/share/doc/${P}"
+ einfo "read the README-WPS file in /usr/share/doc/${PF}"
einfo "for info on how to use WPS"
fi
}