summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-wireless/kismet-ubertooth/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-wireless/kismet-ubertooth/files')
-rw-r--r--net-wireless/kismet-ubertooth/files/kismet-ubertooth-0.0_p534-respect-cflags.patch61
1 files changed, 61 insertions, 0 deletions
diff --git a/net-wireless/kismet-ubertooth/files/kismet-ubertooth-0.0_p534-respect-cflags.patch b/net-wireless/kismet-ubertooth/files/kismet-ubertooth-0.0_p534-respect-cflags.patch
new file mode 100644
index 000000000000..570a5def7882
--- /dev/null
+++ b/net-wireless/kismet-ubertooth/files/kismet-ubertooth-0.0_p534-respect-cflags.patch
@@ -0,0 +1,61 @@
+--- /var/tmp/portage/net-wireless/kismet-ubertooth-0.0_p534/work/ubertooth-r534/host/kismet/plugin-ubertooth-phyneutral/Makefile 2012-04-30 12:08:07.000000000 -0400
++++ host/kismet/plugin-ubertooth-phyneutral/Makefile 2012-07-23 12:50:07.883119040 -0400
+@@ -11,13 +11,12 @@
+
+ PLUGINLDFLAGS ?= $(LDFLAGS)
+ PLUGINLDFLAGS += -shared -rdynamic
+-LIBS += -lstdc++ -lusb-1.0 -lpthread -lbtbb
+-CFLAGS ?= $(CFLAGS) $(CPPFLAGS)
++LIBS += -lstdc++ -lusb-1.0 -lpthread -lbtbb
+ CFLAGS += -I$(KIS_INC_DIR) -I$(RXTX_INC_DIR) -g -fPIC
++CXXFLAGS += -I$(KIS_INC_DIR) -I$(RXTX_INC_DIR) -g -fPIC
+
+ SRVOBJS = packetsource_ubertooth.o packet_btbb_types.o \
+- phy_btbb.o kismet_ubertooth.o \
+- $(RXTX_SRC_DIR)/ubertooth.o
++ phy_btbb.o kismet_ubertooth.o
+ SRVOUT = ubertooth.so
+
+ all: $(SRVOUT)
+@@ -38,9 +37,9 @@
+ @-rm -f *.so
+
+ .c.o:
+- $(CC) $(CFLAGS) -c $*.c -o $@
++ $(CC) $(CPPFLAGS) $(CFLAGS) -c $*.c -o $@
+
+ .cc.o:
+- $(CXX) $(CFLAGS) -c $*.cc -o $@
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -c $*.cc -o $@
+
+ .SUFFIXES: .c .cc .o
+--- /var/tmp/portage/net-wireless/kismet-ubertooth-0.0_p534/work/ubertooth-r534/host/kismet/plugin-ubertooth/Makefile 2012-04-04 19:18:29.000000000 -0400
++++ host/kismet/plugin-ubertooth/Makefile 2012-07-23 12:50:07.890119040 -0400
+@@ -11,12 +11,12 @@
+
+ PLUGINLDFLAGS ?= $(LDFLAGS)
+ PLUGINLDFLAGS += -shared -rdynamic
+-LIBS += -lstdc++ -lusb-1.0 -lpthread -lbtbb
+-CFLAGS ?= $(CFLAGS) $(CPPFLAGS)
++LIBS += -lstdc++ -lusb-1.0 -lpthread -lbtbb
+ CFLAGS += -I/usr/include -I$(KIS_INC_DIR) -I$(RXTX_INC_DIR) -g -fPIC
++CXXFLAGS += -I/usr/include -I$(KIS_INC_DIR) -I$(RXTX_INC_DIR) -g -fPIC
+
+ SRVOBJS = packetsource_ubertooth.o packet_btbb.o packet_btbb_types.o \
+- tracker_btbb.o kismet_ubertooth.o $(RXTX_SRC_DIR)/ubertooth.o
++ tracker_btbb.o kismet_ubertooth.o
+ SRVOUT = ubertooth.so
+
+ CLIOBJS = ubertooth_ui.o
+@@ -48,9 +48,9 @@
+ @-rm -f *.so
+
+ .c.o:
+- $(CC) $(CFLAGS) -c $*.c -o $@
++ $(CC) $(CPPFLAGS) $(CFLAGS) -c $*.c -o $@
+
+ .cc.o:
+- $(CXX) $(CFLAGS) -c $*.cc -o $@
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -c $*.cc -o $@
+
+ .SUFFIXES: .c .cc .o