summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2017-03-20 13:06:20 -0400
committerZero_Chaos <zerochaos@gentoo.org>2017-03-20 13:06:55 -0400
commitb265417f73de7d6cd26f05fee4cfd1e4f0945c7b (patch)
tree3d135a4e7a4e5f688baa64e222492e2677bbb70d /net-wireless/kismet-ubertooth/kismet-ubertooth-2017.03.2.ebuild
parentnet-wireless/ubertooth: bump (diff)
downloadgentoo-b265417f73de7d6cd26f05fee4cfd1e4f0945c7b.tar.gz
gentoo-b265417f73de7d6cd26f05fee4cfd1e4f0945c7b.tar.bz2
gentoo-b265417f73de7d6cd26f05fee4cfd1e4f0945c7b.zip
net-wireless/kismet-ubertooth: bump
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'net-wireless/kismet-ubertooth/kismet-ubertooth-2017.03.2.ebuild')
-rw-r--r--net-wireless/kismet-ubertooth/kismet-ubertooth-2017.03.2.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-wireless/kismet-ubertooth/kismet-ubertooth-2017.03.2.ebuild b/net-wireless/kismet-ubertooth/kismet-ubertooth-2017.03.2.ebuild
new file mode 100644
index 000000000000..1ed24b3efdb0
--- /dev/null
+++ b/net-wireless/kismet-ubertooth/kismet-ubertooth-2017.03.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit multilib
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/greatscottgadgets/ubertooth.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ MY_PV=${PV/\./-}
+ MY_PV=${MY_PV/./-R}
+ S="${WORKDIR}/ubertooth-${MY_PV}"
+ SRC_URI="https://github.com/greatscottgadgets/ubertooth/releases/download/${MY_PV}/ubertooth-${MY_PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Provides basic bluetooth support in kismet"
+HOMEPAGE="http://ubertooth.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE=""
+
+DEPEND=">=net-wireless/kismet-2011.03.2-r1:= \
+ >=net-wireless/ubertooth-${PV}:= \
+ >=net-libs/libbtbb-${PV}:= \
+ virtual/libusb:1"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ if has_version =net-wireless/kismet-9999; then
+ cd "${S}/host/kismet/plugin-ubertooth-phyneutral" || die
+ else
+ cd "${S}/host/kismet/plugin-ubertooth" || die
+ fi
+ emake KIS_SRC_DIR="/usr/include/kismet/"
+}
+
+src_install() {
+ if has_version =net-wireless/kismet-9999; then
+ cd "${S}/host/kismet/plugin-ubertooth-phyneutral" || die
+ else
+ cd "${S}/host/kismet/plugin-ubertooth" || die
+ fi
+ emake DESTDIR="${ED}" LIBDIR="/$(get_libdir)" KIS_SRC_DIR="/usr/include/kismet/" install
+}
+
+pkg_postinst() {
+ ewarn "This package must be rebuilt every time kismet is rebuilt. Or else."
+}