summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-12-03 13:08:34 -0500
committerZero_Chaos <zerochaos@gentoo.org>2018-12-03 13:08:47 -0500
commit2b53af8fbb1f5710abdd9cbf24ee8c450d2b5bd4 (patch)
tree51903cdcf6a26daa8971ad283afde3ba79c7d51a /net-wireless/kismet/files
parentwww-client/opera-developer: Old (diff)
downloadgentoo-2b53af8fbb1f5710abdd9cbf24ee8c450d2b5bd4.tar.gz
gentoo-2b53af8fbb1f5710abdd9cbf24ee8c450d2b5bd4.tar.bz2
gentoo-2b53af8fbb1f5710abdd9cbf24ee8c450d2b5bd4.zip
net-wireless/kismet: fix bug #662726
patch upstream issue disabling lmsensors live fixups while I'm in there Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless/kismet/files')
-rw-r--r--net-wireless/kismet/files/fix-setuptools3.patch65
1 files changed, 65 insertions, 0 deletions
diff --git a/net-wireless/kismet/files/fix-setuptools3.patch b/net-wireless/kismet/files/fix-setuptools3.patch
new file mode 100644
index 000000000000..4e9787d8aa99
--- /dev/null
+++ b/net-wireless/kismet/files/fix-setuptools3.patch
@@ -0,0 +1,65 @@
+diff --git a/capture_freaklabs_zigbee/Makefile.in b/capture_freaklabs_zigbee/Makefile.in
+index cfbf99b0..c2e68453 100644
+--- a/capture_freaklabs_zigbee/Makefile.in
++++ b/capture_freaklabs_zigbee/Makefile.in
+@@ -6,7 +6,7 @@ all:
+ $(PYTHON2) ./setup.py build
+
+ install:
+- $(PYTHON2) ./setup.py install
++ $(PYTHON2) ./setup.py install --root=$(DESTDIR)
+ # $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) $(MONITOR_BIN) $(BIN)/$(MONITOR_BIN)
+
+ clean:
+diff --git a/capture_sdr_rtl433/Makefile.in b/capture_sdr_rtl433/Makefile.in
+index e33f7de5..e1be587d 100644
+--- a/capture_sdr_rtl433/Makefile.in
++++ b/capture_sdr_rtl433/Makefile.in
+@@ -7,7 +7,7 @@ all:
+ $(PYTHON2) ./setup.py build
+
+ install:
+- $(PYTHON2) ./setup.py install
++ $(PYTHON2) ./setup.py install --root=$(DESTDIR)
+ # These are now part of the setup.py install
+ # $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) $(MONITOR_BIN) $(BIN)/$(MONITOR_BIN)
+ # $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) $(MQTTMONITOR_BIN) $(BIN)/$(MQTTMONITOR_BIN)
+diff --git a/python_modules/KismetExternal/Makefile b/python_modules/KismetExternal/Makefile
+index 036541a0..fc660dfe 100644
+--- a/python_modules/KismetExternal/Makefile
++++ b/python_modules/KismetExternal/Makefile
+@@ -4,7 +4,7 @@ all:
+ $(PYTHON2) ./setup.py build
+
+ install:
+- $(PYTHON2) ./setup.py install
++ $(PYTHON2) ./setup.py install --root=$(DESTDIR)
+
+ protobuf:
+ $(PROTOCBIN) -I ../../protobuf_definitions --python_out=./KismetExternal ../../protobuf_definitions/*.proto
+diff --git a/python_modules/KismetLog/Makefile b/python_modules/KismetLog/Makefile
+index d0d6f784..60e1eac1 100644
+--- a/python_modules/KismetLog/Makefile
++++ b/python_modules/KismetLog/Makefile
+@@ -4,7 +4,7 @@ all:
+ $(PYTHON2) ./setup.py build
+
+ install:
+- $(PYTHON2) ./setup.py install
++ $(PYTHON2) ./setup.py install --root=$(DESTDIR)
+
+ clean:
+ @-$(PYTHON2) ./setup.py clean
+diff --git a/python_modules/KismetRest/Makefile b/python_modules/KismetRest/Makefile
+index d0d6f784..60e1eac1 100644
+--- a/python_modules/KismetRest/Makefile
++++ b/python_modules/KismetRest/Makefile
+@@ -4,7 +4,7 @@ all:
+ $(PYTHON2) ./setup.py build
+
+ install:
+- $(PYTHON2) ./setup.py install
++ $(PYTHON2) ./setup.py install --root=$(DESTDIR)
+
+ clean:
+ @-$(PYTHON2) ./setup.py clean