summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-08-02 14:34:57 -0400
committerZero_Chaos <zerochaos@gentoo.org>2018-08-02 14:35:22 -0400
commitd9ba9843cdb7df8d267580bb4a02635dc74d01bd (patch)
tree75934f922a4246aca719d9b6bb5aeffb02ac6af2 /net-wireless/kismet/kismet-9999.ebuild
parentmedia-video/mjpegtools: Remove old. (diff)
downloadgentoo-d9ba9843cdb7df8d267580bb4a02635dc74d01bd.tar.gz
gentoo-d9ba9843cdb7df8d267580bb4a02635dc74d01bd.tar.bz2
gentoo-d9ba9843cdb7df8d267580bb4a02635dc74d01bd.zip
net-wireless/kismet: beta wooooooo
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'net-wireless/kismet/kismet-9999.ebuild')
-rw-r--r--net-wireless/kismet/kismet-9999.ebuild91
1 files changed, 12 insertions, 79 deletions
diff --git a/net-wireless/kismet/kismet-9999.ebuild b/net-wireless/kismet/kismet-9999.ebuild
index 2a6321ed5126..1f6e8da8176c 100644
--- a/net-wireless/kismet/kismet-9999.ebuild
+++ b/net-wireless/kismet/kismet-9999.ebuild
@@ -8,6 +8,7 @@ PYTHON_COMPAT=( python2_7 )
inherit autotools eutils multilib user python-single-r1
MY_P=${P/\./-}
+MY_P=${MY_P/_beta/-BETA}
MY_P=${MY_P/./-R}
S=${WORKDIR}/${MY_P}
@@ -27,7 +28,7 @@ HOMEPAGE="https://www.kismetwireless.net"
LICENSE="GPL-2"
SLOT="0/${PV}"
-IUSE="+pcre speech selinux +suid"
+IUSE="lm_sensors +pcre selinux +suid"
CDEPEND="
${PYTHON_DEPS}
@@ -43,13 +44,10 @@ CDEPEND="
)
dev-libs/protobuf-c:=
sys-libs/ncurses:=
+ lm_sensors? ( sys-apps/lm_sensors )
pcre? ( dev-libs/libpcre )
suid? ( sys-libs/libcap )
- !arm? ( speech? ( app-accessibility/flite ) )
"
- #plugin-btscan? ( net-wireless/bluez )
- #plugin-dot15d4? ( virtual/libusb:0 )
- #plugin-spectools? ( net-wireless/spectools )
DEPEND="${CDEPEND}
virtual/pkgconfig
@@ -69,95 +67,30 @@ src_prepare() {
epatch "${FILESDIR}"/fix-setuptools.patch
eapply_user
- eautoreconf
+ if [[ ${PV} == "9999" ]] ; then
+ sed -i 's#-O3##' configure.ac
+ eautoreconf
+ else
+ sed -i 's#-O3##' configure
+ fi
}
src_configure() {
+ if ! use lm_sensors; then
+ adddeny /usr/include/sensors/sensors.h
+ fi
econf \
$(use_enable pcre)
- #--disable-python-tools
-}
-
-src_compile() {
- emake
-
- #if use plugin-autowep; then
- # cd "${S}"/restricted-plugin-autowep
- # KIS_SRC_DIR="${S}" emake
- #fi
- #if use plugin-btscan; then
- # cd "${S}"/plugin-btscan
- # KIS_SRC_DIR="${S}" emake
- #fi
- #if use plugin-dot15d4; then
- # cd "${S}"/plugin-dot15d4
- # KIS_SRC_DIR="${S}" emake
- #fi
- #if use plugin-ptw; then
- # cd "${S}"/restricted-plugin-ptw
- # KIS_SRC_DIR="${S}" emake
- #fi
- #if use plugin-spectools; then
- # cd "${S}"/plugin-spectools
- # KIS_SRC_DIR="${S}" emake
- #fi
- #if use plugin-syslog; then
- # cd "${S}"/plugin-syslog
- # KIS_SRC_DIR="${S}" emake
- #fi
}
src_install() {
- #if use plugin-autowep; then
- # cd "${S}"/restricted-plugin-autowep
- # KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
- #fi
- #if use plugin-btscan; then
- # cd "${S}"/plugin-btscan
- # KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
- #fi
- #if use plugin-dot15d4; then
- # cd "${S}"/plugin-dot15d4
- # KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
- #fi
- #if use plugin-ptw; then
- # cd "${S}"/restricted-plugin-ptw
- # KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
- #fi
- #if use plugin-spectools; then
- # cd "${S}"/plugin-spectools
- # KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
- #fi
- #if use plugin-syslog; then
- # cd "${S}"/plugin-syslog
- # KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
- #fi
- #if use ruby; then
- # cd "${S}"/ruby
- # dobin *.rb
- #fi
-
- #cd "${S}"
emake DESTDIR="${D}" commoninstall
emake DESTDIR="${D}" forceconfigs
- ##dragorn would prefer I set fire to my head than do this, but it works
- ##all external kismet plugins (read: kismet-ubertooth) must be rebuilt when kismet is
- ##is there an automatic way to force this?
- # install headers for external plugins
- insinto /usr/include/kismet
- doins *.h
- doins Makefile.inc
- #todo write a plugin finder that tells you what needs to be rebuilt when kismet is updated, etc
-
#dodoc CHANGELOG RELEASENOTES.txt README* docs/DEVEL.client docs/README.newcore
dodoc CHANGELOG README*
newinitd "${FILESDIR}"/${PN}.initd kismet
newconfd "${FILESDIR}"/${PN}.confd kismet
-
- #if use suid; then
- # dobin kismet_capture
- #fi
}
pkg_preinst() {