summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2023-08-19 09:41:17 -0400
committerRick Farina <zerochaos@gentoo.org>2023-08-19 09:41:17 -0400
commitc9f4f60f07fcfd759eb418fc8b3d5f5fdc5e93f6 (patch)
tree1dbd4c7a1ec512ab942d7bffdd46dd9a14cc9561 /net-wireless/lorcon/lorcon-0.0_p20200214.ebuild
parentnet-wireless/lorcon: enable py3.12 (diff)
downloadgentoo-c9f4f60f07fcfd759eb418fc8b3d5f5fdc5e93f6.tar.gz
gentoo-c9f4f60f07fcfd759eb418fc8b3d5f5fdc5e93f6.tar.bz2
gentoo-c9f4f60f07fcfd759eb418fc8b3d5f5fdc5e93f6.zip
net-wireless/lorcon: drop 0.0_p20200214
Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless/lorcon/lorcon-0.0_p20200214.ebuild')
-rw-r--r--net-wireless/lorcon/lorcon-0.0_p20200214.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/net-wireless/lorcon/lorcon-0.0_p20200214.ebuild b/net-wireless/lorcon/lorcon-0.0_p20200214.ebuild
deleted file mode 100644
index f3d0a140a745..000000000000
--- a/net-wireless/lorcon/lorcon-0.0_p20200214.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-DISTUTILS_OPTIONAL=1
-
-inherit distutils-r1
-
-DESCRIPTION="A generic library for injecting 802.11 frames"
-HOMEPAGE="https://github.com/kismetwireless/lorcon"
-
-if [[ ${PV} == "9999" ]] ; then
- #EGIT_REPO_URI="https://www.kismetwireless.net/lorcon.git"
- EGIT_REPO_URI="https://github.com/kismetwireless/lorcon.git"
- inherit git-r3
- S="${WORKDIR}"/${P}
-else
- GIT_HASH="7dbf24ee6f7c277240c0fbd988b6902850577772"
- SRC_URI="https://github.com/kismetwireless/lorcon/archive/${GIT_HASH}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}"/"${PN}-${GIT_HASH}"
- KEYWORDS="amd64 arm ~arm64 ppc x86 ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="python"
-
-DEPEND="
- python? ( ${PYTHON_DEPS} )
- dev-libs/libnl:3=
- net-libs/libpcap"
-RDEPEND="${DEPEND}"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RESTRICT="test"
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- git-r3_src_unpack
- cp -R "${S}/" "${WORKDIR}/all"
- fi
- default_src_unpack
-}
-
-src_prepare() {
- default
- use python && distutils-r1_src_prepare
-}
-
-src_configure() {
- econf --disable-static
-}
-
-src_compile() {
- default_src_compile
- if use python; then
- LDFLAGS+=" -L${S}/.libs/"
- cd pylorcon2 || die
- distutils-r1_src_compile
- fi
-}
-
-src_install() {
- emake DESTDIR="${ED}" install
- if use python; then
- cd pylorcon2 || die
- distutils-r1_src_install
- fi
- find "${ED}" -name '*.la' -delete || die
-}