summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.9.4.4180.20120502.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.9.4.4180.20120502.ebuild')
-rw-r--r--net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.9.4.4180.20120502.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.9.4.4180.20120502.ebuild b/net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.9.4.4180.20120502.ebuild
new file mode 100644
index 000000000000..8ebaca2b30a1
--- /dev/null
+++ b/net-wireless/madwifi-ng-tools/madwifi-ng-tools-0.9.4.4180.20120502.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit versionator toolchain-funcs
+
+MY_PN=${PN/-ng-tools/}
+MY_PV=$(get_version_component_range 1-3)
+MY_REV=$(get_version_component_range 4)
+MY_DATE=$(get_version_component_range 5)
+MY_P=${MY_PN}-${MY_PV}-r${MY_REV}-${MY_DATE}
+S=${WORKDIR}/${MY_P}/tools
+
+DESCRIPTION="Next Generation tools for configuration of Atheros based IEEE 802.11a/b/g wireless LAN cards"
+HOMEPAGE="http://www.madwifi-project.org/"
+SRC_URI="http://snapshots.madwifi-project.org/${MY_PN}-${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!net-wireless/madwifi-old-tools"
+
+src_prepare() {
+ # format string fix from solar
+ #sed -i \
+# -e 's:err(1, ifr.ifr_name);:err(1, "%s", ifr.ifr_name);:g' \
+# ${S}/tools/athstats.c || die
+
+ sed -i \
+ -e "s:CC =.*:CC = $(tc-getCC):" \
+ -e "s:CFLAGS=:CFLAGS+=:" \
+ -e "s:LDFLAGS=:LDFLAGS+=:" \
+ "${S}"/Makefile || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" BINDIR=/usr/bin MANDIR=/usr/share/man STRIP=echo \
+ install || die "emake install failed"
+
+ dodir /sbin
+ mv "${D}"/usr/bin/wlanconfig "${D}"/sbin
+
+ # install headers for use by
+ # net-wireless/wpa_supplicant and net-wireless/hostapd
+ cd "${S}"/..
+ insinto /usr/include/madwifi/include/
+ doins include/*.h
+ insinto /usr/include/madwifi/net80211
+ doins net80211/*.h
+}
+
+pkg_postinst() {
+ if [ -e "${ROOT}"/etc/udev/rules.d/65-madwifi.rules ]; then
+ ewarn
+ ewarn "The udev rules for creating interfaces (athX) are no longer needed."
+ ewarn
+ ewarn "You should manually remove the /etc/udev/rules.d/65-madwifi.rules file"
+ ewarn "and either run 'udevstart' or reboot for the changes to take effect."
+ ewarn
+ fi
+ einfo
+ einfo "If you use net-wireless/wpa_supplicant or net-wireless/hostapd with madwifi"
+ einfo "you should remerge them now."
+ einfo
+}