summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-wireless/multimode/multimode-9999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-wireless/multimode/multimode-9999.ebuild')
-rw-r--r--net-wireless/multimode/multimode-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-wireless/multimode/multimode-9999.ebuild b/net-wireless/multimode/multimode-9999.ebuild
new file mode 100644
index 000000000000..26b61e05aa78
--- /dev/null
+++ b/net-wireless/multimode/multimode-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT="python2_7"
+
+inherit python-single-r1
+
+DESCRIPTION="multimode radio decoder for rtl-sdr devices using gnuradio"
+HOMEPAGE="https://www.cgran.org/browser/projects/multimode/trunk"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="https://www.cgran.org/svn/projects/multimode/trunk"
+ inherit subversion
+ KEYWORDS=""
+else
+ #SRC_URI="http://www.sbrac.org/files/${PN}-r${PV}.tar.gz"
+ SRC_URI="https://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DEPEND="=net-wireless/gnuradio-9999:=[grc,utils,${PYTHON_USEDEP}]
+ =net-wireless/gr-osmosdr-9999:="
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ PYTHONPATH="${S}":"${PYTHONPATH}" emake
+}
+
+src_install() {
+ newbin ${PN}.py ${PN}
+ insinto $(python_get_sitedir)
+ doins ${PN}_helper.py
+ insinto /usr/share/${PN}
+ doins ${PN}.grc
+ python_fix_shebang "${ED}"/usr/bin
+}