summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-12-03 22:00:34 -0500
committerRick Farina <zerochaos@gentoo.org>2020-12-03 22:14:07 -0500
commit76fe64f580c4e2d89b3a6952fdf84c0dadbf09cf (patch)
treeb1b9a8e764c34560ee2a440a49caa1701a99e8c7 /net-wireless/soapysdr/soapysdr-9999.ebuild
parentnet-wireless/nanovna-saver: bump (diff)
downloadgentoo-76fe64f580c4e2d89b3a6952fdf84c0dadbf09cf.tar.gz
gentoo-76fe64f580c4e2d89b3a6952fdf84c0dadbf09cf.tar.bz2
gentoo-76fe64f580c4e2d89b3a6952fdf84c0dadbf09cf.zip
net-wireless/soapysdr: fix qa warnings
Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless/soapysdr/soapysdr-9999.ebuild')
-rw-r--r--net-wireless/soapysdr/soapysdr-9999.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/net-wireless/soapysdr/soapysdr-9999.ebuild b/net-wireless/soapysdr/soapysdr-9999.ebuild
index f3b498a69d52..d5a5aa7bad6c 100644
--- a/net-wireless/soapysdr/soapysdr-9999.ebuild
+++ b/net-wireless/soapysdr/soapysdr-9999.ebuild
@@ -3,9 +3,9 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
-inherit cmake-utils python-r1
+inherit cmake python-r1
DESCRIPTION="vendor and platform neutral SDR support library"
HOMEPAGE="https://github.com/pothosware/SoapySDR"
@@ -13,7 +13,6 @@ HOMEPAGE="https://github.com/pothosware/SoapySDR"
if [ "${PV}" = "9999" ]; then
EGIT_REPO_URI="https://github.com/pothosware/SoapySDR.git"
EGIT_CLONE_TYPE="shallow"
- KEYWORDS=""
inherit git-r3
else
KEYWORDS="~amd64 ~x86"
@@ -49,5 +48,10 @@ src_configure() {
python_foreach_impl configuration
fi
- cmake-utils_src_configure
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ python_foreach_impl python_optimize
}