summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2021-03-30 16:20:06 -0400
committerRick Farina <zerochaos@gentoo.org>2021-03-30 16:20:06 -0400
commit192e85579ff29966aaeca626319646a5f85261f2 (patch)
treec4f909cf12587702722a5a39328406f9ccfcf245 /net-wireless/ubertooth
parentnet-libs/libbtbb: drop old (diff)
downloadgentoo-192e85579ff29966aaeca626319646a5f85261f2.tar.gz
gentoo-192e85579ff29966aaeca626319646a5f85261f2.tar.bz2
gentoo-192e85579ff29966aaeca626319646a5f85261f2.zip
net-wireless/ubertooth: drop old
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless/ubertooth')
-rw-r--r--net-wireless/ubertooth/Manifest1
-rw-r--r--net-wireless/ubertooth/ubertooth-2018.12.1.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/net-wireless/ubertooth/Manifest b/net-wireless/ubertooth/Manifest
index 03ea22126d66..5c58d150391e 100644
--- a/net-wireless/ubertooth/Manifest
+++ b/net-wireless/ubertooth/Manifest
@@ -1,2 +1 @@
-DIST ubertooth-2018-12-R1.tar.xz 704208 BLAKE2B 7a17830a0ed417a737d78aa22c5a6a270a67b350a3a5e9a0aebabd4b38547d8d35551e061ea3d5260996f8fe1a366c75c8773d5e3a6abf37a0930f93200da3fc SHA512 409fdb403d6a3fa84b92757e0fd8672b1403ba3d24888fbde4d6d6923d8e0796914c20d38e2fc58909f81fcb8a0b6290bcf91282bb02354c310e6e91ad85e23b
DIST ubertooth-2020-12-R1.tar.xz 763952 BLAKE2B 592c5fa689e0f944875bd777dedfd83394ebe5c9c65c1ac2c19006a949daeda8440dc102e537cf97b4547e0730df8f47d5c2a420d84d5dc770577b6039e16b28 SHA512 f127cae09d9b20dc34ffad080871f4505cbeccc1117e0e4e841ecf4a30f578d02b67b52786d7a82bdfc43d06562919008c076f8eb9befc7e4bd95def05a3864c
diff --git a/net-wireless/ubertooth/ubertooth-2018.12.1.ebuild b/net-wireless/ubertooth/ubertooth-2018.12.1.ebuild
deleted file mode 100644
index d71069e391f4..000000000000
--- a/net-wireless/ubertooth/ubertooth-2018.12.1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit cmake udev
-
-HOMEPAGE="http://ubertooth.sourceforge.net/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+bluez static-libs +ubertooth1-firmware +udev"
-
-DEPEND="bluez? ( net-wireless/bluez:= )
- >=net-libs/libbtbb-${PV}:=[static-libs?]
- static-libs? ( dev-libs/libusb[static-libs] )
- virtual/libusb:1="
-RDEPEND="${DEPEND}
- udev? ( virtual/udev )"
-
-MY_PV=${PV/\./-}
-MY_PV=${MY_PV/./-R}
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/greatscottgadgets/ubertooth.git"
- inherit git-r3
- S="${WORKDIR}/${P}/host"
-else
- S="${WORKDIR}/${PN}-${MY_PV}/host"
- SRC_URI="https://github.com/greatscottgadgets/${PN}/releases/download/${MY_PV}/${PN}-${MY_PV}.tar.xz"
- KEYWORDS="amd64 arm x86"
-fi
-DESCRIPTION="open source wireless development platform suitable for Bluetooth experimentation"
-
-#readd firmware building, but do it right
-#USE="-fortran -mudflap -nls -openmp -multilib" crossdev --without-headers --genv 'EXTRA_ECONF="--with-mode=thumb --with-cpu=cortex-m3 --with-float=soft"' -s4 -t arm-cortexm3-eabi
-
-PATCHES=( "${FILESDIR}"/"${P}"-gcc-10.patch )
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_BLUEZ=$(usex bluez)
- -DBUILD_STATIC_LIB=$(usex static-libs)
- -DINSTALL_UDEV_RULES=$(usex udev)
- -DENABLE_PYTHON=false
- )
- if use udev; then
- mycmakeargs+=(
- -DUDEV_RULES_GROUP=usb
- -DUDEV_RULES_PATH="$(get_udevdir)/rules.d"
- )
- fi
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- insinto /usr/share/${PN}
- pushd "${WORKDIR}/${PN}-${MY_PV}" || die
- if [[ ${PV} == "9999" ]] ; then
- ewarn "Firmware isn't available for git releases, we assume you are already"
- ewarn "on the latest and/or can build your own."
- else
- use ubertooth1-firmware && newins ubertooth-one-firmware-bin/bluetooth_rxtx.dfu ${PN}-one-${PV}-bluetooth_rxtx.dfu
- use ubertooth1-firmware && newins ubertooth-one-firmware-bin/bluetooth_rx_only.dfu ${PN}-one-${PV}-bluetooth_rx_only.dfu
- fi
- popd
-
- elog "Everyone can read from the ubertooth, but to talk to it"
- elog "your user needs to be in the usb group."
-}