summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2021-02-03 09:56:30 +0000
committerTony Vroon <chainsaw@gentoo.org>2021-02-03 09:56:51 +0000
commit28f7499d2c1da25520b543dbd9716c3ac8d039de (patch)
tree75a7517262646cd4ec23e9f982795ec1ee7dcad7 /net-wireless/wireless-regdb/wireless-regdb-20201120.ebuild
parentwww-apps/nextcloud: Removed old (diff)
downloadgentoo-28f7499d2c1da25520b543dbd9716c3ac8d039de.tar.gz
gentoo-28f7499d2c1da25520b543dbd9716c3ac8d039de.tar.bz2
gentoo-28f7499d2c1da25520b543dbd9716c3ac8d039de.zip
net-wireless/wireless-regdb: Version bump to 20201120
With thanks to David Michael, this brings us in line with Fedora. This introduces the following changes compared to 20190603: Egypt (EG) * Channels 12 & 13 are allowable on 2.4GHz range * Outdoor usage of the U-NII-1 & 2A bands is not permitted Great Britain (GB) * Channel 144 on 5GHz range is allowable (5725-5730) * 5.8GHz maximum transmit power is 100mW, not 25mW * DMG band is extended to cover channels 5 & 6 (66-71GHz) Croatia (HR) * Indoor usage & higher transmit power for channels 32-50 on 5GHz * Indoor usage permitted for channels 52-68 Indonesia (ID) * Outdoor usage is not permitted Kazakhstan (KZ) * Channels 12 & 13 are allowable on 2.4GHz range * Higher transmit power for U-NII-1 band * 160MHz channels are permitted on U-NII-2C band * Indoor usage permitted for U-NII-3 band * Channels 1-4 are allowable for WiGig 802.11ad/ay Pakistan (PK) * Channels 144 & 175 are allowable on 5GHz range Russia (RU) * Channels 12 & 13 are allowable on 2.4GHz range * 160MHz channels are permitted on 5GHz * Outdoor usage is not permitted on 5GHz * Channels 1-4 are allowable for WiGig 802.11ad/ay, indoor only Singapore (SG) * U-NII-2C is now available without TPC (harmonised) * Channels 1-4 are allowable for WiGig 802.11ad/ay Taiwan (TW) * Channel 144 is allowable on 5GHz range United States (US) * Channels 12 & 13 are disabled on 2.4GHz due to unclear restrictions * Channels 32, 68 & 144 are allowable on 5GHz range Closes: https://bugs.gentoo.org/766612 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-Off-By: Tony Vroon <chainsaw@gentoo.org> Package-Manager: Portage-3.0.13, Repoman-3.0.2
Diffstat (limited to 'net-wireless/wireless-regdb/wireless-regdb-20201120.ebuild')
-rw-r--r--net-wireless/wireless-regdb/wireless-regdb-20201120.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-wireless/wireless-regdb/wireless-regdb-20201120.ebuild b/net-wireless/wireless-regdb/wireless-regdb-20201120.ebuild
new file mode 100644
index 000000000000..861834a692fc
--- /dev/null
+++ b/net-wireless/wireless-regdb/wireless-regdb-20201120.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="wireless-regdb-${PV:0:4}.${PV:4:2}.${PV:6:2}"
+DESCRIPTION="Binary regulatory database for CRDA"
+HOMEPAGE="https://wireless.kernel.org/en/developers/Regulatory"
+SRC_URI="https://www.kernel.org/pub/software/network/${PN}/${MY_P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ einfo "Recompiling regulatory.bin from db.txt would break CRDA verify. Installing unmodified binary version."
+}
+
+src_install() {
+ # This file is not ABI-specific, and crda itself always hardcodes
+ # this path. So install into a common location for all ABIs to use.
+ insinto /usr/lib/crda
+ doins regulatory.bin
+
+ insinto /etc/wireless-regdb/pubkeys
+ doins sforshee.key.pub.pem
+
+ # Linux 4.15 now complains if the firmware loader
+ # can't find these files #643520
+ insinto /lib/firmware
+ doins regulatory.db
+ doins regulatory.db.p7s
+
+ doman regulatory.bin.5
+ dodoc README db.txt
+}